none
Server 2012R2 DNS port conflict. RRS feed

  • Question

  • We recently upgraded QuickBooks Enterprise to the 2016 version. On server reboot, the QB database service fails to start due the port being in use by DNS. The port is 55368 but it may use the range 55368-55372. I found articles on reserving ports for earlier versions of Windows Server but not for 2012R2. How do I keep DNS from using this port range in Server 2012R2?
    Monday, December 28, 2015 2:40 PM

Answers

All replies

  • Have you asked intuit about this? It seems the issue should be corrected within the application.

    https://community.intuit.com/articles/1224559-system-requirements-for-quickbooks-2016-and-enterprise-solutions-16-0

     

     

     


    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows]

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.

    Monday, December 28, 2015 4:10 PM
  • As Dave already mentioned, I believe that the issue should be corrected on the application side. Meaning that if it finds that the port is already in use, it should try another one or maybe you can fix the port to use manually. More if you contact the application support.

    This posting is provided AS IS with no warranties or guarantees , and confers no rights.

    Ahmed MALEK

    My Website Link

    My Linkedin Profile

    My MVP Profile

    Monday, December 28, 2015 4:38 PM
  • You can use the netsh command to reserve the ports required by QuickBooks.  To do so:

    1. On Server 2008/2008 R2, install this Microsoft hotfix.  This is not required on Server 2012 or later.
    2. Stop any processes using the ports to be reserved.  If a process is using a port included in the range of ports to be reserved, NETSH will return the following error and the reservation will fail:

      The process cannot access the file because it is being used by another process.

    3. Use the following NETSH command to reserve the ports:

      netsh int <ipv4|ipv6> Add excludedportrange [protocol=]tcp|udp [startport=]<integer> [numberofports=]<integer> [[store=]active|persistent]


      For example, to reserve ports 55368-55372 for UDPv6, use the command:

      netsh int ipv6 add excludedportrange protocol=udp startport=55368 numberofports=5

      Notes:

      - By default port reservations are persistent across reboots
      - Ports may be reserved for either version 4 or 6 of a protocol, but not both (i.e. you cannot reserve port 60000 for both TCPv4 and TCPv6)

      See https://support.microsoft.com/en-us/kb/929851 for more information, including how to view or delete existing port reservations.
        
    • Proposed as answer by Trade of Jacks Wednesday, March 14, 2018 3:37 PM
    Monday, June 6, 2016 4:13 PM

  • Anyone know where the hotfix is now located?  the excludedportrange is not a valid option to me on Server 2012 r2. I click on the link for the hotfix, and it take you to the KB, but no hotfix found, and the microsoft download catalog doesn't have that KB hotfix in it. 

    Laura Loding ABC Computer

    Wednesday, March 14, 2018 2:53 PM

  • Anyone know where the hotfix is now located?  the excludedportrange is not a valid option to me on Server 2012 r2. I click on the link for the hotfix, and it take you to the KB, but no hotfix found, and the microsoft download catalog doesn't have that KB hotfix in it. 

    Laura Loding ABC Computer

    Please start a new thread.

     

     



    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows Server] Datacenter Management

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees, and confers no rights.

    Wednesday, March 14, 2018 3:17 PM
  • You don't need the hotfix for Server 2012 or later. Re-read my post (above) more carefully.
    Wednesday, March 14, 2018 3:37 PM
  • You don't need the hotfix for Server 2012 or later. Re-read my post (above) more carefully.

    The excludeaddressrange subcommand appears to have been removed from netsh; it no longer works.

    C:\Users\administrator>netsh int ipv4 Add excludedportrange
    The following command was not found: int ipv4 Add excludedportrange.

    On top of that, something running under netsvcs is using ports that QuickBooks needs (55373, specifically). Because it's running under netsvcs it cannot be exactly indentified.

    It is one of these:


    Image Name                     PID Services
    ========================= ======== ============================================
    svchost.exe                    992 AeLookupSvc, gpsvc, IKEEXT, iphlpsvc,
                                       LanmanServer, ProfSvc, RasMan,
                                       RemoteAccess, Schedule, SENS, SessionEnv,
                                       Winmgmt

    Monday, March 26, 2018 3:55 PM
  • DNS server is the process that takes the Quickbooks port.

    While I agree that Intuit should fix this...  A solution is needed before that can happen.

    Stop the DNS server service

    Start the QuickBooksDB28 service

    Start DNS server

    Works until reboot.

    Monday, March 4, 2019 5:08 PM