locked
Hub Transport Server RRS feed

  • Question

  • Dear All,

    I have 2 mailbox servers which are in DAG with one HUB transport server it's working fine . I have a problem with Hub transport server .If  we shutdown Hub transport server the exchange mail users they can't login to email . how can we solve this ? or can i create another one Hub transport ? or which one best for Usss.

    I am waiting .

    Regards

    Subash

    Monday, October 13, 2014 8:57 AM

Answers

  • Hi Subash,
    I suggest you install one HUB+CAS and configure CAS array to load balance your CAS servers. 
    http://blogs.technet.com/b/ucedsg/archive/2009/12/06/how-to-setup-an-exchange-2010-cas-array-to-load-balance-mapi.aspx

    CAS Array will not load balance by itself you should have a load balancer. It is an object in AD. Please read this to understand about CAS array. http://exchangeserverpro.com/exchange-server-2010-cas-array/

    If you have a load balancer it will load balance both HUB and CAS.
    if you don't have budget for load balancer you can go with DNS RoundRobin which is not an automatic failover system. Please read these. Threads discussing about DNS RoundRobin and CAS array. 
    1.https://social.technet.microsoft.com/Forums/exchange/en-US/f0f591d2-90cd-4a8b-9c42-a0e4d1304567/cas-array-and-dns-round-robin
    2.http://smtp25.blogspot.com/2012/01/exchange-2010-cas-array-simple-dns.html


    Thanks, MAS
    Please mark as helpful if you find my comment helpful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you.

    Monday, October 13, 2014 10:58 AM
  • This is the classic example of ill make a DAG and I'm covered for HA, right? Nope.

    Think about each role individually and plan HA per role.

    So you need to plan out HA for MBX and CAAS and HUB at a minimum.


    Cheers,

    Rhoderick

    Microsoft Senior Exchange PFE

    Blog: http://blogs.technet.com/rmilne  Twitter:   LinkedIn:   Facebook:   XING:

    Note: Posts are provided “AS IS” without warranty of any kind, either expressed or implied, including but not limited to the implied warranties of merchantability and/or fitness for a particular purpose.

    • Marked as answer by Suriya Subash Sunday, October 26, 2014 8:29 AM
    Monday, October 13, 2014 1:20 PM
  • Hi Subash

    I agree with MAS.

    By your state, I also suggest you install one Hub+CAS for balance.

    Not only login on email, but also send/receive email.

    I think it’s important for high available to your organization.

    If you follow my advice ,you can refer to the solution that MAS give you,

    You can refer to the following link  for balance  by hardware;

    http://www.msexchange.org/articles-tutorials/exchange-server-2010/high-availability-recovery/load-balancing-exchange-2010-client-access-servers-using-hardware-load-balancer-solution-part1.html

    Note: Microsoft is providing this information as a convenience to you. The sites are not controlled by Microsoft. Microsoft cannot make any representations regarding the quality, safety, or suitability of any software or information found there. Please make sure that you completely understand the risk before retrieving any suggestions from the above link.

    If any questions, please let us know.

    Best Regard,

    Jim Xu

    • Marked as answer by Suriya Subash Wednesday, October 15, 2014 5:06 AM
    Tuesday, October 14, 2014 9:30 AM
  • Dear All,

    Thanks for replay my task. I have installed another one server and it's have HUB+CAS( Client Access services) for load balancing purpose . For testing I made it shutdown for one of the HUB+CAS server . Then i had try to send and receive mail from client users it's say Exchange server connection it's lost . how can i solve this issue ?

    or 

    Can i install only hub transport server ? 

     

    • Marked as answer by Suriya Subash Sunday, October 26, 2014 8:29 AM
    Wednesday, October 15, 2014 5:13 AM
  • hi Subash

    Because you have install another one server and it’s have Hub and CAS ,

    You can do balance for Hub:

    http://technet.microsoft.com/en-us/library/gg476050(v=exchg.141).aspx

    You can also do balance for CAS:

    http://technet.microsoft.com/en-us/library/ff625247(v=exchg.141).aspx

    If any questions, please let me know.

    Best Regard,

    Jim Xu

    • Marked as answer by Suriya Subash Sunday, October 26, 2014 8:29 AM
    Wednesday, October 15, 2014 5:44 AM
  • Hi Suriya,
    Did you configure CAS Array?
    If yes
    Did you point the database to the CAS Array using command ?

    Get-MailboxDatabase | Set-MailboxDatabase -RpcClientAccessServer outlook.domain.com

    Do you have an A record with FQDN of your CAS array which points to your load balancing IP?
    Do you have a load balancer in place to load balance your CAS servers?

    Without these your clients  will not connect automatically to the next available CAS server in the Array.

    If  CAS array not configured.
    You will have to create one CAS array  and point your databases and load balance your CAS servers(refer links above in my previous posts)
    If you are planning to use WNLB please check this
    http://exchangeserverpro.com/how-to-install-an-exchange-server-2010-client-access-server-array/
    Create an A record FQDN of the CAS array and point to your WNLB VIP.
    FYI WNLB is not recommended by MS Exchange Team to load balance CAS servers.


    Thanks, MAS
    Please mark as helpful if you find my comment helpful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you.

    • Marked as answer by Suriya Subash Sunday, October 26, 2014 8:29 AM
    Wednesday, October 15, 2014 5:48 AM

All replies

  • Dear All,

    I have 2 mailbox servers which are in DAG with one HUB transport server it's working fine . I have a problem with Hub transport server .If  we shutdown Hub transport server the exchange mail users they can't login to email . how can we solve this ? or can i create another one Hub transport ? or which one best for Usss.

    Hi Suriya,
    Is this it holding only HUB or CAS+HUB? If It is holding CAS+HUB you need to have one more CAS server.  Your clients are connecting to CAS server except for PF. 


    Thanks, MAS
    Please mark as helpful if you find my comment helpful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you.


    • Edited by MAS- Monday, October 13, 2014 10:03 AM
    Monday, October 13, 2014 10:02 AM
  • Dear Boss,

    It's holding HUB+CAS . SO can i install another  one server for HUB ? or HUB +CAS ?

    Regards

    Subash

    Monday, October 13, 2014 10:44 AM
  • Hi Subash,
    I suggest you install one HUB+CAS and configure CAS array to load balance your CAS servers. 
    http://blogs.technet.com/b/ucedsg/archive/2009/12/06/how-to-setup-an-exchange-2010-cas-array-to-load-balance-mapi.aspx

    CAS Array will not load balance by itself you should have a load balancer. It is an object in AD. Please read this to understand about CAS array. http://exchangeserverpro.com/exchange-server-2010-cas-array/

    If you have a load balancer it will load balance both HUB and CAS.
    if you don't have budget for load balancer you can go with DNS RoundRobin which is not an automatic failover system. Please read these. Threads discussing about DNS RoundRobin and CAS array. 
    1.https://social.technet.microsoft.com/Forums/exchange/en-US/f0f591d2-90cd-4a8b-9c42-a0e4d1304567/cas-array-and-dns-round-robin
    2.http://smtp25.blogspot.com/2012/01/exchange-2010-cas-array-simple-dns.html


    Thanks, MAS
    Please mark as helpful if you find my comment helpful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you.

    Monday, October 13, 2014 10:58 AM
  • This is the classic example of ill make a DAG and I'm covered for HA, right? Nope.

    Think about each role individually and plan HA per role.

    So you need to plan out HA for MBX and CAAS and HUB at a minimum.


    Cheers,

    Rhoderick

    Microsoft Senior Exchange PFE

    Blog: http://blogs.technet.com/rmilne  Twitter:   LinkedIn:   Facebook:   XING:

    Note: Posts are provided “AS IS” without warranty of any kind, either expressed or implied, including but not limited to the implied warranties of merchantability and/or fitness for a particular purpose.

    • Marked as answer by Suriya Subash Sunday, October 26, 2014 8:29 AM
    Monday, October 13, 2014 1:20 PM
  • Hi Subash

    I agree with MAS.

    By your state, I also suggest you install one Hub+CAS for balance.

    Not only login on email, but also send/receive email.

    I think it’s important for high available to your organization.

    If you follow my advice ,you can refer to the solution that MAS give you,

    You can refer to the following link  for balance  by hardware;

    http://www.msexchange.org/articles-tutorials/exchange-server-2010/high-availability-recovery/load-balancing-exchange-2010-client-access-servers-using-hardware-load-balancer-solution-part1.html

    Note: Microsoft is providing this information as a convenience to you. The sites are not controlled by Microsoft. Microsoft cannot make any representations regarding the quality, safety, or suitability of any software or information found there. Please make sure that you completely understand the risk before retrieving any suggestions from the above link.

    If any questions, please let us know.

    Best Regard,

    Jim Xu

    • Marked as answer by Suriya Subash Wednesday, October 15, 2014 5:06 AM
    Tuesday, October 14, 2014 9:30 AM
  • Dear All,

    Thanks for replay my task. I have installed another one server and it's have HUB+CAS( Client Access services) for load balancing purpose . For testing I made it shutdown for one of the HUB+CAS server . Then i had try to send and receive mail from client users it's say Exchange server connection it's lost . how can i solve this issue ?

    or 

    Can i install only hub transport server ? 

     

    • Marked as answer by Suriya Subash Sunday, October 26, 2014 8:29 AM
    Wednesday, October 15, 2014 5:13 AM
  • hi Subash

    Because you have install another one server and it’s have Hub and CAS ,

    You can do balance for Hub:

    http://technet.microsoft.com/en-us/library/gg476050(v=exchg.141).aspx

    You can also do balance for CAS:

    http://technet.microsoft.com/en-us/library/ff625247(v=exchg.141).aspx

    If any questions, please let me know.

    Best Regard,

    Jim Xu

    • Marked as answer by Suriya Subash Sunday, October 26, 2014 8:29 AM
    Wednesday, October 15, 2014 5:44 AM
  • Hi Suriya,
    Did you configure CAS Array?
    If yes
    Did you point the database to the CAS Array using command ?

    Get-MailboxDatabase | Set-MailboxDatabase -RpcClientAccessServer outlook.domain.com

    Do you have an A record with FQDN of your CAS array which points to your load balancing IP?
    Do you have a load balancer in place to load balance your CAS servers?

    Without these your clients  will not connect automatically to the next available CAS server in the Array.

    If  CAS array not configured.
    You will have to create one CAS array  and point your databases and load balance your CAS servers(refer links above in my previous posts)
    If you are planning to use WNLB please check this
    http://exchangeserverpro.com/how-to-install-an-exchange-server-2010-client-access-server-array/
    Create an A record FQDN of the CAS array and point to your WNLB VIP.
    FYI WNLB is not recommended by MS Exchange Team to load balance CAS servers.


    Thanks, MAS
    Please mark as helpful if you find my comment helpful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you.

    • Marked as answer by Suriya Subash Sunday, October 26, 2014 8:29 AM
    Wednesday, October 15, 2014 5:48 AM
  • Dear Pavin,

    As per you Query . Yes HUB+CAS Witness server . Pls cloud you see my image of entire Exchange server  setup . If i shutdown Witness server . the client users they can't get any email and they couldn't login to there email ..

    Sunday, October 26, 2014 8:29 AM