locked
Office 2016 ProPlus - First Things First (EULA) won't go away RRS feed

  • Question

  • Hi,

    I've successfully installed Office 2016 using ODT on an W7 computer with the following config file:

    <Configuration>
    
    <Add SourcePath="\\server\TemporaryArea\O365_2016" OfficeClientEdition="32" Branch="Current">
        <Product ID="O365ProPlusRetail">
          <Language ID="en-us" />
          <Language ID="nb-no" />
          <Language ID="sv-se" />
          <Language ID="da-dk" />
        </Product>
      </Add>
    
    <Updates Enabled="TRUE" Branch="Current" />
    <Display Level="None" AcceptEULA="TRUE" />
    <Property Name="AUTOACTIVATE" Value="1" />
    
    </Configuration>

    Now, every time I open an Office Application I get prompted with the "First things first" image below. Closing the application and opening it again, makes the prompt re-appear. And it is the same with all of them!

    I've tried the following, without any luck:

    [HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Common\General]
    "shownfirstrunoptin"=dword:00000001
    
    [HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\FirstRun]
    "BootedRTM"=dword:00000001
    
    [HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Registration]
    "AcceptAllEulas"=dword:00000001

    O365 -> My Account has the installation on the computer activated, so connectivity should not be an issue...


    ./ Lars Olsen


    Friday, November 20, 2015 2:27 PM

Answers

  • Hi,

    Good news. The issue is resolved.

    As we are several administrators on the same domain, one of our other admins used a live GPO in a production OU for testing another unrelated Office issue.

    User Settings --> Administrative Templates --> Office 2016 --> Privacy --> Trust Center --> "Disable opt-in wizard on first run" was set to disabled.

    This caused the "First things first" prompt to show at every application startup.


    ./ Lars Olsen


    Monday, November 30, 2015 1:05 PM

All replies

  • Hi,

    Please try to check the following keys:

    HKCU\Software\Microsoft\Office\16.0\FirstRun\BootedRTM 1 (DWORD)

    HKCU\Software\Microsoft\Office\16.0\FirstRun\disablemovie 1 (DWORD)

    HKCU\Software\Microsoft\Office\16.0\Common\General\shownfirstrunoptin 1 (DWORD)

    HKCU\Software\Microsoft\Office\16.0\Common\General\ShownFileFmtPrompt 1 (DWORD)

    HKCU\Software\Microsoft\Office\16.0\Common\PTWatson\PTWOptIn 1 (DWORD)

    HKCU\Software\Microsoft\Office\16.0\Common\qmenable 1 (DWORD)

    Note: Backup the key before modify.

    Regards,

    George Zhao
    TechNet Community Support


    Please mark the reply as an answer if you find it is helpful.

    If you have feedback for TechNet Support, contact tnmff@microsoft.com.
    Monday, November 23, 2015 6:21 AM
  • Hi George,

    Tried this now. Still no change :(


    ./ Lars Olsen

    Monday, November 23, 2015 7:51 AM
  • Update:

    Tried with the CTR (Click-To-Run) installer from the O365 portal for Office 2016.

    Same issue, no change.

    Seems to be related to Win7, because on my own computer I'm running W10 and Office 2016 without issues.

    Tried on other W7 clients, same issue. Other W10 clients, no issue.


    ./ Lars Olsen

    Tuesday, November 24, 2015 3:15 PM
  • Hi,

    The above registry keys are all user settings. If you try and set them at the end of your installation they usually won’t work as the installation is likely to be done under an admin account. Unless you set them from a user-side login script or Group Policy then they won’t apply to each user that logs onto the machine.

    Please see this article and follow the method there:

    https://www.autoitconsulting.com/site/deployment/automating-office-365-click-run-first-use-without-group-policy/

    (It also applies to Office 2016, please change 15.0 to 16.0)

    Please Note: Since the web site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

    Regards,

    George Zhao
    TechNet Community Support


    Please mark the reply as an answer if you find it is helpful.

    If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Wednesday, November 25, 2015 1:22 AM
  • Hi George,

    I think you have misunderstood.

    I'm not looking to remove the prompt completely. It is OK to make it appear the first time... But that is not what happens. It appears every time I open an Office application, even after pressing "Accept".

    And, I do not set the registery settings with the admin user. I log on as the normal user, open regedit and add them manually to HKCU.

    With that said, I have now also tried with the script from the article you linked to. Just so this would not go un-tested. (64bit OS + 32bit Office, is also my setup so I just copy-pasted the script to my own installation and edited from 15 to 16) No success here either, but the keys were successfully created and it did remove the "Default File Types" prompt.

    And again, the issue is only present on W7 clients.


    ./ Lars Olsen


    Wednesday, November 25, 2015 8:24 AM
  • Hi  Lars Olsen,

    I know your situation that you have encountered now. I want to test this issue in Windows 7 client, it needs sometimes. If I have any update, I'll reply in this thread.

    Regards,

    George Zhao
    TechNet Community Support


    Please mark the reply as an answer if you find it is helpful.

    If you have feedback for TechNet Support, contact tnmff@microsoft.com.
    • Proposed as answer by JC Moriaud Tuesday, September 12, 2017 7:13 AM
    Thursday, November 26, 2015 2:49 AM
  • Hi,

    Good news. The issue is resolved.

    As we are several administrators on the same domain, one of our other admins used a live GPO in a production OU for testing another unrelated Office issue.

    User Settings --> Administrative Templates --> Office 2016 --> Privacy --> Trust Center --> "Disable opt-in wizard on first run" was set to disabled.

    This caused the "First things first" prompt to show at every application startup.


    ./ Lars Olsen


    Monday, November 30, 2015 1:05 PM
  • Lars, thanks for finding that policy. It was a needle in a haystack of needles.

    However, I don't see how it was related to the behavior that you saw of repeated prompts, as it's only supposed to pertain to the "first time they run a Microsoft Office 2016 application."

    Also, that it was set to Disabled is not important since "If you disable or do not configure this policy setting, the Opt-in Wizard displays the first time users run a Microsoft Office 2016."

    We enabled it so that users will never see the prompt, as we handle updates elsewhere regardless of the user. It's most curious that this prompt comes up at all in a VL MSI installation--it has much more of a C2R feel to it.

    Anyway, glad that enabling it let you workaround what sounds like a bug.

    Friday, December 25, 2015 11:15 PM
  • I fixed it with the following

    Hive HKEY_CURRENT_USER
    Key path Software\Microsoft\Office\16.0\Registration
    Value name AcceptAllEulas
    Value type REG_DWORD
    Value data 0x1 (1)

    This is tested on 2016 C2R and not on 2013 C2R.

    --

    Alex

    • Proposed as answer by Sausage 360 Friday, May 27, 2016 5:17 PM
    Monday, February 1, 2016 1:37 PM
  • This works a treat, I was looking everywhere for this setting. Thank you.
    Wednesday, April 6, 2016 4:02 AM
  • Thank you, this worked great utilizing AppSense in Non-persistent Citrix Desktops and Servers!!

    We were capturing all the hostnames in that Registration location, now it just doesn't bother asking users anymore.

    Friday, May 27, 2016 5:17 PM
  • Thanks that registration key did the trick... for some reason the 'disable opt in wizard' GPO was not working for me!
    Monday, January 9, 2017 1:43 AM
  • This wasn't working for me, but AcceptAllEulas DWORD=1 under Software\Policies\Microsoft\Office\16.0\Registration did.

    Thank you to: http://svenhuisman.com/2015/02/how-to-configure-office-365-pro-in-a-non-persistent-vdi-environment/

    Friday, February 3, 2017 9:42 AM
  • I fixed it with the following

    Hive HKEY_CURRENT_USER
    Key path Software\Microsoft\Office\16.0\Registration
    Value name AcceptAllEulas
    Value type REG_DWORD
    Value data 0x1 (1)

    This is tested on 2016 C2R and not on 2013 C2R.

    --

    Alex


    Gotcha with this, thanks! First opt was enabled already, wasn´t enough.

    Please remember to mark my post as an answer, if I really helped you out, or vote if usefull. Thank you!

    Monday, March 27, 2017 8:04 AM
  • Works a treat - thanks for posting. 
    Tuesday, October 17, 2017 10:07 AM