none
This form cannot be opened in a Web browser. To open this form, use Microsoft InfoPath

    Question

  • After publishing an InfoPath form without code, This is the error I get while trying to open it. (This form cannot be opened in a Web browser. To open this form, use Microsoft InfoPath)

    I checked all necessary setting like:

    clicking in web browser, activating enterprise features on central admin, site collection features, checked the form and it was web browser enabled, used powershell to activate allow userform browser rendering and I also clicked on central admin.

    Please is there anyother thing I need to do to make it work. it is sharepoint 2010 enterprise. Thanks.

    Friday, October 11, 2013 9:28 AM

All replies

  • Ensure you have the "SharePoint Server Enterprise Site Collection features" feature activated in your site collection features for the site collection.

    After this you will need to re-publish, checking the "Enable this form to be filled out by using a browser" checkbox.

    I hope you have already followed the below steps :

    When you are creating a Infopath form make sure you tick the Enable browser enabled features only at the time when you are creating a new infopath form. Make sure that your form is browser enabled (Tools -> Form Options -> Compatibility) in InfoPath. The "Design a form that can be opened in the browser" is checked and selected. After designing your form publish it in your Sharepoint Forms Library.

    After that follow this step:
    1. Go to the Form Library to which you published the InfoPath form template.
    2. Click Settings on the Form Library menu bar and choose Form Library Settings from the drop-down menu.
    3. On the Customize <Form Library Name> page under the General Settings category, click Advanced settings .
    4. On the Form Library Advanced Settings: <Form Library Name> page under the Browser-enabled Documents category, choose Display as a Web page .
    from the Central Administration also make sure to enable this feature.

    To enable this setting:

    1. Open SharePoint Central Administration .
    2. Click the Application Management tab.
    3. On the Application Management page under the InfoPath Forms Services category, click Configure InfoPath Forms Services .
    4. On the Configure InfoPath Forms Services page under the User Browser-enabled Form Templates category, check Render form templates that are browser-enabled by users .
    • Proposed as answer by Rahul Bhalla Friday, October 11, 2013 10:05 AM
    Friday, October 11, 2013 10:03 AM
  • Hi Charles,

    I had a similar error to you when I was setting up a workflow in a site with restricted permissions. Does this sound like your example?

    If the people updating your tasks do not have contribute permissions at the site level then you might have to go and set permissions explicitly on the workflow files (particularly the .xsn files).

    They are not visible via the browser interface, but you can find them via All files in SharePoint Designer, Workflows folder, select, and choose permissions, this ensures that your Task approvers can access the xsn files (Read access should be sufficient).

    My error was to develop this workflow in a secure site and try and allow people in to update the tasks and Documents library. A better model would have been to create the workflow, tasks and document library in a separate site, that way the permissions errors would not occur.

    Hope this helps!
    (If it does help you, can you mark this as an answer so others find it? )


    Ruth, UK

    Friday, February 14, 2014 6:07 PM
  • Please confirm that you have given "Read Only/View Only" rights on site to users who will be updating/approving the tasks. Best of luck :)
    Tuesday, March 18, 2014 12:57 PM
  • I spent hours on this and just got lucky...for some reason, when I published my form, it remained "checked out" so only I could open it in a browser.  Once I checked it in, everyone was able to.

    Something so easy took forever to find....

    Friday, July 11, 2014 4:02 PM