none
Drive mapping - extended error

    Question

  • Error message:

    The mapped network drive could not be created because the following error has occurred: An extended error has occurred.

    Things I have checked:

    AD account

    Time/date on server and local machine

    User account can map them successfully on other PCs

    Only a problem when using the fully qualified path to the server. Mapping by IP address works.

    Flushed and re-populated DNS cache

    Rebooted multiple times

    Logon script that normally maps drives is correct


    Any ideas?

    Thanks,

    -Tom
    Tuesday, March 27, 2012 3:11 PM

Answers

All replies

  • 1. What you get when you issue

    net use * \\server\share

    2. Would you catch the network traffic by network monitor....

    3. Are there any traces in Event logs?

    Regards

    Milos

    Tuesday, March 27, 2012 6:39 PM
  • Hi,

    What the error code or message you get in your issue?  Is there some event logs related to the issue?
    You may run “net use” command.  For example:
    To assign the disk-drive device name E: to the Letters shared directory on the \\Financial server, type:
    net use e: \\financial\letters
    Meanwhile, please open an elevated command and refresh DNS and reset Winsock.
    >ipconfig /flushdns
    >netsh winsock reset

    Net Use command
    http://technet.microsoft.com/en-us/library/bb490717.aspx

    I suggest you post the error code or event logs in the forum.

    Thursday, March 29, 2012 8:43 AM
  • Error message:

    The mapped network drive could not be created because the following error has occurred: An extended error has occurred.

    Ivan-Liu:

    That is the error message, word for word. It's not very helpful, is it. No code or description or anything. No event log that I can find (weird). Like I said, I already tried to flush DNS. Just tried to reset winsock and it didn't change anything, either. Net use produces the exact same results as mapping through windows explorer.

    Unfortunately I'm going to have to call this issue closed, it was the CEO's PC and he just got fed up and had us buy him a new one. He needed it anyways, the computer was pretty old and slow. Thanks for the help.

    Tuesday, April 3, 2012 5:19 PM
  • Hi!

    This solved the problem for me:

    http://support.microsoft.com/kb/2686098

    (When I did net use \\server\share I got this error: System error 2148073478 has occurred.)

    -Klaus

    • Proposed as answer by audiocircuit Saturday, September 1, 2012 2:49 AM
    Monday, June 4, 2012 4:19 AM
  • Worked perfect for me.  Thanks!
    Saturday, September 1, 2012 2:49 AM
  • Yes this worked perfectly for me

    Thanks

    Monday, March 18, 2013 6:36 PM
  • This fixed it for me.  

    For some reason, a user suddenly cannot use the "NET USE" command to map network drives. Windows logon is working, but accessing network shares become very strange, with "System Error 2221 has occurred" message. This probably is a stored credential problem.  I also got error when trying to use a UNC path with the DNS name "\\Server1\Share1'  but it will work if you use an IP based path "\\192.168.0.123\share1"

    SOLUTION: Press your Windows' Start / Launch, in "Search programs and files" field type "Credential Manager" and you should see it shows up on the list. Run it.

    Check the stored credentials and remove related credentials, by click on the "Remove from vault". Now, try your NET USE command to map drives again.

    • Proposed as answer by jcgorrin Monday, March 24, 2014 2:17 PM
    Monday, August 26, 2013 6:39 PM
  • Thanks !! The winsock reset worked fine for me! Great
    Tuesday, December 10, 2013 12:36 PM
  • Removing the credential in Credential Manager worked for me, thanks!  The user had changed it somehow. 
    Thursday, January 2, 2014 3:26 PM
  • This worked instantly - many thanks!  I have been waiting for a week for my IT function to resolve, glad I founf this answer via Google in 5 mins, wish I'd done it earlier. 
    Tuesday, May 6, 2014 11:01 AM
  • I had this same annoyingly unhelpful popup "An extended error has occurred."   

    I opened a command window and typed:

    > net use x: \\server\sharedrive

    and received a more detailed error message.  Including the guidance that the user account (in a different domain) had expired.  After changing the account expiration it worked fine.

    Monday, January 19, 2015 4:31 PM
  • This fixed my issue as well.

    I had typed the wrong password to the shared drive and selected, "Remember My Credentials" .  Every time I attempted to connect to the share drive, I would get the error, "An extended error has occurred."

    Your help is greatly appreciated.

    

    Friday, April 10, 2015 8:46 PM
  • This work for me! Thanks!
    • Proposed as answer by CS2 Computers Friday, February 19, 2016 12:22 PM
    • Unproposed as answer by CS2 Computers Friday, February 19, 2016 12:22 PM
    Friday, July 31, 2015 3:25 AM
  • Old thread, but I wanted to share that I was getting the "extended error" on Windows 10 computers trying to access a file share over a Windows VPN connection. The workaround thathelped me on both computers was to create a Windows Credential for the Server. Control Panel -> Credential Manager. Each user had an account in AD on the target Server/Domain so that is what I used for the credential. 
    Friday, February 19, 2016 12:25 PM
  • Just wanted to add that when I have seen this issue, either the server does not have an WINS IP defined on the NIC, or the clients are not pointing to a server hosting a WINS database. 

    If you can access a share by IP but not \\server\share name, this is almost always a WINS issue.  Make sure your clients and servers WINS settings are configured correctly.

    Monday, August 22, 2016 5:05 PM
  • This resolved my issue. Removing the saved password from Cedential manager.
    • Edited by shoetechdue Monday, December 19, 2016 8:26 PM
    Monday, December 19, 2016 8:26 PM
  • Unfortunately, Windows 10 after the Anniversary Update no longer allows the registry edit.
    Friday, January 13, 2017 1:08 AM
  • Thank God for your advice!  I spent 2 hours troubleshooting why a domain user's profile wouldn't load completely and it came down to remote folder access.  I tired everything but never thought to check credentials manager.  I removed the entry, restarted and BAM!!  Good to go!!!  Thank you so much kind sir!  May life's karma bless you!
    Tuesday, January 23, 2018 4:55 AM
  • Removing the stored Credentials from Credential Manager worked after the I.T dept. couldn't figure it out for over a week !!!

    Thank you.

    Wednesday, June 27, 2018 8:27 AM