none
No server displayed in Configure external access domain window

    Question

  • Hello!

    Newly-installed Exch2016 CU2: I can see my Exch1 server when adding users...

    ...but not when configuring external access domain:

    No errors in logs, mail flows as expected... ???

    This did not happen on Exch2016 CU1 installed on the same box a week earlier.

    Thank you in advance,

    Michael


    • Edited by MF47 Friday, July 08, 2016 2:04 PM
    Friday, July 08, 2016 2:03 PM

Answers

All replies

  • Hi Michael,

    Welcome to our forum.

    By my test, we also have same phenomenon as you said. This issue will be reported to production group (PG). we will update this thread if there are any updates.

    Best Regard,

    Jim Xu

    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Jim Xu
    TechNet Community Support

    Monday, July 11, 2016 4:48 AM
    Moderator
  • Hi jim-xu,

    Thank you for the help!

    Regards,

    Michael

    Monday, July 11, 2016 8:32 AM
  • We have the same problem. Outlook users are unable to connect. (Outlook Web Access works as expected)
    Monday, July 18, 2016 10:32 AM
  • ...but in my case both Outlook and OWA connect successfully:

    Monday, July 18, 2016 3:03 PM
  • Hi Michael,

    Thank you for your waiting.

    The issue occurs because of change in Get-ExchangeServer command of CU2. The Get-ExchangeServer cmdlet has been updated in Exchange Server 2016 Cumulative Update 2 to reflect the Exchange 2016 ServerRole definitions: Mailbox or Edge. Due to the way Remote PowerShell (RPS) works, the ServerRole definition output will be based upon the version hosting the RPS session, e.g. CU2 endpoints will report CU2 ServerRole definitions for all servers in the org.

    We could run the following script relying upon ServerRole Output looking for ClientAccess to be installed will need to look for the IsClientAccessServer property in the cmdlet output. An example follows: 

    [PS] C:\Windows\system32>$MyServer = Get-ExchangeServer <Exchange server Name>
    [PS] C:\Windows\system32>$MyServer.ServerRole
    Mailbox
    [PS] C:\Windows\system32>$MyServer.IsClientAccessServer
    True
    [PS] C:\Windows\system32>

    If above configurations are correct, we suggest you use Exchange Management Shell to configure “Configure external access domain” in Exchange 2013 CU2.

    Thank you for your understand and support again.

    Best Regard,

    Jim Xu

    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Jim Xu
    TechNet Community Support

    Tuesday, July 19, 2016 8:30 AM
    Moderator
  • Hi jim-xu,

    Thank you for the explanation!

    ...but I still don't understand what prevents the server name to appear on the aforementioned window - if MS has made the change to the Get-ExchangeServer command of CU2 why haven't they made the same change to the GUI?

    "If above configurations are correct, we suggest you use Exchange Management Shell to configure “Configure external access domain” in Exchange 2013 CU2" - you mean "this behaviour is by design" ??? No comments...

    By the way, I asked this question to MS support (in Russia) and they answered that they don't have this problem in CU2...

    Regards,

    Michael

    Tuesday, July 19, 2016 9:01 AM
  • Maybe this deserves a seperate thread, but I've found another issue with Exchange 2016 CU2. After migration from Exchange 2010 to Exchange 2016, all Outlook users were not able to connect to the Exchange 2016 server. Outlook Web App en Mobile Devices can connect successfully. I've found that the default settings on the mapi virtual directory are incorrect.

    Tuesday, July 19, 2016 10:52 AM
  • I've already started the thread on this issue:

    https://social.technet.microsoft.com/Forums/en-US/549951a6-0012-435b-8058-11797ebf5d25/mapi-over-http-in-2016-cu2?forum=Exch2016GD

    Tuesday, July 19, 2016 1:15 PM
  • And what happens if this is your very first and only Exchange 2016 server and you installed it using CU2?

    • Edited by IT_Ron Thursday, August 18, 2016 12:19 AM
    Thursday, August 18, 2016 12:05 AM
  • Nothing - I just  would have not to use Configure external access domain window and configure external access domain for each virtual directory manually...

    Regards,

    Michael

    Monday, August 22, 2016 8:51 AM
  • And what happens if this is your very first and only Exchange 2016 server and you installed it using CU2?

    I installed exchange 2016 on a fresh test environment, and found the same issue on 'configure external access domain'. About mapi authentication, it is configured by default windows authentication - ntlm and negotiate.

    Exchange version - Version 15.1 ‎(Build 466.34)‎

    Thanks

    Prabodha

    Monday, August 22, 2016 10:17 AM
  • "About mapi authentication, it is configured by default windows authentication - ntlm and negotiate." - mapi authentication did not work until I have configured it manually.
    Monday, August 22, 2016 11:21 AM
  • The same issue exists in CU3 as well. I'll write about that letter to Santa. Maybe in Christmas time this will changed.


    Sunday, October 23, 2016 7:31 AM
  • "Maybe in Christmas time this will changed." - seems Santa is the only one who can help...

    Seems MS releases any new software products as soon as they start working for a first time - it's up to their customers to find and report bugs (and even reported bugs can "live" for a very long time)...

    Sunday, October 23, 2016 2:16 PM
  • Hi Michael,


    If above configurations are correct, we suggest you use Exchange Management Shell to configure “Configure external access domain” in Exchange 2013 CU2.


    so how do we use powershell command to configure external access domain.
    Thursday, October 27, 2016 10:26 AM
  • Hi, SK I, the easiest way would be using Paul's script with ConfigureExchangeURLs.ps1.

    GUI wizard doing just Set-WebServicesVirtualDirectory,Set-OwaVirtualDirectory,Set-OabVirtualDirectory,Set-EcpVirtualDirectory,Set-PowerShellVirtualDirectory,Set-ActiveSyncVirtualDirectory, at the same time so no magic here.

    Thursday, October 27, 2016 11:29 AM
  • I have the exact same issue in CU3. Will this be fixed in next CU?
    Thursday, October 27, 2016 5:32 PM
  • Hello

    i confirm the reason found by Jim. I just wrote a small article on this issue with a workaround

    Exchange 2016 CU2 and CU3 Configure External access domain server list empty

    Rgs

    Stéphane



    • Edited by WeetA Friday, November 18, 2016 11:51 AM
    • Marked as answer by MF47 Friday, November 18, 2016 1:15 PM
    Friday, November 18, 2016 10:52 AM
  • Stéphane, thanks for sharing!
    Friday, November 18, 2016 11:48 AM
  • ...great... an Exchange user/administrator could be able to fix the issue that MS could not even in the new CU...

    Thank you very much, Stéphane!

    Regards,

    Michael

    Friday, November 18, 2016 1:15 PM
  • You're welcome.

    It's not the proper way to resolve the issue because the GUI will show Exchange 2013 Servers with Mailbox Role only.

    Setting Virtual directories for these servers will generate an error.

    It's not a big deal as Microsoft recommends Multiroles since many years now and also it's not worse than Microsoft which uses ServerPicker.aspx located in certmgmt folder (certificate) for virtual directory management :) 

    • Edited by WeetA Friday, November 18, 2016 2:16 PM
    Friday, November 18, 2016 2:12 PM
  • "It's not the proper way to resolve the issue..." - but it is the way suggested by Stéphane, MS suggested nothing :)
    Friday, November 18, 2016 2:30 PM