none
Hyperlink to Outlook 2010 public folder contact RRS feed

  • Question

  • I am trying to use a hyperlink in Internet Explorer using the Outlook Protocol (outlook://) to open a public folder contact. 

     

    I am running Window 7 64bit with Outlook 2010 connected with Exchange 2003.  This used to work in Outlook 2003 & 2007 (2007 after a registry change converted below for Office 2010).  After changing a few keys in the registry I am able to open a specific public folder but not the actual items in the public folders.

     

    I tried replacing the users name with then Entity ID with no luck.  Does anyone know if there is some special syntax to get this to work in Outlook 2010?

     

    Example:   (Note: URL Encoding these values does NOT solve the problem)

    - “outlook://public folders - user@domain.com/All Public Folders/Contacts Public” – will open the public folder

     - “outlook://public folders - user@domain.com/All Public Folders/Contacts Public/~John Smith” – will display the error message, “Cannot display the selected folder or item.”

     

    Registry Changes: (Allows opening of public folders)

    [HKEY_CLASSES_ROOT\outlook]

    "URL Protocol"=""

    @="URL:Outlook Folders"

     

    [HKEY_CLASSES_ROOT\outlook\DefaultIcon]

    @="C:\\Program Files (x86)\\Microsoft Office\\Office14\\OUTLOOK.EXE

     

    [HKEY_CLASSES_ROOT\outlook\shell]

    @="open"

     

    [HKEY_CLASSES_ROOT\outlook\shell\open]

    @=""

     

    [HKEY_CLASSES_ROOT\outlook\shell\open\command]

    @="\"C:\\Program Files (x86)\\Microsoft Office\\Office14\\OUTLOOK.EXE\" /select \"%1\""

    Thursday, September 30, 2010 8:22 PM

Answers

  • Hi Dave,

    Thanks for posting this discovery.

    As you already mentioned, the URL: Outlook Folders association was left out starting with Outlook 2007. After employing the reg settings on the client machine, you could gain the URL Protocol functionality fully back with Outlook 2007.

    With Outlook 2010, the reg hack ONLY seems to NOT allow URL: Outlook Folders to open a Public Folder.

    For testing, I added a second Exchange Account to my Outlook 2010 profile. After switching the registry keys to point to my Office14 folder, I can open any Outlook folder in my primary Exchange Account and my secondary.

    Outlook://Contacts   ' my default Contacts folder

     

    Outlook://jahawk2@larrymei2k7.net/Contacts   ' the Contacts folder in my second Exchange account's mailbox.

     

    No method that I can find to allow the URL Protocol to access an Exchange Public Folder in Outlook 2010.

     

    Not finding any reported issues on my side that confirms\denies the Outlook 2007 reg hack will not work (completely) with Outlook 2010.

     

     

    So, I would suggest calling in and opening a Microsoft Outlook 2010 support incident on this. That will give Microsoft's Outlook team the opportunity to document and test this out. The goal being to find out "Why, the registry settings will not allow Outlook 2010 to open a Public Folder?" and "Is it possible to get this functionality back, in Outlook 2010?"

     

     

    Lastly, I used the following links to help set up this repro on my machines. -Outlook 2007\Outlook 2010 on Win 7 64-bit machines.

    http://www.slipstick.com/outlook/ol2007/outlookprotocol.asp 

    You can download the reg file and a doc walking you through its creation from this link on the page -->  Registering Outlook 2007 to a URL Protocol.zip

     

    Thanks again, Dave!

    Jahawk MSFT

    Wednesday, October 6, 2010 6:08 PM
    Moderator

All replies

  • Hi Dave,

    Thanks for posting this discovery.

    As you already mentioned, the URL: Outlook Folders association was left out starting with Outlook 2007. After employing the reg settings on the client machine, you could gain the URL Protocol functionality fully back with Outlook 2007.

    With Outlook 2010, the reg hack ONLY seems to NOT allow URL: Outlook Folders to open a Public Folder.

    For testing, I added a second Exchange Account to my Outlook 2010 profile. After switching the registry keys to point to my Office14 folder, I can open any Outlook folder in my primary Exchange Account and my secondary.

    Outlook://Contacts   ' my default Contacts folder

     

    Outlook://jahawk2@larrymei2k7.net/Contacts   ' the Contacts folder in my second Exchange account's mailbox.

     

    No method that I can find to allow the URL Protocol to access an Exchange Public Folder in Outlook 2010.

     

    Not finding any reported issues on my side that confirms\denies the Outlook 2007 reg hack will not work (completely) with Outlook 2010.

     

     

    So, I would suggest calling in and opening a Microsoft Outlook 2010 support incident on this. That will give Microsoft's Outlook team the opportunity to document and test this out. The goal being to find out "Why, the registry settings will not allow Outlook 2010 to open a Public Folder?" and "Is it possible to get this functionality back, in Outlook 2010?"

     

     

    Lastly, I used the following links to help set up this repro on my machines. -Outlook 2007\Outlook 2010 on Win 7 64-bit machines.

    http://www.slipstick.com/outlook/ol2007/outlookprotocol.asp 

    You can download the reg file and a doc walking you through its creation from this link on the page -->  Registering Outlook 2007 to a URL Protocol.zip

     

    Thanks again, Dave!

    Jahawk MSFT

    Wednesday, October 6, 2010 6:08 PM
    Moderator
  •  

    I discovered a work around of sorts.  If you want to paste a link to a Outlook 2010 contact into OneNote:

    1. In outlook, with the contact open, click on "One Note" (under "Forward") on the Home tab.  This will allow you to paste info about the contact including a link to the outlook entry.  This link is a special link that OneNote will not let you edit.  However, …
    2. Click on the special link and make a copy of it to the clip board.
    3. Paste the clip board into notepad
    4. In Notepad you will see something like: "onenote:outlook?folder=Contacts&entryid=00000000626947C29CB9D011920300400530DD34A4562003"
    1. This string can be used as the "Address" part of a standard link definition in OneNote.
    2. Also note that the GUID included in the link produced above is the same GUID reported by Linker for Windows so you can use LfW to capture the GUID and prepend the GUID with "onenote:outlook?folder=Contacts&entryid=" to create the link Address. 
    3. Use this Address in a standard definition of an arbitrary link.
    Tuesday, November 16, 2010 1:46 PM
  • Hi Dave,

    Did you ever get this issue resolved?

    Did you chase it up with Microsoft?

    I've just started setting up my first Windows 7/Office 2010 machine (WS 2008 R2/Exchange 2010) and have come across this problem for the first time. I rely very heavily on being able to create hyperlinks to Public Folder items and this would be a major problem for me.

    Thanks,

    Gary

     

    Thursday, February 10, 2011 9:40 AM
  • I opened a case with Microsoft. Here's the answer that I got...

    For Outlook 2010, there is no solution.

     "Access is denied" error when you click an "outlook:\\" link to a public folder in Outlook 2010 http://support.microsoft.com/KB/2470828

     Cause:

    Support for multiple Microsoft Exchange accounts in a single profile was added to Outlook 2010. With the introduction of this feature, each Exchange account is distinguished from others because the mailbox user's SMTP address is included in the Mailbox and Public Folder store names. The inclusion of this additional data in the folder structure prevents the "outlook:\\" protocol link from using the correct store/folder path. See the "More Information" section for an example.


    Friday, February 18, 2011 3:10 PM
  • Hi Matt,

    I have a similar problem here. How have you - if you have - finally solved the problem when you have different users (= user smtp adresses) and want to use one single link for all people?


    Viele Grüße Dirk
    Monday, March 28, 2011 8:43 AM
  • Hi Matt,

    I have a similar problem here. How have you - if you have - finally solved the problem when you have different users (= user smtp adresses) and want to use one single link for all people?


    Viele Grüße Dirk


    Hi Dirk,

    The following solution/shortcut worked for us on our workstations:

    "C:\Program Files (x86)\Microsoft Office\Office14\OUTLOOK.EXE" /recycle /select "outlook://Public Folders - %username%@CompanyName.com/All Public Folders/CompanyName Information/CompanyName Phone List"

     

    • Proposed as answer by Casamyr Friday, April 29, 2011 12:16 AM
    Tuesday, April 26, 2011 9:32 PM