none
Site Collection permissions only work for admins

    Question

  • I have a strange problem that happened to me only with this specific site collection.

    I am a Site Collection administrator and I added users to specific groups like 'Site Collection Members'- edit, 'Site Collection Visitors'- read etc.

    Then I made sure that libraries like 'Site Pages', 'Style Library' etc. are all inheriting permission from root (as above).

    When I 'Check Permissions', ale the users I want to access the page have either edit, read or contribute rights to the pages and libraries. This is what I normally do on any other site collections and it always works.

    When the user with permissions browses in to the root site page, they get "Sorry, you do not have access to that page". If they request their access via the web page, I (admin) get an e-mail that the user wants to access "Site Pages". But I already gave them edit access to 'Site Pages'. I (admin) use a SharePoint form to assign the permissions again in 'Access requests' so the troubled user gets a confirmation e-mail with the link to the site. It still does not work.

    Users can only see the page when I add them as Site Collection admins. What is the problem??????? 

    Thursday, October 2, 2014 8:47 AM

Answers

  • Did you modify the site collection root site's Style Library permissions?

    Those, and a few others, should have unique permissions and should not inherit the site perms. This is by design to ensure that users who may not have access to that site have access to CSS, master pages etc. that are used by child sites.


    Thursday, October 2, 2014 11:56 AM
  • Hi, I was using a publishing site.

    the quickest resolution in my case was to save all lists and libraries with the users' content as templates, delete this site collection and re-create it again restoring the lib's. All works fine now.

    Another strange glitch with SP2013.

    Thursday, October 2, 2014 11:58 AM
  • Hi Lukas,

    Your quick work around is fine for the sites which contains small set of data.Suppose a site which has huge amount of data ,this option will not work.

    So this is purely a permission issue.Either on master page gallery or style library someone has broke the permission.

    Regards

    Thursday, October 2, 2014 1:34 PM

All replies

  • I've seen this very behaviour within a SharePoint 2007 deployment recently.  It only seems to happen within system generated pages. 

    Can you try a quick test or two; -

    1. Create a Doc Library with your Admin account and move a copy (not the original) the offending page into this library.  Test
    2. Recreate the page in this doc library and see if it's happening still

    Can you also advise if you're using a publishing site too?


    Steven Andrews
    SharePoint Business Analyst: LiveNation Entertainment
    Blog: baron72.wordpress.com
    Twitter: Follow @backpackerd00d
    My Wiki Articles: CodePlex Corner Series
    Please remember to mark your question as "answered" if this solves (or helps) your problem.

    Thursday, October 2, 2014 10:47 AM
    Answerer
  • Did you modify the site collection root site's Style Library permissions?

    Those, and a few others, should have unique permissions and should not inherit the site perms. This is by design to ensure that users who may not have access to that site have access to CSS, master pages etc. that are used by child sites.


    Thursday, October 2, 2014 11:56 AM
  • Hi, I was using a publishing site.

    the quickest resolution in my case was to save all lists and libraries with the users' content as templates, delete this site collection and re-create it again restoring the lib's. All works fine now.

    Another strange glitch with SP2013.

    Thursday, October 2, 2014 11:58 AM
  • Hi Lukas,

    Your quick work around is fine for the sites which contains small set of data.Suppose a site which has huge amount of data ,this option will not work.

    So this is purely a permission issue.Either on master page gallery or style library someone has broke the permission.

    Regards

    Thursday, October 2, 2014 1:34 PM