none
unable to desactived the SMB V1 protocole RRS feed

  • Question

  • Hello,

    I want o use only SMB V2 or higher protocol for sharing folder on my windows 7 professional with Windows 10 machines

    i have modified the key SMB1 to zero on the right registry key : HKLM:\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters

    I  have also run

    sc.exe config mrxsmb10 start= disabled

    with success

    BUT

    sc.exe qc lanmanworkstation shows still SMB10 & SMB20

    which make my acces to the sahre files impossible from my windows 10 machines...

    so how to sove this problem?

    Wednesday, October 30, 2019 2:45 PM

All replies

  • Hi,

    >>I have also run sc.exe config mrxsmb10 start= disabled with success.

    Which server did you run this command? Windows 7 or Windows 10?

    If on windows 10, you should also disable SMB1.0 on windows 7, and you need to enable SMB2.0 on windows 7.

    >>i have modified the key SMB1 to zero on the right registry key: HKLM:\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters,

    Did you restart the computer after you make these changes?

    If not, please restart your computer after you configure the registry key.

    Please refer the following auricle about disable and enable SMB:

    How to detect, enable and disable SMBv1, SMBv2, and SMBv3 in Windows and Windows Server

    Hope this can help you, if you have anything unclear, please let me know.

    Best Regards,

    Ellen


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Thursday, October 31, 2019 7:12 AM
  • Hi,

    Just checking in to see if the information provided was helpful.

    Please let us know if you would like further assistance.

    Best Regards,

    Ellen


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.




    Monday, November 4, 2019 2:34 AM
  • Hi,

    As this thread has been quiet for a while, we will propose it as ‘Answered’ as the information provided should be helpful.

    If you need further help, please feel free to reply this post directly so we will be notified to follow it up. You can also choose to unmark the answer as you wish.

    Best regards,

    Ellen

    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Tuesday, November 5, 2019 1:48 AM
  • Hi,

    >>I have also run sc.exe config mrxsmb10 start= disabled with success.

    Which server did you run this command? Windows 7 or Windows 10?

    it was on my Windows 7 server

    If on windows 10, you should also disable SMB1.0 on windows 7, and you need to enable SMB2.0 on windows 7.

    >>i have modified the key SMB1 to zero on the right registry key: HKLM:\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters,

    Did you restart the computer after you make these changes?

    If not, please restart your computer after you configure the registry key.

    Yes several times.. without any success!

    Please refer the following auricle about disable and enable SMB:

    How to detect, enable and disable SMBv1, SMBv2, and SMBv3 in Windows and Windows Server

    Hope this can help you, if you have anything unclear, please let me know.

    Best Regards,

    Ellen

    in conclusion,I have tried  all these classical solutions described in this article without a correct answer : smbV1 is still active..


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.



    Tuesday, November 12, 2019 10:56 AM
  • hello,

    HELP : nobody can help me to find a solution???

    Tuesday, November 19, 2019 9:20 AM