none
Exchange 2016 with 2010 RRS feed

  • Question

  • Hey,

    I have just installed Exchange 2016 with 2010 co existence however when I try to login to a 2010 mailbox from 2016 OWA I get an error message with CafeError=CAS14WithNoWIA in the URL.

    I have googled but I can't find anything about what this means does anyone have any idea?

    Also I have checked the event logs but I can't find any relevant errors etc

    Thanks in advance

    Friday, May 20, 2016 1:44 PM

Answers

  • Just in case anyone comes across this in the future and is having the same issue it turned out that Integrated Windows Authentication was not enable on the OWA and ECP sites in Exchange 2010 therefore the pass though authentication wasn't working. As soon as I disabled Forms Auth and Enables Integrated Windows Authentication it worked like a charm.
    • Marked as answer by MartinP86 Saturday, June 4, 2016 1:13 PM
    Saturday, June 4, 2016 1:13 PM

All replies

  • What Service Pack and Rollup Update is installed on Exchange 2010?

    Regards, Konrad Sagala, Office Servers & Services MVP, MCT, MCSE-M, MCITP: Exchange 2007/2010, Lync 2010, Office365, Windows 2008, Virtualization

    Friday, May 20, 2016 7:19 PM
  • Hi,

    We can deploy Exchange 2010 and Exchange 2016 co-existence environment, and OWA request will proxy to legacy server if the mailbox exist in Exchange 2010 server.

    For your question, I want to confirm:
    1. How about login Exchange 2010 mailbox with 2010 OWA URL?
    2. Is there any relevant error message in Event log?
    3. Whether all Exchange services works in each server?

    Please run below command to check the status of Exchange server component, especially OwaProxy and EcpProxy:
    Get-ServerComponentstate -Identity “servername”

    If the state is Inactive, please run below command to active relevant component:
    Set-ServerComponentState <Identity> -Component “component name” -Requester HealthAPI -State Active


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Allen Wang
    TechNet Community Support

    Monday, May 23, 2016 8:47 AM
    Moderator
  • Just in case anyone comes across this in the future and is having the same issue it turned out that Integrated Windows Authentication was not enable on the OWA and ECP sites in Exchange 2010 therefore the pass though authentication wasn't working. As soon as I disabled Forms Auth and Enables Integrated Windows Authentication it worked like a charm.
    • Marked as answer by MartinP86 Saturday, June 4, 2016 1:13 PM
    Saturday, June 4, 2016 1:13 PM
  • Had the same problem and solved it this way - enabling Integrated Windows Auth.
    Wednesday, June 8, 2016 12:38 PM
  • I had exactly the same issue, but wasn´t sure what to change (Set-OwaVirtualDirectory with WindowsAuthentication did the trick). But found the following URL here, which mentioned the needed powershell commands. By the way, the posting here seamed to be the same issue.
    • Proposed as answer by Bastian_W Friday, July 15, 2016 7:29 PM
    • Edited by Bastian_W Friday, July 15, 2016 7:31 PM
    • Unproposed as answer by Bastian_W Friday, July 15, 2016 7:31 PM
    Friday, July 15, 2016 7:29 PM