Access 2010 Issues with multivalued lists in forms


  • I am using Access 2010 and am encountering a problem when I am trying to use two multivalued lists in my table and entering them from an auto generated form.  When I enter the values and click OK on the form, the values are not accepted.  Nothing appears to happen when I click the OK button.  If I go to another record and come back to this one, the values I tried to enter into the multivalued list aren't there.  This is happening in a database that has been split (e.g. a front end and a back end)

    Steps to duplicate the problem:

    Create a new database in Access (File, new, blank database)

    Click the save button to save the default table (the default name Table1 is fine)

    Save the database to your desktop (File, Save Database As, choose desktop and choose a file name)

    Split the database (Database tools, Move Data, Access Database - has a picture of the middle one being split into 2, then follow the prompts, creating a backend and a front end).

    Close Access

    Open up the back end (_be) file, and add two look up fields to Table1 as follows:

        - Open up Table 1

        - Click to Add

        - Lookup & Relationship

        - Select: I will type in the values I want, next

        - Enter the values A, B, and C as separate lines under Col1, Next

        - Set the name to Letters, and check the box to "Allow Multiple Values", Finish

        - Click to Add

        - Lookup & Relationship

        - Select: I will type in the values I want, next

        - Enter the values 1, 2, and 3 as separate lines under Col 1, Next

        - Name this Numbers, check "Allow Multiple Values", Finish

    Close Access

    Open the front end file (the one you saved at first, without the _be)

    Select Table1

    Create, Form

    Under View, click the form view to use the new form

    Try to enter values for the letters and numbers fields, then press OK

    Bug / Issue:

    For me, at this point, it does not let me enter the values, and this is the bug / issue I am trying to work around.  I want to be able to enter the values when I press OK.

    Other things I tried:

    - The multivalue attributes work fine when entering directly from the table, but not from the front end form.

    - If you add other (non-multivalue fields) to the table in the back end, then create a new form in the front end, the new fields work, but the multivalue fields still don't work.


    • Edited by J Copeland Wednesday, April 10, 2013 11:33 AM Clarification, it appears bold does not work, so I spaced the sections out.
    Tuesday, April 09, 2013 8:32 PM

All replies

  • Hi,

    I have verified this behavior, and I am trying to involve someone familiar with this topic to further look at this issue.

    Max Meng
    TechNet Community Support

    Thursday, April 11, 2013 9:51 AM