none
“Download a copy” shrinks downloaded file name RRS feed

  • Question

  • I'm using SharePoint Server 2013 with Russian language pack.

    When in a document library, I choose "Download a copy" menu item in ECB on a file, and SharePoint 2013 downloads a file correctly (it can be opened and the file content is OK), but the file name is trimmed on the local hard disk: downloaded file name is only a couple of first words long, but in a document library the file name is much longer.

    It happens only on files that have names in Russian (cyrillic characters). Files that consist of English characters are downloaded with correct names as they appear in a SharePoint document library. So, it seems not to be connected to a URL length restrictions.


    v

    Wednesday, April 29, 2015 9:17 AM

Answers

  • Consider opening a PSS case on this. It does sound like a bug.

    Trevor Seward

    Follow or contact me at...

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Wednesday, April 29, 2015 1:38 PM
    Moderator

All replies

  • I'm using SharePoint Server 2013 with Russian language pack.

    When in a document library, I choose "Download a copy" menu item in ECB on a file, and SharePoint 2013 downloads a file correctly (it can be opened and the file content is OK), but the file name is trimmed on the local hard disk: downloaded file name is only a couple of first words long, but in a document library the file name is much longer.

    It happens only on files that have names in Russian (cyrillic characters). Files that consist of English characters are downloaded with correct names as they appear in a SharePoint document library. So, it seems not to be connected to a URL length restrictions.


    v



    • Edited by Vadim Maximov Wednesday, April 29, 2015 9:16 AM
    • Merged by Rebecca Tu Friday, May 1, 2015 8:42 AM duplicated
    Wednesday, April 29, 2015 9:12 AM
  • Consider opening a PSS case on this. It does sound like a bug.

    Trevor Seward

    Follow or contact me at...

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Wednesday, April 29, 2015 1:38 PM
    Moderator
  • I've contacted MS support and they told me it was a known problem. But the date a hotfix will be ready on is unknown.

    v

    Thursday, May 21, 2015 12:23 PM