none
Drag and drop within Document Sets Drop Here in odd location RRS feed

  • Question

  • So we recently upgraded to Sharepoint2016.  We have noticed that they replaced the 'upload multiple files' to be able to drag and drop right into the library or document set you are actively in, which sounds great on the surface.  However, at least for document sets, dragging and dropping into the files area of the document set does not work.  After some confusion, we realized you had to actually scroll all the way down below the file area (where it says drag files to upload) to find the box that says 'Drop Here'. Is there something I can do to make this more user friendly?
    Friday, January 5, 2018 3:23 PM

Answers

  • Try this..

    1- Open your document set

    2- Edit page

    3- Delete the "Document set Contents" WebPart

    4- Add new "Document set Contents" WebPart

    5- set WebPart "frame style" to none (not sure if required)

    • Marked as answer by spi_shane Monday, July 9, 2018 5:11 PM
    Monday, July 9, 2018 4:10 PM

All replies

  • You can drag documents right over the top of existing documents. Works fine in Edge/Chrome/FF/IE11.

    Trevor Seward

    Office Servers and Services MVP



    Author, Deploying SharePoint 2016

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Friday, January 5, 2018 3:49 PM
    Moderator
  • Existing documents is not the issue.  The Issue is where the 'Drop Here' message appears within the browser.   We have tried both IE11 as well as Edge both having this issue.  The 'Drag here' message is at the top where I show the file.  The 'Drop Here' message appears at the bottom of the screen and the file will only upload if you put the file there.  If you don't have the browser maximized or are not at the bottom of the website, you will not see the drop-here message, and is very annoying and un-intuitive.  Thus why I'm seeing if there is a solution to this issue.

    Friday, January 5, 2018 4:12 PM
  • I can't reproduce that behavior. Drop appears within the panel of existing files, not below them. This is with the Dec 2017 PU.

    Trevor Seward

    Office Servers and Services MVP



    Author, Deploying SharePoint 2016

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    • Proposed as answer by Carl__Zhou Thursday, February 1, 2018 3:10 AM
    Friday, January 5, 2018 4:15 PM
    Moderator
  • Sometimes this could be your custom CSS or JavaScript on the page which moves some of the features weirdly like this. Create a new site with default masterpage & CSS and test this.

    ViviSP

    Friday, January 5, 2018 9:20 PM
  • Hi ViviSP, thanks for the suggestion. 

    We are using the Seattle master page and the setting 'Use default styles and any CSS files associated with your Master Page'. 


    • Edited by spi_shane Friday, January 5, 2018 9:30 PM
    Friday, January 5, 2018 9:29 PM
  • Hi,

     

    If you solved this issue by yourself, you can share the solution and mark it as answer to help other community members to find the information quickly.

    Have a nice day!

     

    Best Regards,

    Carl Zhou


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Monday, January 8, 2018 2:04 AM
  • Sorry for the delay in following up. How about the javascripts? The java scripts can be added in several different ways to the page. Check to see if there are any javascripts added.

    The best way to test this is to create a new site using the OOB template and see if this happens in the new site.


    ViviSP

    Wednesday, March 7, 2018 7:08 PM
  • The document set pages do have additional web parts added that have references to  <JSLink>clienttemplates.js</JSLink>.

    Wednesday, March 7, 2018 7:55 PM
  • Try this..

    1- Open your document set

    2- Edit page

    3- Delete the "Document set Contents" WebPart

    4- Add new "Document set Contents" WebPart

    5- set WebPart "frame style" to none (not sure if required)

    • Marked as answer by spi_shane Monday, July 9, 2018 5:11 PM
    Monday, July 9, 2018 4:10 PM