none
RDS Cal Licenses not recognized RRS feed

  • Question

  • Available and Issued should add up to 10, but is instead showing 0 available, 0 issued, and using “Built-in-overused” instead of the legitimate CAL.

    This causes an error in the licensing diagnose:

    Screenshot will not post until "verify your account" but no instructions about how to accomplish this.

    Wednesday, January 29, 2014 11:33 PM

All replies

  • Hi Ken,

    Have you check whether grace period for RDS CAL?
    Did you receive any particular Event ID for this issue?

    From you description it seems that you are using User CAL in your environment. Normally there is 120 days grace period available for the license after that you cannot able to use the license and you need to purchase a valid license and need to activate by calling MS clearing house. You can track the RDS per User CAL as per below link.
    Track the Issuance of Remote Desktop Services Per User Client Access Licenses

    Please refer below articles for more information.

    1.  Identify Possible Licensing Problems for the RD Session Host Server
    2.  Review the Configuration of a Remote Desktop License Server
    3.  Understand the licensing grace period

    Hope it helps!

    Thanks,
    Dharmesh
    Thursday, January 30, 2014 7:28 AM
    Moderator
  • It is currently using the built-in grace period, but it shouldn’t need to. Instead it should be using the 10-pack License we already installed and activated via internet connection to clearinghouse (completed without error).  The problem is that the per-user CAL 10-pack we installed by product key is showing 10 installed, 0 available, 0 assigned.  Normally this should show 10,10,0 or 10,7,3 or 10,0,10.  The available and assigned should add up to the total installed, but it doesn’t.  Licensing diagnosis only returns one error that “no licenses are available”, which agrees with 0 available in the license manager, but doesn’t answer the question of “why aren’t my installed licenses available”?  There are no other event viewer errors.  We have tried re-installing the RDS licensing role, reinstalling the license, and re-activating the license server, none of these made any change.

    Thursday, January 30, 2014 11:10 PM
  • Hi Ken,

    For License related there are 3 main issue which can take effect.
    -  Issue with Discovery
    -  Issue with Credential
    -  Issue with Configuration

    Here providing you article you can check as per the following.
    Licensing Diagnosis: Problems and Resolutions

    Hope it helps!

    Thanks,
    Dharmesh
    Friday, January 31, 2014 3:01 AM
    Moderator
  • We’ve already run the licensing diagnosis, and the only problem displayed by that tool is that no licenses are available.  The error looks exactly like Problem 10 in Licensing Diagnosis: Problems and Resolutions.  The only resolution recommended there is to install licenses, which doesn’t solve our problem, as we had already done that.  The root issue is that the licensing manager is showing that installed license as “0 available” while “0 issued”, even though it accepts that 10 CALS of the correct type have been installed. We could install 100 licenses, but it won’t help us if it doesn’t recognize them as available, and we can’t determine why not.

    Friday, January 31, 2014 6:18 PM
  • Hi Ken,

    As you have already installed RDS CAL but cannot able to show available and issued CAL. Here you can check the issuance of RDS CAL, by controlling which RD Session Host server are issued RDS CAL, you can also control which version of RDS CAL is issued to RDSH Server, and also control the auto-discovery of RD License server.

    Location of the License server security group policy setting: Computer Configuration\Administrative Templates\Windows Components\Remote Desktop Services\RD Licensing

    More information.
    Control the Issuance of RDS CALs

    Hope it helps!

    Thanks,
    Dharmesh
    Sunday, February 2, 2014 6:38 AM
    Moderator
  • Hi,

    Is your licensing server running Server 2012 or Server 2012 R2?  I assume it is Server 2012 but please verify.

    In RD Licensing Manager (licmgr.exe), please create a CAL Usage report, right-click on the report you just created and save it as a csv, then open the saved file in Notepad to view details of license usage.  The file should show which users have been issued a license, total counts, expiration dates, etc.

    Please post the contents of the csv file (after modifying domain and user names) here.

    Thanks.

    -TP

    Monday, February 3, 2014 3:03 AM
    Moderator
  • Dharmesh, this is a single machine for a Proof Of Concept application, therefore the licensing server and RD session host are on the same machine.  Though it is part of the domain, the Group Policy for RD Licensing is in the default “not defined” state.  This should not be an issue, as quoted from your link (emphasis added):

    “If you disable or do not configure the License server security group policy setting, the Terminal Server Computers group is not deleted or changed and the license server issues an RDS CAL (if an appropriate RDS CAL is available) to any RD Session Host server that requests one.

    With no changes to GPO defaults, the licensing server should issue CALs to itself without issue.  In fact, CAL’s are being issued, they’re just being issued from the built-in overuse account instead of from the purchased license.

    _______________________

    TP, this is 2012 R2.   licmgr.exe displays the following:

    License Version and Type / License Program / Total Licenses / Available / Issued / Expiry Date / Keypack ID

    Windows 200 Server – Built-in TS Per Device CAL / Built-in / Unlimited / Unlimited / 0 / Never / 2

    Windows Server 2012 – Installed RDS Per User Cal / Built-in OverUsed / 0 / 0 / 8 / Never / 4

    Windows Server 2012 – Installed RDS Per User Cal / Retail Purchase / 10 / 0 / 0 / Never / 3

    This agrees with the raw numbers (10/8) listed in the results of the CAL usage report below, the report isn’t too helpful as it doesn’t note which CAL is being used (as above), which is the problem:

    CAL Usage Report

    RD License Server:,"MYSERVER"

    Report Date:,"Tuesday, February 4, 2014 4:50:31 PM"

    CAL Version,CAL Type,Installed CALs,CALs in Use,CAL Availability

    Windows Server 2012,RDS Per User CAL,10,8,Limited

    Successful Per User License Issuance Detail

    Issued to User,CAL Version,CAL Type,Expires On

    MyDomain.com\LocalAdmin,Windows Server 2012,RDS Per User CAL,"Sunday, March 30, 2014 7:32:02 PM"

    MyDomain.com\EnterpriseAdminUser,Windows Server 2012,RDS Per User CAL,"Sunday, March 30, 2014 7:44:42 PM"

    MyDomain.com\DomainAdmin,Windows Server 2012,RDS Per User CAL,"Sunday, March 30, 2014 10:03:55 PM"

    MyDomain.com\PowerUser,Windows Server 2012,RDS Per User CAL,"Sunday, March 30, 2014 11:15:10 PM"

    MyDomain.com\NormalUser1,Windows Server 2012,RDS Per User CAL,"Monday, March 31, 2014 11:32:33 PM"

    MyDomain.com\NormalUser2,Windows Server 2012,RDS Per User CAL,"Tuesday, April 1, 2014 6:36:22 PM"

    MyDomain.com\NormalUser3,Windows Server 2012,RDS Per User CAL,"Saturday, April 5, 2014 3:22:40 AM"

    MyDomain.com\NormalUser4,Windows Server 2012,RDS Per User CAL,"Saturday, April 5, 2014 8:54:29 PM"

    No Per User License Issuance has failed

    No Per Device License has been issued

    Wednesday, February 5, 2014 1:05 AM
  • Hi,

    1. Have you tried restarting the RD Licensing service?

    2. Before you installed the license pack, were Per User licenses already issued?  It would have showed up under Built-in OverUsed.

    Normally when you install a license the OverUsed should go away and its issued count will be subtracted from the Retail or Volume total.  Additionally the list of users that it has listed (the list in RD Licensing Manager, not the report list) as being issued a CAL from the OverUsed will move to the new license pack you installed.  I think there are times when this process does not work properly which is why I asked if you have restarted the service yet since that may trigger cleanup.

    There was someone else that recently reported a similar problem with OverUsed and theirs went back to normal (I think on its own, if I remember correctly).  This is likely a new bug.

    If necessary you can rebuild the licensing database, reinstall the licenses, and then it should be correct from that point forward.  Even if you do not correct the count users should still be able to connect.

    -TP

    Wednesday, February 5, 2014 7:31 AM
    Moderator
  • Hi TP,

    1. Tried a full reboot of the server as well as the licensing service. No change
    2. Tried on purpose after the last rebuild: before the retail CALs were installed, 2 overuse licenses were issued. 6 additional after that.

    We’ve tried rebuilding the licensing database and reinstalling the license, no change. We’ve also tried fully removing all RDS services including session host and Licensing server and reinstalling/reactivating them.  No change.

    I saw the other user’s recent issue… his was a little different in that his was issuing from overused like ours, but his retail package did show licenses available where ours does not.

    For the moment users can connect, but I can’t have it just break when the grace period expires… given this is a fresh install on a new VM, that would not be a reassuring proof of concept for our customer.

    Thursday, February 6, 2014 1:12 AM
  • Any updates?  We've followed all the recommendations and still don't have a working set of CALs.  If this is a bug, is there a bug tracking number?
    Tuesday, February 11, 2014 8:10 PM
  • I have exactly the same issue. I have uninstalled and reinstalled all of my RDS components and there is no change. Are there any updates?
    Tuesday, February 25, 2014 7:40 PM
  • Located another set of CALS through our MSDN account and added these and all of a sudden all of the CALS were available including the original CALS that were showing 0 available CALS; never understood why this worked
    Tuesday, February 25, 2014 7:52 PM
  • Don't just reinstall the license role, you will have to perform the following steps. This issue is possible due to license db is correct

    ======================

    ->Deactivate the LS

    ->Remove the Licensing role

    ->Restart the server

    ->Renamed the existing lserver folder to .old (c:\windows\system32\)

    ->Install the licensing role

    ->lserver folder will be created automatically

    ->Activate the License server

    ->install the licenses using EA agreement number

    ======================


    Hari Kumar --- Disclaimer: This posting is provided AS-IS with no warranties or guarantees and confers no rights

    • Proposed as answer by Transistor1 Wednesday, April 6, 2016 12:46 PM
    Wednesday, April 22, 2015 7:58 PM
  • Worked for me; thanks!
    Wednesday, April 6, 2016 12:46 PM