none
User calendar entries showing up in other calendars RRS feed

  • Question

  • Hi,

    A couple of months ago every single user recieved an invitation to get access to a single users calendar.

    She claims she's never been tinkering with the permission settings for her calendar, but a lot of the others users just blindly accepted this invitation.

    Now all of them are seeing her appointments in their own personal calendar, and while they can remove them manually, any new entry will show up. And people are tearing out their hair about this.

    I've checked her Outlook permission settings on her PC, and no one has been granted any extraordinary access. The same goes when I check the calendar settings for the affected people in powershell. No one has extraordinary access to her calender other than a global reviewer right that has been used for years.

    It simply does not make any sense, so I hope someone can help us out.

    We are using the Microsoft 365 E3 solution for all out users, and Exchange Online, by the way.

    • Edited by BB-ITDK Wednesday, August 21, 2019 8:53 AM Extra info
    Wednesday, August 21, 2019 8:52 AM

All replies

  • I have some questions, Does any new entry created in user's calendars in other user's calendar immediately ? 

    Does it shows as accepted or tentative when you open the meeting from the other user's outlook ? 

    Also close the outlook / turn internet in the mobile if it has the user account configured.

    Then create a meeting and check if it shows up on calendar from OWA of other users.

    This allow us to isolate the issue.


    S_K_P

    Wednesday, August 21, 2019 7:34 PM
  • Hi,

    Are you all internal users?

    >> Now all of them are seeing her appointments in their own personal calendar,

    Normally, when we accept a sharing invitation, this calendar will be opened under Shared Calendars section.

    Do these shared calendar items show directly in other users’ personal calendar?

    To eliminate whether this issue lies on client-side or server side, please exit Outlook client on both side and directly test this issue on the web mail.

    Besides, please try starting Outlook in safe mode and see whether this issue continues. This helps eliminate if the problem is related to any third party add-ins. To do this, please exit Outlook, press Win key + R to open the Run command, type outlook /safe, press Enter.

    Any updates, please feel free to post back.

    Regards,

    Perry


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Thursday, August 22, 2019 2:46 AM
    Moderator
  • Hi S_K_P,
    I'll return as soon as I got something.

    Thursday, August 22, 2019 6:32 AM
  • Hi Perry,

    Sure, I'll keep you posted as soon as I have something.

    Thursday, August 22, 2019 6:32 AM
  • Hi,

    Haven't heard from you for several days. Just check if I can do anything else for you.

    If this issue has been fixed, you can also share the solution here which will benefit other users a lot.

    Regards,

    Perry


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Sunday, August 25, 2019 5:45 AM
    Moderator
  • Hi Perry,

    Sorry, we have been pretty hung up on projects lately, and will be for another month, so I haven't had the time to do some proper testing.

    I have, however, tried removing all access rights on the users calendar, added them again after a sync cycle, and haven't heard any complaints from other users in the meantime, so it may have been fixed that way.
    Thursday, August 29, 2019 7:12 AM
  • Hi Perry,

    Sorry, we have been pretty hung up on projects lately, and will be for another month, so I haven't had the time to do some proper testing.

    I have, however, tried removing all access rights on the users calendar, added them again after a sync cycle, and haven't heard any complaints from other users in the meantime, so it may have been fixed that way.

    That would be great if this issue got fixed after re-assigning permission. We can monitor for a while. If issue comes back, we can research on it again:)

    Regards,

    Perry


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Thursday, August 29, 2019 8:28 AM
    Moderator