none
Word 2010 - Unable to Save Keyboard Shortcut to Normal.dot

    Question

  • I am using Word 2010 64-bit.  I created a macro to insert a date in European format.   I created a shortcut key and assigned it using Options, Customize Ribbon, Customize Keyboard Shortcuts, and saved to Normal.  The keyboard shortcut works in new documents until I close Word and then restart.  Then the keyboard shortcut doesn't work anymore.  This worked for me in Word 2007.  Is this a bug in Word 2010 64-bit?
    Seth Thomas
    Wednesday, May 18, 2011 6:17 PM

All replies

  • Hi

     

    Thank you for using Microsoft Office for IT Professionals Forums.

     

    Step 1: Determine the template that is used by the document

    a)       Open the problem document in Word 2010.

    b)       Click File on the Ribbon, and then click Word Options.

    c)        Click Add-Ins.

    d)       In the Manage box, click Templates under View and manage Office add-ins

    e)       Click Go.

    The Document template box will list the template that is used by the document. If the template listed is Normal, go to step 2. Otherwise, go to step 3.

     

    Step 2: Rename the global template (Normal.dotm)Follow the steps for the operating system that you are using:

    Windows Vista and Windows 7

    a)       Exit Word 2010

    b)       Click Start.

    c)        In the Start Search box, type the following text, and then press ENTER:

    1.       %userprofile%\appdata\roaming\microsoft\templates

    d)       Right-click Normal.dotm, and then click Rename.

    e)       Type Oldword.old, and then press ENTER.

    Microsoft Windows XP

    a)       Exit Word 2010

    b)       Click Start, and then click Run.

    c)        In the Open box, type the following text, and then press ENTER:
    %userprofile%\Application Data\Microsoft\Templates

    d)       Right-click Normal.dotm, and then click Rename.

    e)       Type Oldword.old, and then press ENTER.

    f)        Close Windows Explorer.

     

    Step 3: If it’s not work fine, please follow these steps to save as Normal.dotm to template folder after created shortcut key.

    a)       Click File > Save As

    b)       In the File name box, Type follow text  Normal

    c)        Drop down Save as type: choose Word Macro-Enabled Template(*.dotm)

    d)       In the location box , type the following text, and then press ENTER:

    %userprofile%\appdata\roaming\microsoft\templates

    e)       Close Windows Explorer.

    f)        Start Word 2010, and then open the document.

     

    Please take your time to try the suggestions and let me know the results at your earliest convenience. If anything is unclear or if there is anything I can do for you, please feel free to let me know.

     

    Hope that helps.

     

    Sincerely

    William Zhou CHN
    Friday, May 20, 2011 8:41 AM
  • Dear William,

    I'm also experiencing the same problem with keyboard shortcuts using Word 2010 on de 64-bit system. I’ve read your suggestions and followed them step-by-step, but my problem isn’t solved. The customized keyboard shortcut works in new documents until Word is closed and then restart. After restarting the keyboard shortcut doesn't work anymore. Can you help me fix this problem?

    Thanks! Miranda

    Friday, July 08, 2011 11:24 AM
  • DITTO! When I tried step 3, even though I had successfully maneuvered through step 2, it said "Word cannot save a document with the same name as an open document." I was in the correct templates file and everything, and the Normal template had been renamed to oldword.old. I've never had trouble doing this in Word before and there's a shortcut I'm lost without that I've used for years. Please help!!
    Thursday, October 06, 2011 6:34 PM
  •  I also tried, and then copied and pasted my old macros back in.  But same result - after setting up keyboard shortcuts that work, they then fail to work after closing Word and restarting.
    Seth Thomas
    Monday, November 21, 2011 7:35 PM
  • I'm having the same problem with keyboard shortcuts I use for special characters and autocorrect settings. The problem persists across all templates used, not just the Normal.dotm file. I also tried the solution proposed at http://social.technet.microsoft.com/Forums/eu/office2010/thread/9add6d33-1e26-43fe-b5d4-2a636da9b5b8, which directs us to open Word using "C:\Program Files\Microsoft Office\Office14\WinWord.exe" /a

    Please help with this problem. These shortcuts help make using Word so much more productive.

    • Proposed as answer by Sjjtwo Wednesday, June 27, 2012 6:31 PM
    • Unproposed as answer by Sjjtwo Wednesday, June 27, 2012 6:32 PM
    Tuesday, November 29, 2011 9:48 PM
  • It's January 1, 2012 - Has ANYBODY solved this problem?  I am a new 2010 user and I can't get Word to save my custom keyboard changes either. How frustrating!
    Monday, January 02, 2012 1:46 AM
  • This solution did NOT work for me either.  It is difficult for me to understand why updating the visual aspects of Word affect the operation software coding.  Has this problem been solved? 
    Friday, February 17, 2012 7:01 PM
  • It is not a bug in Word but related to other software (I have heard it is Adobe 7 Reader that causes the problem). Most suggested work-arounds don't seem to work. What I do is load Normal.dotm into Word, make my changes directly into the template, and then save it. This works for me, and although it is a little involved it might be preferable to trying to uninstall other software. Hopefully, either Microsoft or the manufacturer of the other software involved will make a patch soon and include it in their upgrades.

    • Proposed as answer by Sjjtwo Wednesday, June 27, 2012 6:30 PM
    Wednesday, June 27, 2012 6:28 PM
  • Try loading the template you wish to change into word as though it were a document -- just go to the template's location and load it into Word. Make your changes while the template is loaded in this fashion, and then save it. Please let me know if this works or not, or if you need anymore information. 
    • Proposed as answer by Sjjtwo Wednesday, June 27, 2012 6:40 PM
    Wednesday, June 27, 2012 6:40 PM
  • Try loading the template you wish to change into word as though it were a document -- just go to the template's location and load it into Word. Make your changes while the template is loaded in this fashion, and then save it. Please let me know if this works or not, or if you need anymore information. 
    Do you have instructions as to how to "load" or "change" a template?  Thank you.
    Friday, April 04, 2014 8:32 PM