locked
Cannot create a data set RRS feed

  • Question

  • Hi,

    I had recently installed SSRS 2016. I could connect to Oracle DB and create data source, data sets and reports and also mobile reports. I even published those mobile reports in Power BI and installed the Power BI app in the mobile phones of our Managing Director, Director, VP Sales and others. Now, yesterday, the server of SSRS 2016 went down and I have no been able to put it back up.

    I am now trying to create another server so that I can create those same reports and the management can again start using Power BI which they really liked. I can connect to Oracle DB (through SQLPLUS Command prompt) which has our ERP data. I can even create a shared data source in SSRS and connect to Oracle. 

    But, when I try to create a shared data set using this shared data source, it gives me an error saying - "The selected data extension ORACLE is not installed or cannot be loaded. Verify that the selected data extension is installed on the client for local repors and on the report server for published reports."

    I have tried to install many versions of Oracle client. Every time I can connect to Oracle DB through SQLPLUS Command Prompt and even create a shared data source, but everytime I get the above mentioned error while creating a shared data set using this data source.

    Kindly help, I am really frustrated and under a lot of pressure.

    Regards,

    Ashish Sood

    Saturday, May 27, 2017 12:39 PM

Answers

  • Hi Ashish Sood,

    You could try suggestion provided by Uri Dimant, here is another reference: The selected data extension ORACLE is not installed or cannot be loaded.

    Besides, the Oracle data source uses the Oracle Data Provider directly and requires an Oracle client software component, make sure you have installed it correctly. To install the Oracle Client tools you can do the following:

    1. Go to Oracle’s download site
    2. Download ODAC 12c Release 4 (12.1.0.2.4) for Windows (64bit for server, 32bit for tools)
    3. Install the Data Provider for .NET 4

    For detailed information, you could refer to Oracle Connection Type (SSRS).

    If you have any questions, please feel free to ask.

    Best Regards,

    Henry 

    Monday, May 29, 2017 6:37 AM

All replies

  • Try install Oracle 12 client full package(oracle.com/technetwork/database/enterprise-edition/d‌​ownloads/…)

    Best Regards,Uri Dimant SQL Server MVP, http://sqlblog.com/blogs/uri_dimant/

    MS SQL optimization: MS SQL Development and Optimization
    MS SQL Consulting: Large scale of database and data cleansing
    Remote DBA Services: Improves MS SQL Database Performance
    SQL Server Integration Services: Business Intelligence

    Sunday, May 28, 2017 5:31 AM
  • Hi Ashish Sood,

    You could try suggestion provided by Uri Dimant, here is another reference: The selected data extension ORACLE is not installed or cannot be loaded.

    Besides, the Oracle data source uses the Oracle Data Provider directly and requires an Oracle client software component, make sure you have installed it correctly. To install the Oracle Client tools you can do the following:

    1. Go to Oracle’s download site
    2. Download ODAC 12c Release 4 (12.1.0.2.4) for Windows (64bit for server, 32bit for tools)
    3. Install the Data Provider for .NET 4

    For detailed information, you could refer to Oracle Connection Type (SSRS).

    If you have any questions, please feel free to ask.

    Best Regards,

    Henry 

    Monday, May 29, 2017 6:37 AM
  • Hi Henry,

    Thank you much for replying. I will surely try this and will get back to you.

    I wanted to ask about a doubt that is coming to me. 

    Earlier when I was able to do everything (in the server which went down), in that server, I had installed Microsoft Windows 12 Datacentre edition. Whereas, now in this new server (where I cannot create a data set, even though the data source is getting created and connected), I have installed Microsoft Windows 12 Standard edition.

    Can this be any kind of issue which is causing this problem?

    Regards,

    Ashish Sood

    Monday, May 29, 2017 7:58 AM
  • Hi Uri,

    Thank you for replying to my query!

    I tried to install the full package of Oracle 12 C. But with that I cannot even create a data source. 

    Is there anything else I should try?

    Regards,

    Ashish Sood

    Monday, May 29, 2017 11:09 AM
  • Hi Henry,

    I have installed Oracle client 12 C release 4 as mentioned. 

    Still my problem persists.

    What else should I try?

    Regards,

    Ashish Sood

    Saturday, June 3, 2017 4:51 AM
  • Hi,

    Have you installed the Data Provider for .NET 4 and to connect to Oracle DB, You should install the .NET Framework Data Provider for Oracle on the server hosting the SSRS instance to be able to target an Oracle database.

    Thursday, June 8, 2017 9:11 AM
  • Hi Henry,

    I tried to search for Data Provider for .Net 4 and I found that ODAC 12C has that component. However, when I try to install that, it asks to install Visual Studio first. Am I doing the correct thing?

    Also, kindly help me to find .Net Framework Data Provider for Oracle. If you have any link for this, it will be a great help!

    Regards,

    Ashish Sood

    Monday, June 12, 2017 7:55 AM
  • Hi Henry,

    Thanks a million for the reply! My instance works properly.

    So to sum it up for a not so technical person in Oracle and SSRS, you need to do the following to connect Oracle from SSRS 2016:

    1) Server should have Windows 12 Standard, Datacentre, Enterprise or later.

    2) Oracle 12 C full (Administrator) client needs to be installed on server.

    3) ODAC 12 C 32 bit (as it has Data Provider for .NET 4, you can uncheck Visual Studio component while installation of ODAC 12 C)  needs to be installed on the clients for developing reports in SSRS 2016 as Report Builder of SSRS 2016 is a 32 bit application. You can / should do this on server also.

    Again thanks a lot Henry for your patients and support. You are a STAR!!!!!!

    Regards,

    Ashish Sood

    Monday, June 19, 2017 6:19 AM
  • Hi,

    Glad that you have figured it out and thank you for sharing your answer!

    Best Regards,

    Henry 

    Monday, June 19, 2017 2:21 PM