Can't view emails older than 2 weeks


  • Hi all, 


    I'm running outlook 2010, and all emails older than 2 weeks are not visible. They are still on the server as I can view them on another computer (mac mail) but they disappear from my outlook inbox after 2 weeks. 

    I've checked the auto archiving feature via the following;

    file - options - advanced - auto archive settings - the run auto archive box is unchecked.

    I've also right clicked on my inbox and clicked on properties - auto archive and the 'do not archive items in this folder' box is checked

    I've also checked the rules and don't see anything there (the only rule I have is for the sound and pop up whenever an email appears)

    Is there something else I'm missing? Is it possible it's not an auto archiving issue?


    Any help would be greatly appreciated

    Wednesday, January 05, 2011 2:33 PM

All replies

  • If you can view them with another program (mac mail, OWA) and they are in the inbox in the other program then they are still there.  It is most likely a view filter issue.  In Outlook 2010, while you are in your inbox, click on the "View" ribbon and select the "Reset View" button, or click the "View Settings" button and see if any filters are applied.
    Tim Harrington | MVP: Exchange | MCITP: EMA 2007/2010, MCITP: Server 2008, MCTS: OCS | Blog: | Twitter: @twharrington
    Wednesday, January 05, 2011 2:52 PM
  • Thanks for the suggestion, I tried the above and there doesn't seem to be a visible difference. I'm not sure if I will see a difference until the oldest message goes past 2 weeks of age. If this did fix the solution, is there any way to get the old messages back?
    Wednesday, January 05, 2011 3:48 PM
  • You said you could see them in another app, right (mac mail)?  Can you still see them there?  If so, is Mac mail set for POP/IMAP?  If so, then that client might be pulling the messages off of the server.

    Tim Harrington | MVP: Exchange | MCITP: EMA 2007/2010, MCITP: Server 2008, MCTS: OCS | Blog: | Twitter: @twharrington
    Wednesday, January 05, 2011 4:07 PM
  • My mac mail is set to POP and is set to view all messages on server. The outlook is set up for IMAP/SMTP and I can't find anything else that says view all. The emails that are less that 2 weeks old are viewable on both computers, as well as an iphone.
    Wednesday, January 05, 2011 4:26 PM
  • Hi,

    I had the same issue , but solved now.

    I selected the folder , in my case it was "Inbox" and at the left hand bottom corner I was able to see filter applied. It is the same place where you see the total number of mails in folder. 

    Click on the "Filter applied" text, and you will get one popup , where you will be able to clear the rule. For you it will be set to display content only of before 7 days.

    Let me know if it works for you.


    Monday, February 03, 2014 5:59 PM
  • When I select "Inbox", I don't see the "filter applied" anywhere.  This is so frustrating.  Can I get to it a different way?


    Tuesday, February 18, 2014 1:36 PM
  • Hi,

    If you are not able to see filter text at the bottom bar,  right click to get this menu there,

    Select filter to see specific property.



    Tuesday, February 25, 2014 1:15 AM
  • Make sure outlook is not running in cached mode, you can do this by:

    File > Account Settings > Account Settings > double click on profile > un-check "use Cached Exchange mode" > next > next > finish

    Thursday, January 29, 2015 7:08 PM
  • Go into email account setting and set your server from IMAP to POP. You may need help from your service provider. IMAP mirrors the service providers server and some service providers dump your emails after 2 weeks regardless of your setting. Hope this helps.
    Wednesday, August 26, 2015 11:15 AM