locked
RDS 2012: Can you publish apps installed on a network from the rds server. RRS feed

  • Question

  • Hello,

    I have allot of apps that installed on a network share. So there is a front end installed on the server but the executable sits on network. It does not appear as an installed app in the window of publishing apps. The reason for this is so any settings modified as part of this software must be installed as a network server so that all users get the settings.

    Thanks in advance

    Wednesday, April 10, 2013 7:10 PM

Answers

  • OK I finally figured it out.

    I created a shortcut of the application the is on the network share (\\server\share\app.exe) and put it in the public desktop of the server  (C:\Users\Public\Desktop), so it will be visible for all users who log on to the server desktop as well.

    Then I found this article http://social.technet.microsoft.com/wiki/contents/articles/10817.publishing-remoteapps-in-windows-server-2012.aspx

    At the bottom I followed this users alternative solution

    Jonathan Sills
    6 Feb 2013 7:27 AM

    Hi Freek, The local exec restriction in the UI is not present when using Powershell to create the remote app.  So for appc running over UNC  path, creating a new remote app through Powershell is the way to go!

    1- Run Powershell as admin

    2- Execute the following command:

    New-RDRemoteApp -CollectionName [collection_name] -DisplayName [remote_app_display_name] -FilePath "\\server\share\executable.exe"

    I opened powershell on the rds server and plugged the above users suggestion and I got an iconindex error so I added the following to the end of the command 

    -IconPath \\server\share\app.exe  (location of the original exe file, that shortcut was created) here is my example command

    New-RDRemoteApp -Alias "App Name" -CollectionName Collection -DisplayName "APP Display" -FilePath "C:\Users\Public\Desktop\shortcut.lnk" -FolderName "Folder Name" -IconPath "\\server\share\app name.exe"

    I hope this helps someone and thanks to the wiki and the user for the help.

    • Marked as answer by Clarence Zhang Wednesday, April 24, 2013 8:40 AM
    Wednesday, April 17, 2013 3:16 PM

All replies

  • Hi,

    Yes you can add  executables from a UNC path\network share to a remote app server. When you publish a remote app, you will see a add option in the bottom right hand window of the Publish RemoteApp Programs. Click the add button and browse to the network drive in question.

    Best Regards,

    Wednesday, April 10, 2013 10:20 PM
  • Hello,

    I tried that and I get the following message

    Windows Firewall is disabled on the server. The app executable is installed to a file server called rha-fs3, so I tried the UNC path = \\rha-fs3\app\app.exe


    • Edited by rha_mtl Thursday, April 11, 2013 1:49 PM
    Thursday, April 11, 2013 1:47 PM
  • Hi,

    I forgot to mention apologies,  you would need to create a shortcut on the RDSH servers. You can also use APP-V if you have Software assurance.

    Best Regards,

    Thursday, April 11, 2013 3:58 PM
  • Hi,

    What i did is create a shortcut on the desktop od the server to the executable on the file server and i still get this message


    I don't know what APP-V is.
    • Edited by rha_mtl Thursday, April 11, 2013 6:46 PM
    Thursday, April 11, 2013 6:43 PM
  • OK I finally figured it out.

    I created a shortcut of the application the is on the network share (\\server\share\app.exe) and put it in the public desktop of the server  (C:\Users\Public\Desktop), so it will be visible for all users who log on to the server desktop as well.

    Then I found this article http://social.technet.microsoft.com/wiki/contents/articles/10817.publishing-remoteapps-in-windows-server-2012.aspx

    At the bottom I followed this users alternative solution

    Jonathan Sills
    6 Feb 2013 7:27 AM

    Hi Freek, The local exec restriction in the UI is not present when using Powershell to create the remote app.  So for appc running over UNC  path, creating a new remote app through Powershell is the way to go!

    1- Run Powershell as admin

    2- Execute the following command:

    New-RDRemoteApp -CollectionName [collection_name] -DisplayName [remote_app_display_name] -FilePath "\\server\share\executable.exe"

    I opened powershell on the rds server and plugged the above users suggestion and I got an iconindex error so I added the following to the end of the command 

    -IconPath \\server\share\app.exe  (location of the original exe file, that shortcut was created) here is my example command

    New-RDRemoteApp -Alias "App Name" -CollectionName Collection -DisplayName "APP Display" -FilePath "C:\Users\Public\Desktop\shortcut.lnk" -FolderName "Folder Name" -IconPath "\\server\share\app name.exe"

    I hope this helps someone and thanks to the wiki and the user for the help.

    • Marked as answer by Clarence Zhang Wednesday, April 24, 2013 8:40 AM
    Wednesday, April 17, 2013 3:16 PM
  • Thanks for the above - pointed me in the right direction. We have an important legacy program that only runs on a network share to the host server and I'd given up trying to publish it as a Remoteapp A couple of pointers for people struggling. In order to run the command in powershell you need to load the RemoteDestop Powershell Module by typing: import-module RemoteDesktop. (if it's not loaded already) My Powershell rejected the -CollectionName parameter. The -FilePath had to be the UNC to the executable "\\server\share\program.exe" - it failed using the local shortcut. Hope this helps. Remoteapp is awesome IMHO! :)
    Wednesday, March 12, 2014 11:54 PM
  • Thank your very much with this, I got really mad about this issue.

    In my case it was just an .exe in a shared folder. We're migrating from 2008 r2 to 2012 r2 and the application was already published at the old server.

    In the publishing dialogue of 2012 r2, there were even Applications from the same shared folder but trying to add this file, I always ended up in the same error as sha.mtl :-(

    Thx a lot!!!

    Wednesday, October 29, 2014 10:05 AM
  • Hi, 

    just create a cmd file with the Execution path on the RDS Session host server.

    Cheers.

    Monday, September 12, 2016 5:55 PM
  • To me, worked!

    New-RDRemoteApp -Alias "RM CORP CONSTELLATION" -CollectionName CORPConstellation_Collection -DisplayName "RM CORP CONSTELLATION" -FilePath "\\SRV0019.net.edu\totvs$\CorporeRM\RM.Net\RM.exe"  -IconPath "\\SRV0019.net.edu\totvs$\CorporeRM\RM.Net\RM.exe"

    Wednesday, October 19, 2016 7:43 PM
  • Do you think if I use network path instead of placing the shortcut on the public desktop would cause issues?

    If you don't mind could you tell me what is the best method? 

    I created a batch file created on the RDS server with a UNC path pointing to the app server(non-RDS server).


    Shekar-Technet

    Tuesday, November 20, 2018 11:19 PM
  • Hello,

    I have the same problem, I need to add an application whose path should point to a network drive V: instead of C: ... for the server manager wizard it does not allow me, I have read in this thread that you can through powershell? I have not managed to do it, can someone help me? Thank you

    Wednesday, February 20, 2019 4:57 PM
  • I used a Batch process from the Session Host server to call application on a different server.

    something like start \\networkpath\application.exe


    Shekar-Technet


    • Edited by Shekar7976 Wednesday, February 20, 2019 8:49 PM added information
    Wednesday, February 20, 2019 8:48 PM
  • Hello, thanks for your answer,

    The difference in my case is that the application is not in another server, it is in the same server but it must be started from a network unit, in this case V:. What could I do in this case? Thank you

    Regards

    Thursday, February 21, 2019 10:10 AM
  • Network path or Network drive both are same. I got it working using the Batch file.

    Shekar-Technet

    Friday, February 22, 2019 5:44 PM
  • Hello, greetings and thanks for the clarification. Ok The application in this case is an A3, the application is installed in C:, but A3 requires that it be accessed by users through a unit V: (for example) that points to the app, in this particular case as it would be batch? is that I have tried and I have not managed to do it yet : /

    Thanks

    Saturday, February 23, 2019 9:47 AM
  • Hello, greetings and thanks for the clarification. Ok The application in this case is an A3, the application is installed in C:, but A3 requires that it be accessed by users through a unit V: (for example) that points to the app, in this particular case as it would be batch? is that I have tried and I have not managed to do it yet : /

    Thanks

    @Rajaseck,

    Please create a new question with your specific details so that we can assist you.

    Thanks.

    -TP

    Saturday, February 23, 2019 10:05 AM