none
Outlook Anywhere won't connect - continually prompts for password

    Question

  • I'm running Exchange Server 2007 on Windows Server 2008.  All computers on the domain connect to Exchange fine.  I'm experiencing an issue with Outlook Anywhere trying to connect from Outlook 2007 clients.  I am repeatedly prompted for my username and password (yes, I'm sure they're both being typed in right).  It won't connect.  Every now and then, it is successful - but the next time I close and open Outlook, no go.  I've tried http://support.microsoft.com/kb/913843/en-us to no avail.  Any tips on debugging this problem?  I've read another thread on this, and a lot of the solutions just seemed like crazy talk - people suggesting you uninstall Outlook 2007, then install 2003, then upgrade to 2007 - I'm sorry, but that's a little much.  I'd rather just find and fix the problem... with your help of course :).
    Friday, May 1, 2009 2:11 PM

Answers

  • We have similar problem in our company. It is resolved by editin the registry. try adding to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanserver\parameters new key:
    Name: MaxWorkItems
    Type: REG_DWORD
    Value :8192 (decimal)

    Then restart IIS and system attendant service.
    • Marked as answer by fyathyrio8 Sunday, June 14, 2009 4:20 PM
    Friday, May 8, 2009 6:14 AM

All replies

  • Have you tried the "Exchange Server Remote Connectivity Analyzer"?

    Read about it here:

    http://msexchangeteam.com/archive/2009/03/25/450908.aspx

    Karl
    Friday, May 1, 2009 2:29 PM
  • Have you tried the "Exchange Server Remote Connectivity Analyzer"?

    Read about it here:

    http://msexchangeteam.com/archive/2009/03/25/450908.aspx

    Karl

    The link provided crashes IE8 and Firefox... at least on my machine.

    I did find https://www.testexchangeconnectivity.com/

    It ran testing Outlook Anywhere for Outlook 2003.  The only step it failed on was the certificate (because it isn't made by a Microsoft trusted authority).  This should be fine, though because I added the certificate to the trusted root certificate authorities on the client.

    I should note that when I tried testing Autodiscover for Outlook 2007 using the tool, it fails.  I'm getting a 600 error in the autodiscover.xml, but getting autodiscover to work isn't really a necessity (or at least not a priority).
    • Edited by fyathyrio8 Friday, May 1, 2009 4:25 PM
    Friday, May 1, 2009 3:53 PM
  • It could be a certificate error.  I've had issues determining the correct way to generate the certificate.  Here's the situation, perhaps someone can offer advice (or the cmd-let) to create the certificate(s) properly.  When using Outlook Anywhere, suppose the url is www.domain.com and the server is servername.domain.com.  It seems like no matter what I do, it complains about the name not matching or something.  I believe I need (at least) two certificates, one for Exchange on the network, and one for Outlook Anywhere.
    Friday, May 1, 2009 5:42 PM
  • Hi,

    First ensure the NTLM authentication were configured on the Outlook Anwhere and client side. Additionally, please check whether the below link can help you:
    http://technet.microsoft.com/en-us/library/cc411324.aspx

    What's the result? If the issue persists, please let me know the issue to name of the certificate, then run get-Outlookprovider expr |fl command in EMS, and post the information on the forum.

    Thanks

    Allen
    Tuesday, May 5, 2009 6:56 AM
  • Hi,

    First ensure the NTLM authentication were configured on the Outlook Anwhere and client side. Additionally, please check whether the below link can help you:
    http://technet.microsoft.com/en-us/library/cc411324.aspx

    What's the result? If the issue persists, please let me know the issue to name of the certificate, then run get-Outlookprovider expr |fl command in EMS, and post the information on the forum.

    Thanks

    Allen

    Yesterday morning the issue SEEMED to have gone away (I wish I knew why).  This morning, the problem came back.  I reset IIS on the server, and was then able to connect (strange).  I was having issues with autodiscover screwing up the settings I knew to be right - and the article you posted did in fact solve that problem, though it seems like an unnecessary procedure (thank you Microsoft).  For now, we're ok.  Does it make sense to anyone why resetting IIS would resolve the problem with not being able to connect (at least temporarily)?
    Tuesday, May 5, 2009 2:21 PM
  • Hi,

    Please check whether the IIS was working normally. Hope you can find any tip from the event log.

    Thanks

    Allen
    Wednesday, May 6, 2009 3:56 AM
  • I have been unable to get OA working in two different environments (one lab, one production) without following the steps in this KB: http://technet.microsoft.com/en-us/library/cc671176.aspx

    This is despite havign rollup 7 installed, even though the KB says this bug was fixed in rollup 4.

    Actually I have a call open with MS about it at the moment, because the workaround fixed OA but broke some other stuff.

    Carol

    http://www.wapshere.com/missmiis
    Wednesday, May 6, 2009 8:58 AM
  • Hi,

    Please check whether the IIS was working normally. Hope you can find any tip from the event log.

    Thanks

    Allen

    I have been watching the event logs like a bloody hawk ever since the problem started.  No signs of anything related to the issue.

    As for http://technet.microsoft.com/en-us/library/cc671176.aspx, I scanned it briefly and the down and dirty is to disable IPv6 on the Exchange server.  What problems has it caused for you?  I might give it a shot if and when my scenario fails me again.

    It amazes me that problems like this are made so difficult to track down.  It's little more than guess and check.  Would it be too much to ask to receive meaningful error messages when things like this fail?  Sorry, that's my rant for today.
    Wednesday, May 6, 2009 1:34 PM
  • I have two servers with Mailbox, Hub and CAS role. I was using SCR to replicate the MDBs between the servers. I could not connect to either server with OA.

    After implemeting this workaround (which I had to do via hosts file change, because of having the Mailbox and CAS roles colocated) Outlook Anywhere worked perfectly but SCR was broken.

    The MS guys working on my call have now agreed that changing the hosts file does indeed impact SCR. Now we will go back to why on earth I had to do this workaround anyway, when the technote says you don't need it post rollup 4. We will hopefully have a session on friday - I will post back if anything interesting comes out of it.

    Carol

    http://www.wapshere.com/missmiis
    Wednesday, May 6, 2009 3:02 PM
  • The problem returned this morning.  Before looking at anything else, I performed an iisreset on the server.  Problem gone.  It's a simple enough fix, but I should have to babysit it.  I checked the event viewer and there weren't any errors in the time period that Exchange died.  Any thoughts?

    Thursday, May 7, 2009 3:27 PM
  • HI,
    Have you tried to disable/enable autodiscover (Remove-AutodiscoverVirtualDirectory -Server MyServer) ?
    Do you have problem with OWA ?
    Is autodiscover external host name mach internal server name ?
    What kind of client authentication method is configured ?

    Thursday, May 7, 2009 10:56 PM
  • I have disabled and enabled autodiscover.  As I said in a previous post, I was able to get autodiscover to provide the correct settings for OA.  I haven't had any problems with OWA.  I am using NTLM for authentication (primarily because it allows the client to save their password).  The problem seems to reside in RPC.  When I've had issues before, I attempted to go to https://domain.com/rpc - I was prompted for my user name and password, but the results were the same as in Outlook, i.e. I kept getting the prompt.
    Friday, May 8, 2009 4:55 AM
  • We have similar problem in our company. It is resolved by editin the registry. try adding to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanserver\parameters new key:
    Name: MaxWorkItems
    Type: REG_DWORD
    Value :8192 (decimal)

    Then restart IIS and system attendant service.
    • Marked as answer by fyathyrio8 Sunday, June 14, 2009 4:20 PM
    Friday, May 8, 2009 6:14 AM
  • We have similar problem in our company. It is resolved by editin the registry. try adding to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanserver\parameters new key:
    Name: MaxWorkItems
    Type: REG_DWORD
    Value :8192 (decimal)

    Then restart IIS and system attendant service.

    I'll give it a shot if/when the problem arises again and post results.  Thanks.
    Friday, May 8, 2009 10:37 PM
  • So - the problem came back today.  I added the registry value mentioned above, and I'll post back if the problem persists.  Thanks for your help.
    Wednesday, May 20, 2009 12:52 AM
  • It's been about 3 weeks now, and the problem hasn't returned.  Thanks for your help.
    • Proposed as answer by jdchowdary Thursday, July 9, 2009 7:42 AM
    Sunday, June 14, 2009 4:21 PM
  • i aslo faced the same issue from random group of users in my organisation, and 2nd is new users is not able to create his new profile in outlook and mailbox simple returns a error message as " The exchange server is not available"


    After this messages, i checked for services running. Microsoft Exchange SA service is not started, i restared the service, restared the IIS also.

    The issue closed 
     


    Thursday, July 9, 2009 7:52 AM
  • I'm faced with these issue, will try the solution and keep yous posted. Thanks
    Tuesday, July 17, 2012 5:06 AM
    • Proposed as answer by ingram87 Saturday, November 3, 2012 9:02 PM
    Thursday, September 13, 2012 1:30 AM