Outlook 2007 keeps asking for username and password gmail


  • Once in a while the Outllok 2007 and Outlook Express keep asking the username and password for gmail and stop synchronizing. Then it goes away only to come bak some weeks later. Very annoying..... Sometimes it only takes a few days to start all over again! I see that many people have a problem with this. It never happens with Hotmail, only gmail, very strange! And gmail doesn't really have anyone to help. Is it a gmail problem or an Outlook problem? When I set up the account in the Outlook I set it up to remember the password, so that is not the problem, I have also tried to repair the account on the Outlook but it says that "an encrypted connection for your mail server is not available" then I try the non encrypted one and it says the same thing . It is so very annoying when things stop working properly...... The only thing that seems to work is to go to gmail, where you can suggest a new feature, tell them that this is happening and coincidence or not this stops only to start again some other time. I don't want to give up this e-mail address because a lot of people have it! I didn't update or change anything! Francisca
    Wednesday, July 20, 2011 10:51 PM

All replies

  • Hi Francisca,

    Have you check the the settings in the Gmail help page? Make sure you have followed the steps below to set up your Outlook 2007 client to work with Gmail:

    I've been test on my test machine with Outlook 2007, and configured as the following steps, works fine.


    1. Enable IMAP in Gmail. Don't forget to click Save Changes when you're done.
    2. Open Outlook.
    3. For new setups, select Do not upgrade.
    4. Click Yes.
    5. Enter your display name, email address (including ''), and password. Google Apps users, enter your full email address, e.g. ''
    6. Select the 'Manually configure server settings or additional server types' checkbox.

    7. Select Internet E-mail.
    8. Settings: name, full email address (including '' or '')
      • In the Account Type dropdown menu, select IMAP. In the 'Incoming server name' section, enter: and in the 'Outgoing server name (SMTP)' section, enter:
      • In the 'User Name' field, give your full Gmail address, including '' or ''
      • After creating these settings, clicking Next takes you to the end of the setup.

    9. In the Tools menu, select Options then Mail Setup. Under 'Email Accounts,' click E-mail Accounts.
    10. Select an account, and click Change above the list of accounts. Click More Settings, then the Advanced tab.
      • Incoming server must be 993, and must use SSL3 encryption.
      • Outgoing server can use 587, TLS4 encryption.

    11. Click the Outgoing Server tab. Make sure that 'My outgoing server (SMTP) requires authentication' is selected. The radio button 'Use same settings as my incoming mail server' should also be selected.

    12. Click OK > Next > Finish > Close > OK.
    13. Check our recommended client settings, and adjust your client's settings as needed.


    Max Meng
    Forum Support

    Come back and mark the replies as answers if they help and unmark them if they provide no help.
    Friday, July 22, 2011 6:53 AM
  • Sorry but it hasn't worked! I had gmail configured as POP3, now I changed it to IMAP thinking that this might have been the problem. I did everything you suggested step by step. When Outlook tried to send a message to see if the server worked properly there was a message: can't log on to incoming server. I still get the window saying Enter username and password but no matter what I enter it keeps on appearing. Now I also get a window saying: Your IMAP server wants to alert you to the following: webg login required: (failure).

    I tried to set it all up again but when Outlook tried to send a test message I got another error message saying that Outlook can't connect to the outgoing (MSTP) e-mail server.
    I started out by changing in gmail from POP3 to IMAP and saving the settings. I don't know what to do anymore.... it is like now things even work worse as previously I was able to use synchronize gmail into the Outlook part of the time, now I think that this is completely gone. I still manage to send messages from the Outlook through gmail, I just don't receive in the Outlook although I do receive them in the gmail site!
    Best regards,
    Francisca Williams


    Friday, July 22, 2011 2:45 PM
  • Hi..

    You can add a Group in Send Receive setting. this will solve your issue.

    Select menu . Send Receive setting

    Add a Group.

    select the email account.

    Apply this.

    Now you try send Receive. This solution worked for me.




    • Proposed as answer by CRM 0421 Wednesday, September 12, 2012 7:36 PM
    Monday, September 05, 2011 10:54 AM
  • Hi, Francisca,

    I started experiencing the same thing tonight, and I found this article:

    It worked for me - I hope it helps you!


    Sharon Fry
    Microsoft Certified Trainer
    Software Specialist & Instructor

    • Proposed as answer by karlog Thursday, November 22, 2012 5:45 PM
    Wednesday, October 19, 2011 6:31 AM
  • This is EXACTLY the correct solution... Thank god I finally found it among all the gobbledy gook.

    Thank you

    Wednesday, September 12, 2012 7:35 PM
  • Thanks Sharon but things have been better for a while! When it all goes wrong again I will have a look at the link you sent me. One thing I am sure of, this is all Gmail's doing. They make changes to their site and all of a sudden everybody starts to have problems. What I do now is not to care, just send all e-mails from the gmail site till it all stops and it always does but sometimes it takes many days to go back to normal. I have to say that gmail is a horrible server. If I hadn't given my address to so many people I would change to another one! And they offer no help at all! Just horrible!
    Wednesday, September 12, 2012 9:39 PM
  • I use gmail, as well as their 2-step verification process. For those of you who use the 2-step verification, to get it to work in outlook you have to create an application specific password and use that in outlook to get it to work.
    Tuesday, September 17, 2013 7:57 PM
  • Since July 15, 2014, Gmail updates the default client authentication settings. This update will prevent from Outlook mail client to use the default IMAP authentication protocol which describes as – “basic authentication”.

    To enable Outlook client, access our Gmail mailbox, we will need to “loosen” the Gmail security settings, by turn “ON” the option of – Allow less secure apps.

    Another option is to configure the Outlook client to support the authentication mechanism described as – 2-step verification.

    You can read the following steps by step guide - Outlook cannot connect to Gmail – Password <g class="gr_ gr_11 gr-alert gr_spell gr_run_anim ContextualSpelling ins-del multiReplace" data-gr-id="11" id="11">re prompt</g> | Part 1#3

    Eyal DoronOutlook cannot connect to Gmail – Password re prompt | Part 1#3

    Saturday, April 23, 2016 1:24 PM
  • Hi,

    You need to enable less secure from your Gmail account which you are configuring with MS Outlook. Click here to know how to enable less secure app and cause of this issue.

    Best Regards

    Kelvin Howard

    Tuesday, April 26, 2016 10:18 AM
  • Hi all

    I'm reading through the threat and the different fixes people offer; but as of today (20/8/2016) I'm not able to add a new Gmail account to my outlook 2007:

    I've used the manual and automated POP settings as described in this article (with less secure app's and POP forwarding on GMAIL) and Outlook continously asks me for my password for POP and SMTP;

    I've tried IMAP as described in GMAIL help and in this forum without any success either.

    Is there any other fix anyone can suggest? The oddest thing is that an older GMAIL account in Outlook works - but even with the same settings, I don't get this one set up.

    Cheers Frank

    Saturday, August 20, 2016 4:19 AM
  • A while ago Google didn't let me go onto the homepage until I filled in a load of security and recovery options,

    I think I can remember on of the options was either to allow unsecure apps or not.

    I have had the same problem with Microsoft Outlook 2007 with my incoming gmail, It kept asking me for username and password.

    Fixed this in about 5 minutes, this is what I think the fix may be.

    When you have your gmail account set up have you got a recovery email address added to your account.

    I tried logging in and several times trying a combination of passwords but to no avail, so I opened up chrome and signed in from the google home page to check to see if anybody has changed my password. After finding out that my log in details where correct I opened up outlook to see that i have had a recovery email sent to my ntlworld email account to say that access has been blocked and it gave me the option to allow access or deny access. I clicked on allow access and it took me to a page which gives you the option to select to turn on unsecure apps or turn off unsecure apps. I clicked to allow unsecure apps then re-opened my outlook and clicked send/recieve now I am getting my emails to my google folder in outlook.

    My advise is to go to your gmail settings and set up a recovery email , if you do not have one you will not get the same blocked email that i recieved.



    Sunday, August 28, 2016 2:34 PM
  • Easy fix was for me.

    all computers prompted pass windows on outlook. this was for a gmail account.

    I had to do is remove the two step verification from the gmail security setting. try it

    Thursday, March 02, 2017 8:47 AM
  • Good stuff
    Sunday, November 26, 2017 7:31 PM