none
Sorry, we're having trouble reaching the server. RRS feed

  • Question

  • I am trying to add a Farm admin but I get
    "Sorry, we're having trouble reaching the server."

    When I go and add a primary / secondary site collection administrator in Central admin, it works.
    When I am in a web application that is not Central admin, it works.

    I can type in: domain\username and that works.

    I just dont get a list of users when I type in names of people.

    best regards,
    Olafur Johannsson

    Wednesday, April 10, 2013 11:23 AM

All replies

  • Hi Olafur.

    Does the Application event log give you any, errors, warning etc when you start typing in the name and when i guess you get the "Sorry, we're having trouble reaching the server"?
    You could also check the Applications and service logs - Microsoft - SharePoint Product within Event Viewer that perhaps tell you/us more about the issue.

    /Philip

    Wednesday, April 10, 2013 12:04 PM
  • Event id 3

    WebHost failed to process a request.

    Sender Information: System.ServiceModel.ServiceHostingEnvironment+HostingManager/10158233

    Exception: System.ServiceModel.ServiceActivationException: The service '/_vti_bin/client.svc' cannot be activated due to an exception during compilation.  The exception message is: A binding instance has already been associated to listen URI 'http://server.domain.is:2013/_vti_bin/client.svc'. If two endpoints want to share the same ListenUri, they must also share the same binding object instance. The two conflicting endpoints were either specified in AddServiceEndpoint() calls, in a config file, or a combination of AddServiceEndpoint() and config. . ---> System.InvalidOperationException: A binding instance has already been associated to listen URI 'http://server.domain.is:2013/_vti_bin/client.svc'. If two endpoints want to share the same ListenUri, they must also share the same binding object instance. The two conflicting endpoints were either specified in AddServiceEndpoint() calls, in a config file, or a combination of AddServiceEndpoint() and config.

       at System.ServiceModel.Description.DispatcherBuilder.InitializeServiceHost(ServiceDescription description, ServiceHostBase serviceHost)

       at System.ServiceModel.ServiceHostBase.InitializeRuntime()

       at System.ServiceModel.ServiceHostBase.OnOpen(TimeSpan timeout)

       at Microsoft.SharePoint.Client.Services.MultipleBaseAddressWebServiceHost.OnOpen(TimeSpan timeout)

       at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)

       at System.ServiceModel.ServiceHostingEnvironment.HostingManager.ActivateService(ServiceActivationInfo serviceActivationInfo, EventTraceActivity eventTraceActivity)

       at System.ServiceModel.ServiceHostingEnvironment.HostingManager.EnsureServiceAvailable(String normalizedVirtualPath, EventTraceActivity eventTraceActivity)

       --- End of inner exception stack trace ---

       at System.ServiceModel.ServiceHostingEnvironment.HostingManager.EnsureServiceAvailable(String normalizedVirtualPath, EventTraceActivity eventTraceActivity)

       at System.ServiceModel.ServiceHostingEnvironment.EnsureServiceAvailableFast(String relativeVirtualPath, EventTraceActivity eventTraceActivity)

    Process Name: w3wp

    Process ID: 9400

    I am looking into it unless you know the solution. :)

    I have two SharePoint 2013 Servers in the FARM that are running all the same services.
    Is that the problem?


    Wednesday, April 10, 2013 1:02 PM
  • >>A binding instance has already been associated to listen URI

    I searched with this error, it suggest something wrong with AAM. So could you please post here your AAM entry from Central Administration?

    Friday, April 12, 2013 3:00 AM
  • I have had the same error but on "normal" web applications AND Central Administration. 

    I was able to solve this by deactivating and re-activation "HTTP Activation" features of .NET 3.5 and .NET 4.5 in der Windows OS Server Manager.

    Here is my blog post:

    http://blog.karstein-consulting.com/2014/02/18/sharepoint-2013-people-picker-error-sorry-were-having-trouble-reaching-the-server/

    Regards
    Ingo


    Microsoft Certified Master - SharePoint 2010

    • Proposed as answer by BlueSky2010 Wednesday, June 15, 2016 7:15 PM
    Friday, February 21, 2014 8:05 AM
  • Hi Olafur,

    please try to access your Central Administration without the domain name. Instead of http://server.domain.is:2013 please use http://server:2013.

    Regards Jürgen

    • Proposed as answer by Shane Morgan Wednesday, May 9, 2018 10:34 PM
    Wednesday, April 9, 2014 8:57 AM
  • Old case, but found new reason:

    If you are using host named site collections and the hosting web site has IIS wild card "*" enabled this will cause the error. Remove wild card.

    • Proposed as answer by Stephan Bren Wednesday, December 20, 2017 2:25 PM
    Wednesday, May 17, 2017 4:12 PM
  • Old case, but found new reason:

    If you are using host named site collections and the hosting web site has IIS wild card "*" enabled this will cause the error. Remove wild card.

    Thank you so much! It worked!
    Wednesday, December 20, 2017 2:12 PM
  • Thanks Jürgen! :)
    Wednesday, May 9, 2018 10:34 PM