none
Metro UI apps in Windows 8 does not work after joining to domain Why???

    Question

  • I have installed Windows 8 recently and I created a Live account. Before joining to my domain, all apps in Metro UI works fine (Mail, Calendar, People, SkyDrive, ...).

    After joining to domain, they are not working.

    Friday, August 17, 2012 2:25 PM

Answers

All replies

  • Same here?  thoughts?
    Friday, August 17, 2012 9:19 PM
  • Exactly the same issue here. Had it with the RC, now on RTM.  Something to do with network isolation?
    Saturday, August 18, 2012 2:01 PM
  • Was about to try this on Monday. Thanks for saving me the trouble.

    All our students have Microsoft accounts, so I thought a domain sign-on would populate all metro apps with skydrive/mail/calendar etc.

    Gonna take extra work?

    Sunday, August 19, 2012 9:36 PM
  • Have a look at the following thread from the Consumer Preview. http://social.technet.microsoft.com/Forums/en-US/W8ITProPreRel/thread/acc45e6e-86fe-4928-9f33-429ce8bebc8f. I suspect a number of the options are still equally valid following the RTM release, they certainly were in our environment here. You must of course fulfil the screen resolution pre-requisite as well as any other, but Group Policy settings that are incompatible with Windows 8 UI is the most likely culprit in all of this. I've yet to see a comprehensive list of all settings that could break the UI.

    Best regards,

    Digitus0_0


    Jan

    Monday, August 20, 2012 9:10 AM

  • Hi,

    Please check and adjust the network isolation settings referring to the following document and see if it works:

    Isolating Metro Style Apps on Your Network
    http://technet.microsoft.com/en-us/library/hh831418.aspx

    Hope this helps.

    Thanks.


    Nicholas Li

    TechNet Community Support

    Wednesday, August 22, 2012 10:38 AM
    Moderator
  • I am running Windows 8 Pro x64 RTM.

    Earlier today I joined my existing Windows Server 2008 R2 domain.

    I also changed my Windows-Live password.

    Now, when I attempt to enter the metro store, the store splash screen comes up and just as quickly disappears.  When I attempt start one of the metro apps I purchased before today, The metro tile moves a bit and then goes back to normal.

    So, when I setup the metro store app, my windows-live account had another password.  After I changed the password, I modified the password in the personality setup.

    I tried procedures stated in this forum, to no avail.  I logged on to my local machine user ID, but that didn't help either.

    Any acceptable solution needs to keep the machine and the user in my domain.  Afterall, this is the "Pro" version.

    Does anyone have a solution to this problem?


    - Michael Faklis

    Tuesday, September 11, 2012 2:23 AM
  • Try this to fix (this can destroy your Start Screen latout - unless you've sync'ed it to Microsoft):

    (may be you can just skip this step ....) Login with your domain user account > disconnect your domain account from your Microsoft > logoff (valid: i.e. all your roaming data was sync'ed)

    Login as administrator on your workstation and delete the local profile for your user account just above. Logout of administrator account.

    Login with your domain user account again. Setup the relationship with your Microsoft Account again. Try out an app and the appstore.

    ... the background for doing it this way is - that a lot of the WinRT stuff is cached into the local part of the profile. Remember WinRT roams to Microsoft servers - not your private cloud in your local Network. This way, at least the local profile is recreated if it got messed up for some reason I don't know. But it may take you back to something that works ...


    Wednesday, September 12, 2012 1:47 AM
  • I've opened a tech incident request yesterday.  I'll post when MS provides a solution.

    - Michael Faklis

    Thursday, September 13, 2012 10:24 PM
  • I spent the last week with MS incident expert for Win8.  He extracted some logs and then discussed it with the Win 8 development team.  They acknowledged they didn't test this scenario, but will work to post a fix by the release date (Oct 23?).

    In the mean while I built a couple virtual Win 8 Pro images, and they had no problem joining the domain.  However my scenario included starting with a MS Live ID, moving to a local log on, changing the password on my Live ID, and then joining the domain.

    As in a referenced thread stated earlier, I also believe a culprit may be group policy.  I have a Windows Server 2008 R2 domain server which knows nothing of Win 8 or Win Server 2012.  Applying group policy after joining the domain does result in some unpredictable settings.

    MS will let me know when they solve this and I will post the solution here.  Be patient.  The official release is still a month away.


    - Michael Faklis

    Saturday, September 22, 2012 7:57 PM
  • Hi all,

    Well I have gone through every possible workaround and suggestion available on the net. To no avail.

    I have however noticed one thing, I do not know if this would help or that it even makes sense. Before I joined the computer to a domain all Metro Apps worked fine. I opened up My computer and there is a Home Group option with my live ID in it. The moment I join a domain, the Home Group option is gone! Everything related to home groups is also unavailable. When you go to control panel and click on home group, it says that you cannot create a home group. Now since metro apps works with home groups (well your live id and all), could this relate to the Metro apps not working? It is a long shot but I think the simpler signs would point everyone in the right direction rather than going in depth and trying to fix issues where there is no real problem to start with?

    My conclusion thus that Metro apps may be totally dependant on the homegroup functionality....

    Wednesday, October 03, 2012 8:03 AM
  • Even though I really don't think this was the answer I did recreate a homegroup and that by itself didn't work.  While several people have pointed at the GP I've added this to a domain with no GP and had no better results.  I wonder if it isn't so much that something is set wrong but that something is missing?  It needs the Server 2012 GP extensions?  Anyways, I mostly replied so that I could get notified if someone else posts a solution on this thread, because Michael Falkis has come the closest to any solution :)
    Tuesday, October 16, 2012 8:20 PM
  • I've been doing my own testing while waiting for MS to get back to me on my incident report, for the App Store and metro apps being disabled upon joining a domain.

    I installed Windows 8 Pro from my Windows Deployment Server.  This route requires providing your domain user/password and that domain user is defined first and the installation is installed into the domain.  Later in the install, it asks for a local user/password.  The machine is already joined to the domain, since it wasn't installed into a workgroup.

    The machine is in the domain, and the App Store and all Metro Apps function flawlessly!

    I had many failed attempts.  For some unknown and non-disclosed reason I couldn't upgrade from Windows 7 Ultimate x64.  Also, I was unable to install directly into the domain from a DVD, with no reason disclosed.

    I did testing with Windows Server 2012 Standard.  The App Store is disabled by design.  You also cannot personalize (say your login photo), and that is also be design.  I had an early test where I upgraded Windows 2008 R2 to Windows Server 2012 and I had full access to the App Store, however I was unable to repeat.  MS must have closed the process that allowed the App Store to be installed in an upgrade.

    I believe the problem as I originally reported it is still a serious problem for professional users in a domain.  Some corporate users may have a undesirable surprise when the App Store and Metro apps are disabled after an upgrade to Windows 8 Pro.

    I will post the solution to that problem as soon as MS gives it to me. 


    - Michael Faklis

    Thursday, October 18, 2012 9:34 PM
  • My SBS 2011 Standard-based domain does have a group policy.  It seems to be ignorant of Windows 8 and Server 2012 which I hope MS provides an update to fix.  One problem is that the group policy disables windows 8 from the adding features applet in control panel -> Programs and Features.  It sets the keys shown below to "1", so I have a .reg file to set them back to zero when I need to get into the features function.

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Programs]
    "NoWindowsMarketplace"=dword:00000000
    "NoWindowsFeatures"=dword:00000000

    I recall finding other post-group policy problems, but I can't recall the specifics at this time.


    - Michael Faklis

    Friday, October 19, 2012 2:13 PM
  • Hi Michael -

    I just wanted to direct you to another thread on this subject, as I believe I may have found a workable solution to the Metro Apps not working in the Domain Scenario.

    http://social.technet.microsoft.com/Forums/en-US/w8itprogeneral/thread/f81b5362-0a92-4fbb-b5ab-6720aa5eb697/

    Best regards,
    Simon.

    Saturday, January 05, 2013 12:10 PM
  • I manged to make it work

    previously tried to delete manually and from registry but no success!!!

    now from Control Panel > System > Advanced I deleted the profile of the users not working and then re-entered in the system

    hope it solves your issue too


    Evan Camilleri http://www.holisticrd.com http://www.dotnetmushroom.com http://www.mobilesalesman.com

    Tuesday, February 05, 2013 7:12 PM
  • After a month of messing around with Windows 8 and our SBS 2008 domain I got Windows 8 Pro installed and Metro applications now work and I really cannot believe what the fix was, all I can say is that it is a major Windows 8 bug.

    Initially I tried upgrading our Windows Vista machines to Windows 8 but would that there were only a few tiles on the metro interface (IE, Store, Desktop) but when clicking the store it just opened and closed with the following errors being written to the error logs:

    SYSTEM LOG:
    > Unable to start a DCOM Server: Windows.Store as Unavailable/Unavailable. The error:  "2" Happened while starting this command: "C:\Windows\System32\WWAHost.exe" -ServerName:Windows.Store

    APPLICATION LOG
    > Activation of application winstore_cw5n1h2txyewy!Windows.Store failed with error: The system cannot find the file specified. See the Microsoft-Windows-TWinUI/Operational log for additional information.

    > App winstore_cw5n1h2txyewy!Windows.Store did not launch within its allotted time.

    I took an image on my built PC and tried and tried to make it all work and everything I was reading on the internet said it was down to Group Policy.
    In the end I had totally disabled our Group Policy objects and still had the same issue.

    As part of my setup I had added Authenticated Users to the local Administrators group on the PC (so that any user logging in to the domain had local admin rights) and I didn't expect this to be the issue but turns out that it was.
    This is very worrying as I would have through this was something that a large number of companies do to give full rights to their end users.

    THIS IS WHAT RESOLVED THE ISSUE ON 12 PC'S FOR ME

    WINDOWS UPGRADES

    • Make sure that Authenticated Users in added to the local Power Users group (Right click COMPUTER, Choose MANAGE, LOCAL USERS AND GROUPS)
    • Make sure that Authenticated Users and Domain Users are NOT a member of the local Administrators group (Right click COMPUTER, Choose MANAGE, LOCAL USERS AND GROUPS)
    • Run the Upgrade

    CLEAN INSTALLATION

    • Install Windows 8
    • Login as a LOCAL ACCOUNT (With Administrator rights as default)
    • Make sure that Authenticated Users in added to the local Power Users group (Right click COMPUTER, Choose MANAGE, LOCAL USERS AND GROUPS)
    • Make sure that Authenticated Users and Domain Users are NOT a member of the local Administrators group (Right click COMPUTER, Choose MANAGE, LOCAL USERS AND GROUPS)
    • Add the computer to the domain and reboot when prompted
    • Login as the domain user

    Once you have done this you can then add Authenticated Users to the local Administrators group and everything seems fine.

    Hope this helps others as I know it was driving me mad and there are so many posts for this and similar issues.


    Sunday, February 17, 2013 1:48 PM
  • What worked for us.

    We currently have Firewall and UAC turned off in our ou's. we created a new ou and re-enabled those features. Before we add a machine to the domain we will create the computer object in this new ou. Then add the machine to the domain. This worked for us using 2008 r2 domain controllers.

    Thursday, April 04, 2013 7:49 PM
  • Brilliant - This is the one -

    Yes, you need UAC and the firewall to be on.

    What I found, is the old trick with win7,vista,xp of adding ntauthority\authenticated users to the administrators group STOPS windows 8 metro apps (and others like pc settings)

    Just add it to the domain, then once on the domain, individually add the users into the administrators group.


    Wednesday, March 26, 2014 8:13 AM