none
Unable to add node in Existing DAG - Exchange 2013 CU19 RRS feed

  • Question

  • Hi,

    I have exchange 2013 with 3 nodes membership. all the mailboxes are with same OS and same CU of exchange.

    NICs are alreeady checked. binding is checked.

    replication network is down in order. no gateway on replication NW. 

    recently i have created another mailbox server 04, while trying to add the additional node in existing DAG setup it is giving me error:

    WriteError! Exception = Microsoft.Exchange.Cluster.Replay.DagTaskOperationFailedException: A server-side database availability group administrative operation failed. Error The operation failed. CreateCluster errors may result from incorrectly configured static addresses. Error: An error occurred while attempting a cluster operation. Error: Cluster API failed: "AddClusterNode() (MaxPercentage=12) failed with 0x800706d3. Error: The authentication service is unknown". ---> Microsoft.Exchange.Cluster.Shared.ClusterApiException: An error occurred while attempting a cluster operation. Error: Cluster API failed: "AddClusterNode() (MaxPercentage=12) failed with 0x800706d3. Error: The authentication service is unknown" ---> System.ComponentModel.Win32Exception: The authentication service is unknown.

    GetRemoteCluster() for the mailbox server failed with exception = An error occurred while attempting a cluster operation. Error: Cluster API failed: "OpenCluster(SHJDV-EXMBX04.deg.com) failed with 0x6d9. Error: There are no more endpoints available from the endpoint mapper". This is OK.
    [2019-06-30T20:09:55] Ignoring previous error, as it is acceptable if the cluster does not exist yet.


    System Administrator

    Monday, July 1, 2019 7:05 AM

All replies

  • Need your support to resolve this issue. 

    waiting to hear from exchange experts guys...


    System Administrator

    Tuesday, July 2, 2019 4:49 AM
  • Hi Irfan,

    >>CreateCluster errors may result from incorrectly configured static addresses. 

    Do you have a static IP set for the DAG? Or is it picking from DHCP? You may have a look at the following article which described a similar issue and see whether it applies to your situation:

    Unable to configure Exchange 2010 Database Availability Group Membership

    You may also check and make sure Exchange trusted subsystem is added to local admin group.

    >>binding is checked

    Make sure the bind order was set to MAPI network first, ensuring the Replication network was last.

    Regards,
    Steve Fan


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Tuesday, July 2, 2019 6:26 AM
    Moderator
  • Hi Steve,

    I have static IP in dag. DAG is working fine for the existing setup which contains 3 mailbox servers. 

    Exchange trusted subsystem is already added in all mailbox server local admin group

    Binding is checked. Mapi is first in order and then MAPI network. 

    I have removed the network adapters from new mailbox and added again. Ran the add-mailboxdatabase group command and now getting a new error:

    [2019-07-02T09:46:35] WriteError! Exception = Microsoft.Exchange.Cluster.Replay.DagTaskOperationFailedException: A server-side database availability group administrative operation failed. Error The operation failed. CreateCluster errors may result from incorrectly configured static addresses. Error: An error occurred while attempting a cluster operation. Error: Cluster API failed: "AddClusterNode() (MaxPercentage=12) failed with 0x800706d3. Error: The authentication service is unknown". ---> Microsoft.Exchange.Cluster.Shared.ClusterApiException: An error occurred while attempting a cluster operation. Error: Cluster API failed: "AddClusterNode() (MaxPercentage=12) failed with 0x800706d3. Error: The authentication service is unknown" ---> System.ComponentModel.Win32Exception: The authentication service is unknown
       --- End of inner exception stack trace ---
       at Microsoft.Exchange.Cluster.ClusApi.AmCluster.AddNodeToCluster(AmServerName nodeName, IClusterSetupProgress setupProgress, IntPtr context, Exception& errorException, Boolean throwExceptionOnFailure)
       at Microsoft.Exchange.Cluster.Replay.DagHelper.AddDagClusterNodeInternal(HaTaskStringBuilderOutputHelper output, AmServerName mailboxServerName, String& verboseLog)
       --- End of inner exception stack trace (Microsoft.Exchange.Cluster.Shared.ClusterApiException) ---
       at Microsoft.Exchange.Cluster.Replay.DagHelper.ThrowDagTaskOperationWrapper(Exception exception)
       at Microsoft.Exchange.Cluster.Replay.DagHelper.AddDagClusterNodeInternal(HaTaskStringBuilderOutputHelper output, AmServerName mailboxServerName, String& verboseLog)
       at Microsoft.Exchange.Cluster.Replay.NodeActionTracker.PerformNodeAction(ITaskOutputHelper output, AmServerName nodeName, NodeAction nodeAction, Action clusterAction)
       at Microsoft.Exchange.Cluster.Replay.DagHelper.AddDagClusterNode(AmServerName mailboxServerName, String& verboseLog)
       at Microsoft.Exchange.Data.Storage.Cluster.HaRpcExceptionWrapperBase`2.RunRpcServerOperation(String databaseName, RpcServerOperation rpcOperation)
       --- End of stack trace on server (SHJDV-EXMBX03.deg.com) ---
       at Microsoft.Exchange.Data.Storage.Cluster.HaRpcExceptionWrapperBase`2.ClientRethrowIfFailed(String databaseName, String serverName, RpcErrorExceptionInfo errorInfo)
       at Microsoft.Exchange.Cluster.Replay.ReplayRpcClientWrapper.RunRpcOperation(AmServerName serverName, Nullable`1 dbGuid, Int32 timeoutMs, IHaRpcExceptionWrapper rpcExceptionWrapperInstance, InternalRpcOperation rpcOperation)
       at Microsoft.Exchange.Cluster.Replay.ReplayRpcClientWrapper.RunAddNodeToCluster(AmServerName serverName, AmServerName newNode, String& verboseLog)
       at Microsoft.Exchange.Management.SystemConfigurationTasks.AddDatabaseAvailabilityGroupServer.JoinNodeToCluster()
    [2019-07-02T09:46:35] InternalProcessRecord() hit: Microsoft.Exchange.Cluster.Replay.DagTaskOperationFailedException: A server-side database availability group administrative operation failed. Error The operation failed. CreateCluster errors may result from incorrectly configured static addresses. Error: An error occurred while attempting a cluster operation. Error: Cluster API failed: "AddClusterNode() (MaxPercentage=12) failed with 0x800706d3. Error: The authentication service is unknown". ---> Microsoft.Exchange.Cluster.Shared.ClusterApiException: An error occurred while attempting a cluster operation. Error: Cluster API failed: "AddClusterNode() (MaxPercentage=12) failed with 0x800706d3. Error: The authentication service is unknown" ---> System.ComponentModel.Win32Exception: The authentication service is unknown
       --- End of inner exception stack trace ---
       at Microsoft.Exchange.Cluster.ClusApi.AmCluster.AddNodeToCluster(AmServerName nodeName, IClusterSetupProgress setupProgress, IntPtr context, Exception& errorException, Boolean throwExceptionOnFailure)
       at Microsoft.Exchange.Cluster.Replay.DagHelper.AddDagClusterNodeInternal(HaTaskStringBuilderOutputHelper output, AmServerName mailboxServerName, String& verboseLog)
       --- End of inner exception stack trace (Microsoft.Exchange.Cluster.Shared.ClusterApiException) ---
       at Microsoft.Exchange.Cluster.Replay.DagHelper.ThrowDagTaskOperationWrapper(Exception exception)
       at Microsoft.Exchange.Cluster.Replay.DagHelper.AddDagClusterNodeInternal(HaTaskStringBuilderOutputHelper output, AmServerName mailboxServerName, String& verboseLog)
       at Microsoft.Exchange.Cluster.Replay.NodeActionTracker.PerformNodeAction(ITaskOutputHelper output, AmServerName nodeName, NodeAction nodeAction, Action clusterAction)
       at Microsoft.Exchange.Cluster.Replay.DagHelper.AddDagClusterNode(AmServerName mailboxServerName, String& verboseLog)
       at Microsoft.Exchange.Data.Storage.Cluster.HaRpcExceptionWrapperBase`2.RunRpcServerOperation(String databaseName, RpcServerOperation rpcOperation)
       --- End of stack trace on server (SHJDV-EXMBX03.deg.com) ---
       at Microsoft.Exchange.Configuration.Tasks.Task.ThrowError(Exception exception, ErrorCategory errorCategory, Object target, String helpUrl)
       at Microsoft.Exchange.Configuration.Tasks.Task.WriteError(Exception exception, ErrorCategory category, Object target)
       at Microsoft.Exchange.Management.SystemConfigurationTasks.HaTaskOutputHelper.WriteErrorEx(Exception error, ErrorCategory errorCategory, Object target)
       at Microsoft.Exchange.Management.SystemConfigurationTasks.AddDatabaseAvailabilityGroupServer.JoinNodeToCluster()
       at Microsoft.Exchange.Management.SystemConfigurationTasks.AddDatabaseAvailabilityGroupServer.InternalProcessRecord()
    [2019-07-02T09:46:35] Updated Progress 'Done!' 100%.
    [2019-07-02T09:46:35] COMPLETED
    add-databaseavailabiltygroupserver explicitly called CloseTempLogFile().


    System Administrator

    Tuesday, July 2, 2019 10:07 AM
  • Do you have static DNS records for any of the servers? If so configure the MAPI NICs to register with DNS and remove the static records.
    Tuesday, July 2, 2019 6:22 PM
  • Hi EK,

    MAPI nics are already configured to register with DNS record. 


    System Administrator

    Wednesday, July 3, 2019 5:05 AM
  • Hope it is not too late..

    Someone has shared the solution for this issue:

    Stopped the windows firewall service on both machines and set the startup to disabled. Rebooted the 2 exchange servers and re-add the server to the DAG.

    Regards, 

    Manu Meng


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Wednesday, July 17, 2019 2:03 PM
    Moderator