none
Why can't I make entries in the custom column I added to a Sharepoint Library? RRS feed

  • Question

  • I created a custom column under Library Tools > Library > Create Column (and also via Site Settings > Site columns).  I've tried a Yes/No checkbox column and a Choice column.  Then I add the column using Modify View.  The column appears in my Library list, but there is no way for me to actually enter any data in it.  No checkbox or input option appears no matter what I do.  And the column doesn't appear in the Edit Properties dialogue box associated with each Library entry.

    Has anybody dealt with this and found a solution?

    Thanks!

    Friday, February 19, 2016 5:43 PM

Answers

  • Hi Linda,

    Have you customized the list forms using InfoPath before?

    If yes, you need to customize the form again. Only adding columns in list couldn’t affect the custom list form.

    If no, you should delete the column and create it again. As John said, please make sure “Add to all content types“ is checked.

    Best Regards,

    CY


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Monday, February 22, 2016 6:32 AM
    Moderator

All replies

  • Off hand it sounds like a content type issue, although it's hard to be specific. Is it possible you've added the field to one content type, but then are not editing that same content type when you trying to fill that field in?

    Friday, February 19, 2016 6:07 PM
  • If you have created a site column, then you should add it to the content type.

    - Go to library settings.

    - Click on Advanced Settgins

    - Select "Yes" for allow content types(First question).

    - click ok.

    Now under content types click on the name and click add from existing site columns. select your column and add it.

    Open your form, the column will appear.

    Hope this helps.




    • Edited by ViviSP Friday, February 19, 2016 7:03 PM
    Friday, February 19, 2016 7:03 PM
  • Thanks.  I followed these steps and the column does appear (had already gotten that far) but I'm unable to add any info to the column. I suspect the problem may be related to the fact that the "Used in" field is empty for this column (in Library Settings > Columns).  Any idea how to get this populated?
    Friday, February 19, 2016 7:21 PM
  • Sounds like what I suspected. In the settings page see what the default content type is for that library. What are the other content types listed? If adding a column is causing this much trouble I wonder if the complexity is necessary.

    When you add documents to the library, how do you do it?

    When you click Create Column, make sure you leave the "Add to all content types" box checked at the bottom.

    Friday, February 19, 2016 7:30 PM
  • Hi Linda,

    Have you customized the list forms using InfoPath before?

    If yes, you need to customize the form again. Only adding columns in list couldn’t affect the custom list form.

    If no, you should delete the column and create it again. As John said, please make sure “Add to all content types“ is checked.

    Best Regards,

    CY


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Monday, February 22, 2016 6:32 AM
    Moderator