none
Outlook 2010 x32 on Windows 7 x64 - No signature editing capability

    Question

  • I have Office Professional Plus 2010 x32 after having Office Profesional Plus x64  The signatures worked under x64 but not under x32 1office.  I uninstalled x64 office due to compatibility problems with other applications.  The x32 plays better with other apps but will not let me edit signatures.  Any thoughts?  I saw a workaround posted but I could not find a signatures folder under users\... etc.
    Tuesday, August 03, 2010 3:25 PM

Answers

All replies

  • Hi,

    You may use VBA to insert Outlook Signature in mail.

    You can add signature within an plain message or add HTML signature within an HTML message.

    For more information about how to do this via VB script, please refer to this article:

    http://www.rondebruin.nl/mail/folder3/signature.htm

    Hope it does help.

    Wednesday, August 04, 2010 8:18 AM
    Moderator
  • Try the steps below...

    1. Go to  Start > Search an type in regedit and hit enter
    2. Browse out to HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Wow6432Node\CLSID\{0006F03A-0000-0000-C000-000000000046}\LocalServer32
    3. Right click on the Default key and make sure the value reads "C:\PROGRA~2\MICROS~1\Office14\OUTLOOK.EXE" without the quotes
    4. Close the registry, reboot and try the signatures tab again

    Doakm(MSFT)

    Thursday, September 02, 2010 6:20 PM
  • Try the steps below...

    1. Go to  Start > Search an type in regedit and hit enter
    2. Browse out to HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Wow6432Node\CLSID\{0006F03A-0000-0000-C000-000000000046}\LocalServer32
    3. Right click on the Default key and make sure the value reads "C:\PROGRA~2\MICROS~1\Office14\OUTLOOK.EXE" without the quotes
    4. Close the registry, reboot and try the signatures tab again

    Doakm(MSFT)


    I have the same problem.  In Outlook Options - Mail Tab, clicking on the Signatures or the Stationary and Fonts buttons does nothing, click Reading Pane (the very next button) and the proper dialog displays.  Also, clicking in the Message Window Ribbon - Signature button does nothing.  I initially had 64 bit Office installed, but since have removed that and installed the 32 bit for 3rd party software to work.  My software is Microsoft Office Professional Plus 2010 Version: 14.0.4760.1000 (32-bit) on Windows 7 Home Premium 64-bit.

    I tried the steps above and made a change from
    C:\PROGRA~2\MICROS~2\Office14\OUTLOOK.EXE to
    C:\PROGRA~2\MICROS~1\Office14\OUTLOOK.EXE
    Close the registry and reboot with no change in the problem.

    Thanks for any advice.

    Tuesday, September 14, 2010 6:33 PM
  • When you get a chance change the data value to the path below and reboot the machine.

    C:\Program Files (x86)\Microsoft Office\Office14\Outlook.exe

    Also take a look at HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{0006F03A-0000-0000-C000-000000000046} and see if you have the key LocalServer32. If so change the data value there.

    Doakm(MSFT)

    Wednesday, September 15, 2010 5:28 PM
  • Thanks for your reply.  My data value is currently listed as below.  Are you saying that it should be C:\Program Files (x86)\Microsoft Office\Office14\Outlook.exe instead?

    "ykG^V5!!!!!!!!!MKKSkOUTLOOKFiles>U3iokj@Ji?5v2bfyv=F,
    "

    I made that change and after a reboot tried to open the Signatures dialog with no luck.

    Wednesday, September 15, 2010 5:36 PM
  • Yeah on a clean Win7 x64 box the data value should be C:\PROGRA~2\MICROS~1\Office14\OUTLOOK.EXE but you can also use C:\Program Files (x86)\Microsoft Office\Office14\Outlook.exe

    Did you also look at the HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{0006F03A-0000-0000-C000-000000000046} key?

    Doakm(MSFT)

    Wednesday, September 15, 2010 8:03 PM
  • That fixed it.  I hadn't recognized that there were two different registry key paths that were suggested.  So in order to document the resolution to the issue, I am describing the changes that were made.

    HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Wow6432Node\CLSID\{0006F03A-0000-0000-C000-000000000046}\LocalServer32
    and
    HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{0006F03A-0000-0000-C000-000000000046}\LocalServer32
    Change both (Default) and LocalServer32 values in each to C:\Program Files (x86)\Microsoft Office\Office14\Outlook.exe

    Mine were somehow corrupt with these values:
    HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Wow6432Node\CLSID\{0006F03A-0000-0000-C000-000000000046}\LocalServer32
    (Default) was C:\PROGRA~2\MICROS~2\Office14\OUTLOOK.EXE
    LocalServer32 was ykG^V5!!!!!!!!!MKKSkOUTLOOKFiles>U3iokj@Ji?5v2bfyv=F,
    and
    HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{0006F03A-0000-0000-C000-000000000046}\LocalServer32
    (Default) was (value not set)
    LocalServer32 was w_1^V8!!!!!!!!!MKKSkOUTLOOKFiles>tW{~$4Q]c@zPX6FxaTO5

    Thank you Doakm for your help.

    • Proposed as answer by AngelMarc Thursday, November 14, 2013 1:59 PM
    Thursday, September 16, 2010 8:00 PM
  • Thank you - it worked for me, too! FYI techs at Microsoft have been telling me they are working on a fix.  They should read this column.
    Sunday, September 26, 2010 8:30 PM
  • I've been going round and round on this issue and now it's fixed thanks to you folks. THANK YOU! And happy holidays (now I can change my font to something more festive).
    Monday, November 22, 2010 9:49 PM
  • I have run into this issue on Outlook 2010 x32 on Windows 7 x32bit with the no signature editing capability as wel as the stationary and fonts. Those keys mentioned do not exisit and no 64 bit office has been installed. Tried adding those registry entries to see if they have any effect on the situation, which they do not. Have tried outlook /safe with no effect either.

     

    Thoughts towards this?

    Saturday, December 11, 2010 1:48 AM
  • Unfortunately, still broken for me after updating **both** keys. Both were corrupt.

    Any other tips?

    (Note: I installed Office x86 after uninstall x64, so I'm guessing this problem is related.)

    Sunday, February 06, 2011 12:51 AM
  • OK, I got it working by paying slightly closer attention. :)

    Each of the two registry keys has two values: \LocalServer32 and \Default. In one of the keys, I had changed \Default but not \LocalServer32.

    Restarting Outlook was enough for the fix to work...no need to reboot. Thanks for your help, guys!

    Sunday, February 06, 2011 12:55 AM
  • Found your fix - tried it and it WORKED!!!  YIPPEE!!  MM

     

    Friday, February 25, 2011 12:13 AM
  • I createed an automated fix for this issue using C# and uploaded the exe file to here. You will need .NET 4.0 which you should be directed to if it does not already exist on your computer. Also, the app must be run as administrator. This fix is only for those currently running Win 7 and Office 2010 x86 and is meant to fix the registry corruption resulting from downgrade from x64 Office 2010.

    If the form proportions a a bit off on your computer, I apologize, but it was my first time fooling around with WPF and I wasn't going to spend an eternity on the aesthetics of this app. Also, I cannot be held responsible for any issues it may cause with your computer. The app will check to see if it appears the problem mentioned in this thread is what you have and will then make changes to the registry if you click the "Fix" command.

    PLEASE BACKUP YOUR REGISTRY BEFORE YOU ATTEMPT A FIX.

     

    http://hotfile.com/dl/120825940/f474385/OfficeRegistryFix.zip.html

     

    Kindest Regards,

     

    Peter


    Peter
    Monday, June 13, 2011 8:49 PM
  • Hi Sam,

    Did you ever gain resolution to you problem?  I am having the same one.

    The fix worked great on windows XP-32 and Office 2007, but not on a XP-64 and Office 2007, or win7-32 and office 2007 because the {0006F03A(...) key doesn't exist.

    I will continue to search the forum with high hopes...

    Thanks,

    AJ

    Thursday, March 07, 2013 8:54 PM
  • Thank you!!

    It worked on a terminal server 2008 R2 with Outlook 2013 64 bit.

    Office is 64 bit but the value MUST be wrote in Wow3264Node too.

    HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Wow6432Node\CLSID\{0006F03A-0000-0000-C000-000000000046}\LocalServer32
    (Default) was empty.

    When I wrote the value  C:\PROGRA~1\MICROS~1\Office15\OUTLOOK.EXE the windows for signature works!

    Thanks again

    Thursday, July 27, 2017 10:22 AM