none
Volume Shadow Copy Services trying to backup a file that does not exist RRS feed

  • Question

  • Hi.
    This is my 1st post on the Technet forums, so my apologies in advance if I'm not posting this on the right forum. I've had a big dilemma whether to post here or at the ACT forums, hopefully I'll explain myself well enough for you to understand why.

    Since VSS is a Microsoft OS component I have decided to post it here. In our company we use EMC Networker as an enterprise-wide backup solution. Networker can only backup Windows Vista and Server 2008 using VSS. I have encoutered the following problem on all but 1 of my Vista/2008 computers (this amounts to the grand total of 5, luckily). When Networker initiates the VSS System Writer and tries to back-up files, at some point, VSS returns the following error to the Networker server:

    "System Writer - Error saving file path C:\windows\system32\drivers\somefile.ext that is associated with Shadow Copy path \\?\GLOBALROOT\Device\HarddiskVolumeShadowCopy23\windows\system32\drivers\somefile.ext. The system cannot find the file specified. "


    The VSS System Writer then fails and stops it's backup process.

    somefile.ext changes from computer to computer. I can create a blank file with the same name and extension and that'll "solve" the problem, but in most cases I just get the same error for a different non-existent file. This got me thinking: Why is VSS trying to backup a non-existent file? I have managed to list the System Writer metadata using the vsstools in the Windows SDK. The missing files are indeed in the list. I tried finding out how or where the metadata for the System Writer is created, and only found this article (before-last passage) mentioning the several sources, but not how to access or edit them: In-Box VSS Writers. Checked the registry (PnPLockDownFiles and simple search) for mentions of the file. No go. I then found this article: Volume Shadow Copy Service (VSS) System Writer backup fails, and error messages reference nonexistent files in Windows Server 2008 - Since VSS dll versions and file size are the same in Vista and 2008, I think it's safe to deduce that this article is also valid for Vista. In it Microsoft claims that these sort of problems are the result of a faulty Install/Uninstall process of 3rd-party software, and offers the solution of either contacting your vendor or reinstalling the software.

    So whats my problem?
    1 - I want to know if there's a way to edit/affect the System Writer metadata in any way which will not require me to study the a programming language and the VSS API.
    2 - In most of the cases the Software Vendor is, well - Microsoft. Examples are: wdfconinstaller010005.dll (Windows Driver Framework Coinstaller) on Vista and slanaccel.exe (SAN/LAN Virtualization Accelerator service) on Windows 2008.
    3 - Is there a way to cause VSS to throw warnings instead of errors for missing files? Is there a way to tell VSS to ignore missing files completely?

    All help will be appreciated.
    Thanks in advance
    • Edited by Itstuck Monday, March 9, 2009 2:00 PM
    Thursday, March 5, 2009 1:57 PM

All replies

  • we use BE at work and on customers sites and this problem is usually caused when the file is a temp file
    and is there when it starts the process and  is gone before it finishes
    the way we get round this is simply deselect the file or folder from the backup

    Thursday, March 5, 2009 7:33 PM
  • Thanks Todda2008
    But this isn't the case here. This happens no matter when I run the backup, and I've also monitored files created overnight during a backup with Sysinternals File Monitor and those files weren't preset before the backup started, nor were they created during the backup. Besides, at most cases these files are usually in the some kind of system directory (system32, inf, system32\drivers, etc..) which I can't afford to not back up :)

    Thanks for your help though.
    Friday, March 6, 2009 1:10 PM
  • check the permissions for the account that runs the backup against the files
    Friday, March 6, 2009 7:39 PM
  • Thanks again, but the account that runs the backup (Networker has it's own service on client machines) is a Local System account. Other stuff from these folders are being backed up properly until the backup reaches the non-existent files.
    Sunday, March 8, 2009 12:50 PM
  • FROM : http://msmvps.com/blogs/bradley/archive/2008/08/08/top-hyperv-issues-from-the-partner-managed-newsgroups.aspx

    Issue #3
    =======
    PROBLEM:
    ---------------
    Backupexec jobs are giving a warning that "VSS Snapshot waring.  File
    c:\windows\system32\slanaccel.exe in not present on the snapshot."


    RESOLUTION:
    ---------------
    delete the SAN/LAN Transfer Virtual Accelerator service (this won't impact
    the system). After removing this service, it solves the problem.

    To delete the SAN/LAN Transfer Virtual Accelerator service:

    1. Logon as the Administrator.
    2. Click Start>Run>CMD, open the command prompt
    3. Type the following command:

    SC delete slanaccel

    bye

    FOR MORE INFO : http://seer.entsupport.symantec.com/docs/312643.htm

    • Proposed as answer by julgeb Sunday, June 21, 2009 11:04 PM
    • Unproposed as answer by Itstuck Thursday, July 16, 2009 6:47 AM
    Sunday, June 21, 2009 10:40 PM
  • Thanks Julgeb for you reply,
    But this just solves a very specific case in what seems to be a larger issue.
    As a temporary workaround to this problem I've written a small program that create files missing from the file system that exist in the VSS system set file list. It's ugly, but at least backups are running.
    Thursday, July 16, 2009 9:04 AM
  • Hello All,
                
               I am also facinig similar problem. Please see the following logs.
    ------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

    f1barfs.bar.nsn.com:VSS SYSTEM FILESET:\ savegrp: suppressed 3 lines of output.
    f1barfs.bar.nsn.com:VSS SYSTEM FILESET:\ System Writer - Error saving file path C:\windows\inf\display.inf that is associated with Shadow Copy path \\?\GLOBALROOT\Device\HarddiskVolumeShadowCopy27\windows\inf\display.inf. The system cannot find the file specified.
    f1barfs.bar.nsn.com:VSS SYSTEM FILESET:\
    f1barfs.bar.nsn.com:VSS SYSTEM FILESET:\ System Writer - ERROR: Failed to save FileGroup files, writer = System Writer
    f1barfs.bar.nsn.com:VSS SYSTEM FILESET:\ System Writer - Error saving writer System Writer
    f1barfs.bar.nsn.com:VSS SYSTEM FILESET:\ System Writer - ERROR: Aborting backup of saveset VSS SYSTEM FILESET: because of the error with writer System Writer.
    f1barfs.bar.nsn.com:VSS SYSTEM FILESET:\ System Writer - Error saving
    f1barfs.bar.nsn.com:VSS SYSTEM FILESET:\ 7162:(pid 5852): save of VSS SYSTEM FILESET:\ to s4bckserver.bar.nsn.com failed
    ------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

    Can you please let me know how to resolve the issue.

    Note: We are also using   EMC Networker OEM to take backup (as the initial thread).
     
    Thanks
    With Regards
    Hemant.
    Wednesday, August 19, 2009 10:04 AM
  • Hello All,
    the problem with 32-bit server was terminated by vers. Legato NetWorker 7.4.4.
    For servers 64bit SP2 has a similar error on the backup of the "VSS SYSTEM SERVICES: \", solved with this procedure :


    Following are the suggested updates for vss and some basic
    troubleshooting for it:

    a) make sure you have installed http://support.microsoft.com/kb/940349

    b) make sure you have installed  http://support.microsoft.com/kb/934016

    c) make sure you have installed http://support.microsoft.com/kb/951568


    After  


     Action Plan in case of 32 Bit machine;

     =============================

     

    1. net stop vss

     1a. CD %systemroot%\system32

    2. regsvr32 ole32.dll

    3. regsvr32 vss_ps.dll

    4. Vssvc /Register

    5. regsvr32 /i swprv.dll

    6. regsvr32 /i eventcls.dll

    7. regsvr32 es.dll

    8. regsvr32 stdprov.dll

    9. regsvr32 vssui.dll

    10. regsvr32 msxml.dll

    11. regsvr32 msxml3.dll

    12. regsvr32 msxml4.dll

    13. Stop the Following services:

        -  Volume Shadow Copy Service. It should be stopped

        - "MS Software Shadow Copy Provider"

        - "COM+ event system"

        - "COM+ System Application"


    14. Take the backup of the "Subscriptions" key

       HKLM\Software\Microsoft\EventSystem\{26c409cc-ae86-11d1-b616-00805fc79216}\Subscriptions

    15. Delete the "Subscriptions" key

    16. Restart/Start the following services

       - "COM+ event system"

       - "COM+ System Application"

       - "Microsoft Software Shadow Copy Provider"

       - "Volume Shadow Copy"

    17. Reboot the machine.


    Run the command "VSSadmin List Writers" from the command prompt.

    Got the list of the writers and no errors in event log

    Run the Ntbackup (for example)and it worked fine.


     

     Action Plan in case of 64 Bit machine;

     =============================

    1. Net stop vss

    2. Net stop swprv

    3. Got to command prompt

    4. Cd %systemroot%\system32

    5. regsvr32 /i swprv.dll

    6. regsvr32 /i eventcls.dll

    7. regsvr32 vssui.dll

    8. Vssvc /Register

    9. regsvr32 ole32.dll

    10. regsvr32 vss_ps.dll

    11. regsvr32 es.dll

    12. regsvr32 stdprov.dll

    13. regsvr32 msxml3.dll

    14. Cd %systemroot%\syswow64

    15. regsvr32 ole32.dll

    16. regsvr32 vss_ps.dll

    17. regsvr32 es.dll

    18. regsvr32 stdprov.dll

    19. regsvr32 msxml3.dll

    20. regsvr32 msxml.dll

    21. regsvr32 msxml4.dll

    22. Check and Stop the Following services:

       a) Volume Shadow Copy Service. It should be stopped

       b) Microsoft Software Shadow Copy Provider. It should be stopped

       c) COM+ event system

       d) COM+ System Application

    23. Take the backup of the "Subscriptions" key

        HKLM\Software\Microsoft\EventSystem\{26c409cc-ae86-11d1-b616-00805fc79216}\Subscriptions

    24. Delete the "Subscriptions" key.

        Delete just the Subscriptions subkey;

        leave the EventClasses key.

    25. Restart/Start the following services:

        a) COM+ event system

        b) COM+ System Application

        c) Microsoft Software Shadow Copy Provider

        d) Volume Shadow Copy

    26. Reboot the machine.


    Run the Ntbackup (for example)and it worked fine.


    Bye
    Francesco
     

    Thursday, October 1, 2009 3:11 PM
  • I'm a Networker admin also. 

    Create a text file with the same name of the missing file.  VSS finds the file it expects and backups it up, no more error.

    In your example, make a file text file named "C:\windows\system32\drivers\somefile.ext"

    We need some VSS manipulation tools.

    Thursday, November 18, 2010 2:16 PM
  • Same problem here with VSS - except

    Backup Client: Unitrends

    OS: Windows 7 Pro

    Folder/Files that don't exist: Microsoft Office Files.

    Thursday, May 4, 2017 3:08 PM
  • It might be an old post but i am using Networker and i am facing the same issue with one server. The VSS is trying to backup J:\abc\xyz folder. We don't have any J drive in the server.
    Wednesday, June 27, 2018 3:05 PM