none
Outlook 2010 Cannot display the folder. There is not enough free memory to run the program. Quit one or more programs and then try again.

    Question

  • I have seen similar posts to this with no answers. My OS/Office combination seems unique so I am reposting.

    OS: Win 7 x64 4GB Mem

    Office 2010 x64 (I have tried this with the x32 version same result)

    This is a new computer, new office install (new ost). This user has hundreds of folders in outlook. Total ost size is 3.5GB.  I am able to open folders until Outlook gets to about 80MB of memory usage. Total usage on PC at time of failure is about 1.8 GB. Once the failure occurs mail can be opened and read from the inbox, but no subfolders.

    This behavior occurs in safe mode.

    The old computer for this person was Win 7 x32 Office 2007. This problem does not manifest itself in that install.

    Any suggestions appreciated.

    Thursday, July 15, 2010 12:01 AM

Answers

  • Hello Perry,

    this helps...

    <<<

    Start by setting the SharedMemMaxSize registry value as listed below. Under HKLM\SOFTWARE\Microsoft\Windows Messaging Subsystem\Applications\MyApp\ to 0x300000 and see if that provides temporary relief. If the issue reoccurs try setting it to as high as 0x800000

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Messaging Subsystem\Applications\Outlook
    Value Name: SharedMemMaxSize 
    Value Type: REG_DWORD 
    Value Data: <See the table listed below>

    <<<

    My Outlook works now fine...

     

     


    Gruss Peter
    Wednesday, April 20, 2011 6:07 AM

All replies

  • Hi,

     

    Thank you for using Outlook IT Pro Discussions forum. 

     

    From your description, I understand that you are unable to open the folders in the Outlook PST and encounter the following error message: Outlook 2010 cannot display the folder. There is not enough free memory to run the program. Quit one or more programs and then try again. If there is any misunderstanding, please feel free to let me know.

     

    Based on my research, there are several factors that can cause this issue, such as third-party add-ins conflicts or corrupted PST. So, you can try the suggestions below to troubleshoot this issue.

     

    Step 1: Start Outlook by resetting navigation pane

    ============

    Click Start > Run, copy the command in the Run box and press Enter: "C:\Program Files\Microsoft Office\Office 14\Outlook.exe" /resetnavpane

     

    Note: To show the Run command, right click the Start pearl and choose Properties, in the Start menu tab, click Customize button, check the box before Run command.

     

    If the problem persists, try next.

     

    Step 2: Check if third-party add-ins’ conflicts

    =============

    One similar issue is resolved by disabling Business Contact Manager add-in. We can try the steps below to check if it is caused by add-in’s conflicts.

     

    1.       Click Start, point to All Programs, and then point to Microsoft Office.

    2.        Press and hold the CTRL key, and then click Microsoft Outlook.

     

    If the problem does not occur in the safe mode, this issue might be related to some third-party add-ins in the Outlook program, we can try to disable them. Normally, you could do the following to disable the conflict add-ins in your Outlook program:

     

    Disable add-ins

    ***************************

    1.       Click File menu, click OptionsAdd-in, click Go button in the Manage: Com-in Add.

    2.       Check if there are any add-ins, clear the checkbox to disable them.

    3.       Close the Office program and restart it.

    4.       Add one check back each time to the list of Add-In, restart the Office program, and repeat the above procedure. Once the issue reappears again, we can determine which add-in causes this problem and then disable it.

     

    However, if the problem persists in the safe mode, let’s continue.

     

    Step 3: Repair Inbox

    ================

    Please try to use the Inbox Repair tool to repair your PST. For the detailed steps, refer to this KB article:

     

    How to find and run the Inbox Repair tool in Outlook

    http://support.microsoft.com/kb/272227

     

    Please take your time to try the suggestions and let me know the results at your earliest convenience. If anything is unclear or if there is anything I can do for you, please feel free to let me know.

     

    Best Regards,

     

    Sally Tang

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com  

    • Marked as answer by Sally Tang Wednesday, July 21, 2010 5:59 AM
    • Unmarked as answer by Sally Tang Monday, August 23, 2010 5:06 AM
    Friday, July 16, 2010 2:10 AM
  •  

    Hi,

     

    I am writing to see how everything is going with this issue. Is the problem resolved? If there is anything I can do for you, please feel free to let me know.

     

    Best Regards,

     

    Sally Tang

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com   

    Monday, July 19, 2010 9:12 AM
  •  

    Hi,

     

    As I have not heard from you for several days. I will go ahead and close this thread. If this issue is not resolved or you have any questions, please feel free to reply to us and this thread will be re-opened.

     

    Best Regards,

     

    Sally Tang

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com   

    Wednesday, July 21, 2010 5:58 AM
  • Hi, i actually have the same problem as Mark.M  and tried the 3 steps you outlines above with no luck.  Any other suggestions?
    Wednesday, August 18, 2010 11:30 PM
  • Here is a update on this issue. None of the suggestions applied to me, as I stated everything was new. A new computer, a vanilla install, a fresh OST, no other programs installed, and everything working fine on the old computer.

    For me the problem seems to stem from how Outlook handles additional mailboxes. I was premature when I said that the OST was 3.5 GB. It was when I finished my sync and  started testing. What I discovered is that when I added extra mailboxes to this users Outlook. Outlook 2010 actually cached them for offline access. This caused the PST to balloon to over 8GB. This was the cause of my issue, your problem could be something else.

     

    Thursday, August 19, 2010 1:37 PM
  • Hi,

     

    Sorry for the delay.

     

    Caching additional mailboxes or shared folders seems to run into this problem sometimes. You may try to disable caching of email folders or shared folders. For the detailed steps, you can refer to this KB article:

     

    http://support.microsoft.com/kb/2297543

     

    Hope it helps.

     

    Best Regards,

     

    Sally Tang

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com  

     

     

    Monday, August 30, 2010 7:36 AM
  • Hi,

     

    Does it help?

     

    Sally Tang

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com   

     

    Wednesday, September 01, 2010 7:45 AM
  •  

    Hi,

     

    I will go ahead and close this thread. If this issue is not resolved or you have any questions, please feel free to reply to us and this thread will be re-opened.

     

    Best Regards,

     

    Sally Tang

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com   

    Friday, September 03, 2010 7:00 AM
  • I found a resolution to this issue yesterday after experiencing it myself.

    Close Outlook, browse to c:\users\<user name>\appdata\local\microsoft\outlook

    Then delete (or rename) the .ost being used by Outlook (pretty obvious from the size / date modified attributes)

    Re-open Outlook 2010 and a new .ost will automatically be generated.

    This didn't just solve the problem with the out of memory error, I noticed switching speed between mailboxes is much faster.

    Not sure why nobody has suggested this yet on this thread, I see it as a fairly common resolution other places online for various mailbox related issues.

    Cheers

    Wednesday, December 29, 2010 1:57 PM
  • This is not an answer, this is called removing functionality. Most people would assume this issue can be fixed without disabling features.
    Wednesday, December 29, 2010 2:00 PM
  • Hello Sally,

    your link and the action didnt help.

    http://support.microsoft.com/kb/2297543

    Sorry, thats very bad for us.

    Nobody at Microsoft, with any help?

    The problem ist still there...

    Wednesday, March 09, 2011 5:51 PM
  • Probably a bug in Outlook.  I have a new Lenovo W520 and have reinstalled Office 2007 and set a new PST file.

     

    And am getting this message primarily on my MSN (hotmail account).

     

    None of the proposed solutions appear to work.  I do have an old copy of 2003 I may remove from a desktop to see if that will work.

     

    I have tried removing and reinstalling Office 2007 3 times now.

     

    Perry

    Tuesday, April 19, 2011 6:30 PM
  • Hello Perry,

    this helps...

    <<<

    Start by setting the SharedMemMaxSize registry value as listed below. Under HKLM\SOFTWARE\Microsoft\Windows Messaging Subsystem\Applications\MyApp\ to 0x300000 and see if that provides temporary relief. If the issue reoccurs try setting it to as high as 0x800000

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Messaging Subsystem\Applications\Outlook
    Value Name: SharedMemMaxSize 
    Value Type: REG_DWORD 
    Value Data: <See the table listed below>

    <<<

    My Outlook works now fine...

     

     


    Gruss Peter
    Wednesday, April 20, 2011 6:07 AM
  • Sally & others...  

    I'm running Win 7 Pro & MS Office Enterprise 2007 + Front Page 2003.

    I experienced the same out of memory issues others were citing.  I spent a day going thru messages in this thread trying some of the different suggestions.  As a last ditch effort before calling support, I booted in safe mode with networking.

    I had no problems with Outlook in Safe Mode.

    When I booted back to normal & started Outlook, almost immediately the problem reared its ugly head again.  Then I simply got lucky.

    I don't know how I missed something so basice, but I did.  I have Norton Internet Security Installed.  I noticed that the spam filter in it was turned on in Outlook.  I turned it off.

    ****_BINGO!!!_ ****

    All memory problems / issues were resolved.

    Now Outlook runs FAST! on my Intel i7 box with 16GB of memory.  Amazingly fast.

    I hope this information may save others.  I hope I get used to Outlook.  I REALLY MISS the simplicity of Outlook Express.  It did its job, and I had much more control over the mail store's individual folders. In fact, that allowed me to more easily merge the inboxes from 3 different computers & consolidate them before exporting to Windows Live Mail and then to Outlook on this new machine.

     

     

    Tuesday, December 20, 2011 1:28 PM
  • 'BINGO' also for me!!! I've tried many options and googled to find a solution to this same problem.... 'not enough free memory'....

    When I stopped the spam on my Norton Security it worked at once......

    Only thing: Am I protected against spam because I don't want to reinstall the spam.....

    What to do ?

      
    Tuesday, February 14, 2012 5:50 PM
  • Yatzee! I have been dealing with this issue forever....I do Eset rather than Norton Security, but as soon as I found the Spam setting and turned it off, BAM, it worked and extremely fast as to how it has been slow forever. I thought I would share. thanks to all who posted on this.

    TURN OFF YOUR SPAM SETTING

    Wednesday, April 04, 2012 5:20 PM
  • THANK YOU!

    Wow. This was a long time issue for me as well. Outlook 2010. Windows 7. Norton 360.

    I kept getting the error message "Outlook 2010 Cannot display the folder. There is not enough free memory to run the program. Quit one or more programs and then try again." when I tried to open up some email folders. I finally disabled the add-in in via unchecking it in Outlook (the "Norton AntiSpam Outlook Add-in") AND went to my Norton 306 application and turned off my Norton AntiSpam setting.  Outlook is running MUCH faster.  That said, now am I vulnerable?  What, if anything, can I do about this?

    Thanks. 

    Friday, May 04, 2012 11:13 PM
  • That said, now am I vulnerable?

    No, in the worst case scenarion, some junk emails might end up in your Inbox. Note that Outlook has already a Junk Email filter built-in as well. You can modify its settings by clickin on the Junk button on the Home tab.


    Robert Sparnaaij [MVP-Outlook]
    Outlook guides and more: HowTo-Outlook.com
    Outlook Quick Tips: MSOutlook.info

    Sunday, May 06, 2012 8:19 PM
  • Hello, my issue is similar. In my case it only occurs with my contacts, it is common but random.
    When I open a contact I get this error message:

    "Cannot open this item. Out of memory or system resources. Close some windows or programs and try again"

    I have tried uninstalling reinstalling, repairing …..

    Any Ideas?

    Thanks

     

    Office 2010 pro plus 32 bit

    W 7 ult. 64 bit

    Intel i7 2600k

    16 gb ram


    Friday, June 22, 2012 8:45 AM
  • I also have this issue with a new upgrade installation.  I have upgraded an Office 2007 installation with Office Home and Business 2010 that uses a POP3 email account with no issues at all.  However in a 2nd upgrade from Office 2007, this issue occurs and the account is an Exchange Server account with a large amount of archived email attached.  The user has access to Public Folders but does not use them to store email and does not display them in his Outlook.  Note the user has over 8GB in archived email.

    After looking through the many attempts at help, I have the tried the following solutions to no avail:

    - the registry key listed above, "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Messaging Subsystem\Applications\Outlook
    Value Name: SharedMemMaxSize" does not exist on this system, neither does the \Applications\Outlook\ folder where it supposed to be stored.

    - starting Outlook using the /resetnavpane command does not work

    - starting Outlook in Safe Mode does not work

    - I've disabled all Add-ins such as Google Desktop, McAfee Enterprise A/V software and iTunes, this did not help either.

    - ran Scantpst.exe on all the archive files.  Ran scanost.exe on the account files, neither did any good.

    My only option is to contact MS Support and have them offer all of the suggestions again but from what I'm reading all over is that this is a bug in Outlook that MS is not going to fix.  Since my configuration does not take into account Public Folders, what does this say about the bug?

    If anyone has any further suggestions, please let me know.  Otherwise I will look for procedures to DOWNGRADE back to Office 2007 until this is fixed.  Its really sad that MS just throws away functionality that they built, trying to force you to upgrade.  Public Folders have been around for more than 15 years and millions of people use them still.

    • Proposed as answer by Lord Caric Wednesday, July 18, 2012 9:23 PM
    • Unproposed as answer by Lord Caric Wednesday, July 18, 2012 9:23 PM
    Tuesday, July 17, 2012 8:14 PM
  • I also have this issue with a new upgrade installation.  I have upgraded an Office 2007 installation with Office Home and Business 2010 that uses a POP3 email account with no issues at all.  However in a 2nd upgrade from Office 2007, this issue occurs and the account is an Exchange Server account with a large amount of archived email attached.  The user has access to Public Folders but does not use them to store email and does not display them in his Outlook.  Note the user has over 8GB in archived email.

    After looking through the many attempts at help, I have the tried the following solutions to no avail:

    - the registry key listed above, "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Messaging Subsystem\Applications\Outlook
    Value Name: SharedMemMaxSize" does not exist on this system, neither does the \Applications\Outlook\ folder where it supposed to be stored.

    - starting Outlook using the /resetnavpane command does not work

    - starting Outlook in Safe Mode does not work

    - I've disabled all Add-ins such as Google Desktop, McAfee Enterprise A/V software and iTunes, this did not help either.

    - ran Scantpst.exe on all the archive files.  Ran scanost.exe on the account files, neither did any good.

    My only option is to contact MS Support and have them offer all of the suggestions again but from what I'm reading all over is that this is a bug in Outlook that MS is not going to fix.  Since my configuration does not take into account Public Folders, what does this say about the bug?

    If anyone has any further suggestions, please let me know.  Otherwise I will look for procedures to DOWNGRADE back to Office 2007 until this is fixed.  Its really sad that MS just throws away functionality that they built, trying to force you to upgrade.  Public Folders have been around for more than 15 years and millions of people use them still.

    Ok, it appears I have SOLVED this issue for my particular user's setup.  I'll list all the steps I took to get to a resolution and I'll also list what I believe that actual problem was.

    First, I reviewed this users setup again, including all archived email, public folder displays and mailbox settings.  Here is his setup:

    - Exchange Server account (Exchange 2003 sp2) in Cached Mode

    - Mailbox is 717 MB in size, email is archived once its 6 months old and moved to archive.pst including Calendar, Tasks, Notes, etc.

    - Archived email stored in 3 PST files, 7.1 GB in main, 4.9 in 2nd and 1.1 GB in a 3rd.  Main archive was stored in the Outlook folder (archive.pst) while the others contain old email that was exported out and moved from an old machine.

    - A 2nd Exchange Server mailbox opens that also contains old email (from many years ago).  This was an old solution as Outlook 2003 had memory issues (ran slowly) handling large PST files so we setup a mailbox that could be used to store really old email from this user that may need to be searched.  ***** this is what I believe is the key *****

    - Archive files were stored on 2 different drives.  C drive for the main archive and a second drive for the others.

    - User had been upgraded from Outlook 2003 to 2007 to 2010 in the last few years.

    - User has Public Folders displayed (this was noted to be a cause of the "bug" because MS deprecated them in Exchange 2010), but they are not used for synchronizing any email nor is email from this user stored here.

    Here's the steps I took to resolve the problem, although I think only one step was needed.  Note this is after I attempted the steps above of opening in Safe Mode, disabling Add-ons, running the /resetnavpane switch, etc and checking for the registry entry for SharedMemSize:

    1.) Opened Outlook and closed each of the archive files.  Closed Outlook.

    2.) Opened up the Mail utility from Control Panel and ran the Compact utility on each of the archive files (.pst) one by one.  This reduced 3.4 GB of space.

    3.) Ran the Scanpst.exe utility on each of the archive files, fixing a number of errors in each. (scanpst.exe is located in the Office 14 folder)

    4.) Using the Mail utility again to change settings for the mailbox, I removed the 2nd mailbox from the account.  *****  this is key because this mailbox has a LOT of sub-folders and if its being synchronized, this would create a number of connections.  The number of connections seems to be a major cause of this bug, as those with a lot of Public Folders that also sync experience this issue.

    5.) Once this was done, I opened up Outlook.  With all of the archives closed and the 2nd mailbox closed I eliminated:

    - any other connections to the server except the main mailbox

    - any possible memory issues using 10+ GB of archived email.

    6.) Outlook was now running normally with no sign of the bug!  So one at a time, I opened up the archive files again.  After each one, I browsed through folders and opened up emails to see if the bug would reappear, it did not.  After opening all three archive files, I was able to use Outlook normally for more than 20 minutes.

    7.) I did NOT open the 2nd mailbox and I firmly believe that the 2nd mailbox was causing this problem to appear.

    Previously the bug would appear after only a few minutes of using Outlook, but without the 2nd mailbox, there were no issues and there continue to be no issues.  Problem solved.

    So now I am exporting email from that 2nd mailbox and created a 4th archive file and will advise the user to open and close it only when needed.

    I hope this helps someone else and shows that the bug seems to be caused by connections to the Exchange Server, whether it hits a limit or overloads some kind of buffer, I'm not sure, but this definitely is the cause.

    • Proposed as answer by Lord Caric Thursday, July 19, 2012 2:25 PM
    Thursday, July 19, 2012 2:25 PM
  • Hi all,

    i had the same issue after upgrading from outlook 2007 to 2010 and I solved it in the following way:

    i had several extra mailboxes attached to my out look account. I know that some of them were huge. So i removed them from outlook and even though the folders i was trying to access was not part of them but of my main mailbox, this solved the problem.

    not sure if the reply is relevant to you, in any case good luck 

    Wednesday, October 17, 2012 5:17 PM