none
Media Player not working in firefox

    Question

  • Hi ,

    I am using "Content Editor Web Part" to render Mediaplayer on MOSS webpage. It works fine in IE but doesn't work in firefox.
    Below is my code:

    <object width="350" height="340" id="player" classid="CLSID:6BF52A52-394A-11d3-B153-00C04F79FAA6" >
    <param name="URL" value="abc.wmv" />
    <param name="captioningID" value="cc" />
    <param name="AutoStart" value="true" />
    <param name="AutoRewind" value="true" />
    <embed type="application/x-mplayer2"
    pluginspage = "http://www.microsoft.com/Windows/mediaplayer/"
    id="player"
    name="URL"
    value="abc.wmv"
    width="350"
    height="340"
    autostart="false">
    </embed>
    </object>

    Please Help.
    Regards,
    Sanjeet
    Monday, January 25, 2010 7:38 PM

Answers

  • just try this on firefox and work

    <html>
    <head>
    </head>
    <body>
    <object classid="clsid:6BF52A52-394A-11D3-B153-00C04F79FAA6" id="Player1" width="424" height="379">
    	<param name="URL" value="http://www.microsoft.com/resources/msdn/en-us/office/media/MOSS2007CreateSeqWFUsingVS2008.wvx">
    	<param name="http://path_to_the_video">
    	<param name="AutoStart" value="1">
    	<param name="ShowControls" value="1">
    	<param name="ShowStatusBar" value="1">
    	<param name="ShowDisplay" value="1">
    	<param name="stretchToFit" value="1">
    	<embed type="application/x-mplayer2"
    pluginspage="http://www.microsoft.com/Windows/Downloads/Contents/MediaPlayer/" 
    width="424" height="379" src="http://www.microsoft.com/resources/msdn/en-us/office/media/MOSS2007CreateSeqWFUsingVS2008.wvx"
    filename="http://www.microsoft.com/resources/msdn/en-us/office/media/MOSS2007CreateSeqWFUsingVS2008.wvx" autostart="1" showcontrols="1" showstatusbar="1" showdisplay="1">
    </embed>
    </object>
    </body>
    </html>


    André Lage Microsoft SharePoint, CRM and Sybase Consultant
    Blog:http://aaclage.blogspot.com
    Codeplex:http://spupload.codeplex.com/http://simplecamlsearch.codeplex.com/
    • Marked as answer by Chengyi Wu Wednesday, January 27, 2010 1:25 AM
    • Unmarked as answer by Sanjeet Sinha Wednesday, January 27, 2010 7:49 AM
    • Marked as answer by Sanjeet Sinha Wednesday, January 27, 2010 7:50 AM
    Tuesday, January 26, 2010 3:29 AM

All replies

  • just try this on firefox and work

    <html>
    <head>
    </head>
    <body>
    <object classid="clsid:6BF52A52-394A-11D3-B153-00C04F79FAA6" id="Player1" width="424" height="379">
    	<param name="URL" value="http://www.microsoft.com/resources/msdn/en-us/office/media/MOSS2007CreateSeqWFUsingVS2008.wvx">
    	<param name="http://path_to_the_video">
    	<param name="AutoStart" value="1">
    	<param name="ShowControls" value="1">
    	<param name="ShowStatusBar" value="1">
    	<param name="ShowDisplay" value="1">
    	<param name="stretchToFit" value="1">
    	<embed type="application/x-mplayer2"
    pluginspage="http://www.microsoft.com/Windows/Downloads/Contents/MediaPlayer/" 
    width="424" height="379" src="http://www.microsoft.com/resources/msdn/en-us/office/media/MOSS2007CreateSeqWFUsingVS2008.wvx"
    filename="http://www.microsoft.com/resources/msdn/en-us/office/media/MOSS2007CreateSeqWFUsingVS2008.wvx" autostart="1" showcontrols="1" showstatusbar="1" showdisplay="1">
    </embed>
    </object>
    </body>
    </html>


    André Lage Microsoft SharePoint, CRM and Sybase Consultant
    Blog:http://aaclage.blogspot.com
    Codeplex:http://spupload.codeplex.com/http://simplecamlsearch.codeplex.com/
    • Marked as answer by Chengyi Wu Wednesday, January 27, 2010 1:25 AM
    • Unmarked as answer by Sanjeet Sinha Wednesday, January 27, 2010 7:49 AM
    • Marked as answer by Sanjeet Sinha Wednesday, January 27, 2010 7:50 AM
    Tuesday, January 26, 2010 3:29 AM
  • In order to make Firefox able to render Media Player content, you need Windows Media Plugin in Firefox:

    Download the Windows Media Player Firefox Plugin(http://port25.technet.com/pages/windows-media-player-firefox-plugin-download.aspx)

    Cogito, ergo sum.
    Wednesday, January 27, 2010 1:27 AM
  • Hi Andre,

    Thanks for your reply.

    This code plays single audio link in firefox. but when i use ".m3u" file it doesn't work, its working properly in IE.

    Can you please suggest the needful change for the same.

     

    Regards,

    Sanjeet

    Wednesday, January 27, 2010 4:04 AM
  • hi,

    I changed the above code for .m3u streaming

    <html>
    <head>
    </head>
    <body>
    <object classid="clsid:6BF52A52-394A-11D3-B153-00C04F79FAA6" id="Player1" width="424" height="379">
    	<param name="URL" value="http://www.microsoft.com/resources/msdn/en-us/office/media/MOSS2007CreateSeqWFUsingVS2008.wvx">
    	<param name="http://path_to_the_video">
    	<param name="AutoStart" value="1">
    	<param name="ShowControls" value="1">
    	<param name="ShowStatusBar" value="1">
    	<param name="ShowDisplay" value="1">
    	<param name="stretchToFit" value="1">
    	<embed type="application/x-mplayer2"
    pluginspage="http://www.microsoft.com/Windows/MediaPlayer/default.asp" 
    width="424" height="379" src="http://www.microsoft.com/resources/msdn/en-us/office/media/MOSS2007CreateSeqWFUsingVS2008.wvx"
    filename="http://www.microsoft.com/resources/msdn/en-us/office/media/MOSS2007CreateSeqWFUsingVS2008.wvx" autostart="1" showcontrols="1" showstatusbar="1" showdisplay="1">
    </embed>
    </object>
    </body>
    </html>
















    It is working fine now.

    Thanks,
    Sanjeet
    Wednesday, January 27, 2010 7:49 AM
  • I am using same embed code. when i set "AutoStart" attribute to "false" it works with IE where as its not working with FF. it starts buffering the video any fixes for this ???.

     

    thanks

    Tuesday, April 20, 2010 1:56 PM
  • Guys Just set autostart="0" (zero) it works 

     

    Rock On svrajput at hotmail dot com

    Tuesday, April 20, 2010 2:05 PM
  • Thanks this helped a bunch.
    Thursday, June 28, 2012 6:17 PM