none
how to stop getting exchange emails telling me "your public folder "\xyz\abc" is becoming too large. The current size is 57mb.

    Question

  • I just upgraded to exchange 2013, and now, I'm getting emails from exchange that say the following:

    Your public folder "\Media\Aim Reports\Station Summary" is becoming too large. The current size is 57 MB.<o:p></o:p>

    Please reduce the size of your public folder by deleting any items you don't need.

    <o:p></o:p>

    <o:p>How do I stop them from coming? </o:p>

    <o:p>I have already tried this command, but it didn't work:</o:p>

    Set-PublicFolder -Identity "\Public Folders" -UseDatabaseQuotaDefaults: $False

    Is there a place in the ECP I can just disable it?

    Thanks, Dan

    <o:p></o:p>


    Dan

    Tuesday, February 18, 2014 11:00 PM

Answers

  • I told you two places where there are quotas:

    • Individual public folders
    • Public folder mailboxes

    If the public folder mailbox's quotas are set to use the information store default, then the quotas of mailbox database where the mailbox is homed applies.

    Get-PublicFolder -Identity \ -Recurse | FL Identity,*Quota
    Get-Mailbox -PublicFolder | FL Name,*Quota,UseDatbaseQuotaDefaults
    Get-MailboxDatabase -Identity <Database Name> | FL *Quota
    So, a public folder has a quota.  A public folder mailbox has a quota that applies when the aggregate data of all public folders in it reach the limit.


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."

    • Marked as answer by afacts Monday, March 3, 2014 5:41 PM
    Wednesday, February 19, 2014 12:54 AM
    Moderator

All replies

  • Two things:

    • Remove or increase individual public folder quotas.
    • Verify that you have appropriate public folder mailbox quotas.

    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."


    Tuesday, February 18, 2014 11:36 PM
    Moderator
  • Well, all my folders are set to"use organization quota defaults", and those are all set to unlimited.

    All three options are set to unlimited.

    What do you mean by verify that you have appropriate public folder mailbox quotas?


    Dan

    Tuesday, February 18, 2014 11:56 PM
  • I told you two places where there are quotas:

    • Individual public folders
    • Public folder mailboxes

    If the public folder mailbox's quotas are set to use the information store default, then the quotas of mailbox database where the mailbox is homed applies.

    Get-PublicFolder -Identity \ -Recurse | FL Identity,*Quota
    Get-Mailbox -PublicFolder | FL Name,*Quota,UseDatbaseQuotaDefaults
    Get-MailboxDatabase -Identity <Database Name> | FL *Quota
    So, a public folder has a quota.  A public folder mailbox has a quota that applies when the aggregate data of all public folders in it reach the limit.


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."

    • Marked as answer by afacts Monday, March 3, 2014 5:41 PM
    Wednesday, February 19, 2014 12:54 AM
    Moderator
  • Hi Ed,

    You have to forgive me as I don't use power shell and I'm not new exchange 2013, as I just got it installed.

    So when I ran the first command, almost every entry was "unlimited".

    When running the second command, here's the results.

    Name                         : Public Folders
    ProhibitSendQuota            : 2 GB (2,147,483,648 bytes)
    ProhibitSendReceiveQuota     : Unlimited
    RecoverableItemsQuota        : 30 GB (32,212,254,720 bytes)
    RecoverableItemsWarningQuota : 20 GB (21,474,836,480 bytes)
    CalendarLoggingQuota         : 6 GB (6,442,450,944 bytes)
    IssueWarningQuota            : Unlimited
    RulesQuota                   : 64 KB (65,536 bytes)
    ArchiveQuota                 : 50 GB (53,687,091,200 bytes)
    ArchiveWarningQuota          : 45 GB (48,318,382,080 bytes)

    When running the third command, here's the error message I got:

     C:\Windows\system32>get-mailbox -identity MailboxDB1 | FL *quota | more
    operation couldn't be performed because object 'MailboxDB1' couldn't be found on 'dc1.domain.com'.
    + CategoryInfo          : NotSpecified: (:) [Get-Mailbox], ManagementObjectNotFoundException
    + FullyQualifiedErrorId : 7C59B5B9,Microsoft.Exchange.Management.RecipientTasks.GetMailbox
    + PSComputerName        : elijah.domain.com

    So I'm not where where to look next or what to do?


    Dan

    Wednesday, February 19, 2014 2:16 AM
  • Hello,

    Please check Ed's third command: Get-MailboxDatabase -Identity <Database Name> | fl *Quota.

    You can use Set-OrganizationConfig cmdlet to set the quotas on a public folder mailbox.

    If you have any feedback on our support, please click here


    Cara Chen
    TechNet Community Support

    Wednesday, February 19, 2014 2:51 AM
  • In the first, how about the entry for the folder that's throwing the overlimit messages?

    Use Get-MailboxStatistics to see how much data is in the Public Folders mailbox.

    The third one should be Get-MailboxDatabase.


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."

    Wednesday, February 19, 2014 4:18 AM
    Moderator
  • Hello,

    Is there any update?

    If you have any feedback on our support, please click here


    Cara Chen
    TechNet Community Support

    Thursday, February 20, 2014 6:11 AM
  • I posted my reply in my message above. When I ran that command, I received an error message. Please look at my above error message. I'm not sure why it's not working, or if I typed something wrong?

    Dan

    Thursday, February 20, 2014 1:21 PM

  • [PS] C:\Windows\system32>get-publicfolder -identity \-recurse |fl identity,*quota
    The operation couldn't be performed because '\-recurse' couldn't be found.
        + CategoryInfo          : NotSpecified: (:) [Get-PublicFolder], ManagementObjectNotFoundException
        + FullyQualifiedErrorId : 7C107B60,Microsoft.Exchange.Management.MapiTasks.GetPublicFolder
        + PSComputerName        : exchangeserver.mydomain.org



    [PS] C:\Windows\system32>get-mailbox -publicfolder | fl "Public Folder", *quota,usedatbasequotadefaults

    ProhibitSendQuota            : 2 GB (2,147,483,648 bytes)
    ProhibitSendReceiveQuota     : Unlimited
    RecoverableItemsQuota        : 30 GB (32,212,254,720 bytes)
    RecoverableItemsWarningQuota : 20 GB (21,474,836,480 bytes)
    CalendarLoggingQuota         : 6 GB (6,442,450,944 bytes)
    IssueWarningQuota            : Unlimited
    RulesQuota                   : 64 KB (65,536 bytes)
    ArchiveQuota                 : 50 GB (53,687,091,200 bytes)
    ArchiveWarningQuota          : 45 GB (48,318,382,080 bytes)




    [PS] C:\Windows\system32>get-mailbox -identity mailboxdb1 | fl *quota
    The operation couldn't be performed because object 'mailboxdb1' couldn't be found on 'DC2.mydomain.org'.
        + CategoryInfo          : NotSpecified: (:) [Get-Mailbox], ManagementObjectNotFoundException
        + FullyQualifiedErrorId : 7FB4D9AB,Microsoft.Exchange.Management.RecipientTasks.GetMailbox
        + PSComputerName        : exchangeserver.mydomain.org

    Dan

    Thursday, February 20, 2014 7:26 PM

  • [PS] C:\Windows\system32>get-publicfolder -identity \-recurse |fl identity,*quota
    The operation couldn't be performed because '\-recurse' couldn't be found.
        + CategoryInfo          : NotSpecified: (:) [Get-PublicFolder], ManagementObjectNotFoundException
        + FullyQualifiedErrorId : 7C107B60,Microsoft.Exchange.Management.MapiTasks.GetPublicFolder
        + PSComputerName        : exchangeserver.mydomain.org



    [PS] C:\Windows\system32>get-mailbox -publicfolder | fl "Public Folder", *quota,usedatbasequotadefaults

    ProhibitSendQuota            : 2 GB (2,147,483,648 bytes)
    ProhibitSendReceiveQuota     : Unlimited
    RecoverableItemsQuota        : 30 GB (32,212,254,720 bytes)
    RecoverableItemsWarningQuota : 20 GB (21,474,836,480 bytes)
    CalendarLoggingQuota         : 6 GB (6,442,450,944 bytes)
    IssueWarningQuota            : Unlimited
    RulesQuota                   : 64 KB (65,536 bytes)
    ArchiveQuota                 : 50 GB (53,687,091,200 bytes)
    ArchiveWarningQuota          : 45 GB (48,318,382,080 bytes)




    [PS] C:\Windows\system32>get-mailbox -identity mailboxdb1 | fl *quota
    The operation couldn't be performed because object 'mailboxdb1' couldn't be found on 'DC2.mydomain.org'.
        + CategoryInfo          : NotSpecified: (:) [Get-Mailbox], ManagementObjectNotFoundException
        + FullyQualifiedErrorId : 7FB4D9AB,Microsoft.Exchange.Management.RecipientTasks.GetMailbox
        + PSComputerName        : exchangeserver.mydomain.org

    Dan

    Thursday, February 20, 2014 7:26 PM
  • Hello,

    There should be a space between "\" and "-recurse".

    You should use get-publicfolder -identity \ -recurse |fl identity,*quota cmdlet or Get-PublicFolder -Identity "\xxx" -Recurse | fl *quota cmdlet to check the quotas information.

    You should use Get-MailboxDatabase -Identity <Database Name> | fl *Quota cmdlet.

    If you have any feedback on our support, please click here


    Cara Chen
    TechNet Community Support

    Friday, February 21, 2014 3:12 AM
  • Hello Cara, thank you for the clarification, as you can see, I don't know how to use powershell, which I need to learn.

    So I ran the command, and it worked, everything was set to "unlimited", excel 4 folders.

    Everything for "prohibitpostquota" is set to unlimited.

    There are 4 folders for "issuewarningquota" that are set to 0B.

    How do I fix this, as this might be my problem?

    Now for your second command, I'm not doing something right, as it's still giving me errors:

    [PS] C:\Windows\system32>Get-PublicFolder -Identity "\Public Folders" -Recurse | fl *quota |more
    Couldn't find public folder "\Public Folders". Please make sure you typed the name correctly. Reason: The opera
    couldn't be performed because '\Public Folders' couldn't be found.
        + CategoryInfo          : NotSpecified: (:) [Get-PublicFolder], ManagementObjectNotFoundException
        + FullyQualifiedErrorId : 5420A01C,Microsoft.Exchange.Management.MapiTasks.GetPublicFolder
        + PSComputerName        :exchangeserver.mydomain.org


    [PS] C:\Windows\system32>Get-PublicFolder -Identity "\Mailboxdb1" -Recurse | fl *quota |more
    Couldn't find public folder "\Mailboxdb1". Please make sure you typed the name correctly. Reason: The operation
    couldn't be performed because '\Mailboxdb1' couldn't be found.
        + CategoryInfo          : NotSpecified: (:) [Get-PublicFolder], ManagementObjectNotFoundException
        + FullyQualifiedErrorId : 1334C86E,Microsoft.Exchange.Management.MapiTasks.GetPublicFolder
        + PSComputerName        : exchangeserver.mydomain.org

    The name of my main folder, is called Public Folders.  So what am I doing wrong?

    The name of my mailbox Database is mailboxdb1.   Looks like it doesn't like both commands.


    Dan

    Friday, February 21, 2014 4:37 PM
  • Hello,

    Please check if you use correct public folder name. For example: there is a public folder "test1", you can run the command :Get-PublicFolder  -Identity "\test1" -Recurse | fl *quota.

    Here is an article for your reference.

    http://technet.microsoft.com/en-us/library/aa997615(v=exchg.150).aspx

    For your mailbox database, you should use Get-MailboxDatabase -Identity <Database Name> | fl *Quota cmdlet. The command Get-PublicFolder -Identity "\Mailboxdb1" -Recurse | fl *quota |more is not correct.

    If you have any feedback on our support, please click here


    Cara Chen
    TechNet Community Support

    Tuesday, February 25, 2014 1:42 AM
  • Hello Cara,

    The command: Get-MailboxDatabase -Identity <Database Name> | fl *Quota   (worked just fine)

    ProhibitSendReceiveQuota     : 2.3 GB (2,469,606,400 bytes)
    ProhibitSendQuota            : 2 GB (2,147,483,648 bytes)
    RecoverableItemsQuota        : 30 GB (32,212,254,720 bytes)
    RecoverableItemsWarningQuota : 20 GB (21,474,836,480 bytes)
    CalendarLoggingQuota         : 6 GB (6,442,450,944 bytes)
    IssueWarningQuota            : 1.9 GB (2,040,110,080 bytes)

    It's this command that does NOT work:

    [PS] C:\Windows\system32>get-publicfolder -identity "\Public Folders" -recurse |more
    Couldn't find public folder "\Public Folders". Please make sure you typed the name correctly. Reason: The operatio
    couldn't be performed because '\Public Folders' couldn't be found.
        + CategoryInfo          : NotSpecified: (:) [Get-PublicFolder], ManagementObjectNotFoundException
        + FullyQualifiedErrorId : 5420A01C,Microsoft.Exchange.Management.MapiTasks.GetPublicFolder
        + PSComputerName        : myserver.mydomain.org

    I have attached a snapshot of a screenshot of exchange, to show you that my public folders, is actually called "Public Folders".  When running that command, apparently I'm typing something wrong.


    Can you tell me exactly what I need to type, as this has been a painful process.

    


    Dan

    Tuesday, February 25, 2014 5:13 PM
  • Hello,

    This is a public folder mailbox's name. You should check public folders' name.

    If you want to check the public folders that reside in the public folder content mailbox, you should add mailbox parameter.

    If you have any feedback on our support, please click here


    Cara Chen
    TechNet Community Support


    • Edited by cara chen Thursday, February 27, 2014 2:17 AM edit
    Wednesday, February 26, 2014 5:34 AM
  • Hello,

    Is there any update?

    If you have any feedback on our support, please click here


    Cara Chen
    TechNet Community Support

    Friday, February 28, 2014 9:12 AM
  • Hello,

    I have the issue in this thread and want to confirm the command to set unlimited.

    details:

    [PS] C:\Windows\system32>Get-PublicFolder -Identity "\ADM\Trng Room Reservations\14th Floor Training Room" -Recurse | identity,*quota


    Identity          : \ADM\Trng Room Reservations\14th Floor Training Room
    ProhibitPostQuota : Unlimited
    IssueWarningQuota : 0 B (0 bytes)

     

    [PS] C:\Windows\system32>Get-PublicFolder -Identity "\Oper\ARCorr\How To" -Recurse | fl identity,*quota


    Identity          : \Oper\ARCorr\How To
    ProhibitPostQuota : Unlimited
    IssueWarningQuota : Unlimited


    i want to confirm the command to set the 'IssueWarningQuota : 0 B' in the first one to unlimited.

    is it:

    set-PublicFolder -Identity "\ADM\Trng Room Reservations\14th Floor Training Room" -IssueWarningQuota Unlimited

    Thanks in advance.

    Wednesday, April 22, 2015 2:07 PM
  • Enter:

    Get-MailboxDatabase

    for a list of valid databases.  it appears that "mailboxdb1" isn't one.


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."

    Wednesday, April 22, 2015 6:10 PM
    Moderator