locked
Sorry, this site hasn't been shared with you RRS feed

  • Question

  • I am having issues in accessing a SP 2013 site that I created on port 80.  This site should actually be visible by everyone but I can't even see it, and I created it.  I keep getting 'Sorry, this site hasn't been shared with you.' even though I did share it with myself.

    I have tried removing then adding myself as the site collection admin, clearing the Distributed Cache, clearing the bindings.... You name it, I've done it.

    Thursday, May 16, 2013 3:04 PM

All replies

  • Are you trying on your VM? also, Can you add urself from the central admin and try...

    Ashish Ranjan (Please click "Marked As Answer" if a post solves your problem or "Vote As Helpful" if a post has been useful to you)

    Thursday, May 16, 2013 4:55 PM
  • It is running on a VM.

    I've already added myself through Application Mangement > Manage Applications > User Policy

    Also, logged int the site as sharepointadmin and shared with myself


    cesmendez

    Thursday, May 16, 2013 5:15 PM
  • Hello

    Are you running your application pools as domain accounts?


    MCITP-EA | "You don't understand anything until you learn it more than one way" | Hope This Helps!

    Thursday, May 16, 2013 8:03 PM
  • They're running as sharepoint admin

    cesmendez

    Thursday, May 16, 2013 9:34 PM
  • can you try accessing the settings page via _layouts/settings.aspx and see thats is accessible or not. is so some components on the home page is creating issues for your access


    Regards  Roy Joyson
    Please remember to mark your question as "answered"/"Vote helpful" if this solves/helps your problem

    Roy Joyson

    • Proposed as answer by Adr1an Monday, November 28, 2016 10:39 AM
    Friday, May 17, 2013 12:54 PM
  • That's actually where it tries to go and throws the error.

    cesmendez

    Friday, May 17, 2013 3:12 PM
  • I had similar problems that had to do with the permissions on the site were in Classic Windows Auth but the security for the site was Claims, so it didn't recognize my account (this was after a migration).

    You could look into

    Convert-SPWebApplication

    or

    $wa.MigrateUsers($true)

    Friday, May 17, 2013 4:10 PM
  • Thanks Christopher but this didn't solve it.  This is a new installation of 2013

    cesmendez

    Friday, May 17, 2013 6:38 PM
  • Hello

    Have you configured cache accounts?  I just responded to a post that made me think of this thread, if you have not messed with the cache accounts then please disregard.

    configure cache accounts


    MCITP-EA | "You don't understand anything until you learn it more than one way" | Hope This Helps!

    Friday, May 17, 2013 10:12 PM
  • i haven't messed with the cache accounts

    cesmendez

    Friday, May 17, 2013 11:32 PM
  • Did you ever solve this problem?  I am having the same issue.  We have two new 2013 farms in the same domain (prod &test) configured identically but running under different service accounts (ex: SPSAdmin and tSPSAdmin).  I detached 2 content databases in test that corresponded to two different web apps and deleted them from SQL.  I then restored the production version of these content databases to test SQL, fixed the database security, and re-attached them to test farm.  At first, I could not access either but over the weekend something changed - I can access one web app but not the other.

    I am a farm administrator and secondary site collection administrator in both site collections.  I also tried adding myself with full control to the web application policy.

    Monday, September 23, 2013 3:17 PM
  • This seems to be an authentication issue where user is not being identified in Claims based authentication. Try removing and adding user through powershell.

    1) first remove user,if user exists using Remove-SPUser command

    http://technet.microsoft.com/EN-US/library/ff607894.aspx

    2) Then add user, using New-SPUser command

    http://technet.microsoft.com/EN-US/library/ff607868.aspx

    • Proposed as answer by Ahamed Shaamil Wednesday, September 25, 2013 5:13 AM
    Wednesday, September 25, 2013 5:13 AM
  • If you face the problem for specfic user its seems to be authentication problem as Ahamed said.

    But if you face this problem for all users you should look to the storage if it is full, you should empty some of storage and it will work fine.

    Sunday, October 20, 2013 8:24 AM

  • Error Sorry, this site hasn’t been shared with you.” is the new “Access denied” in sharepoint 2013.

    “Sorry, this site hasn’t been shared with you.” Its a basically uncommon  error for sharepoint users.

    What it actually means that your windows account has not been granted access to the site.

    This error is cause by permissions/credentials access problem.


    If you have credential for account who has rights on site then, by simply hitting below URL, you can have prompt to login prompt.

    <href: <a href=http:/serverurl/_layouts/closeConnection.aspx?loginasanotheruser=true />

    If you want to add your account as Site collection Administrator or to determine the site collection administrator is:


    Lets Log in to SharePoint 2013 Central Administration.


    Make sure Select Application Management -> Change Site Collection Administrators.


    Select the correct site collection and look at the primary site collection administrator.


    Vivek

    Please  mark your question as "answered"/"Vote helpful" if this solves/helps your problem






    • Proposed as answer by Vivek KS Tuesday, January 21, 2014 9:55 AM
    • Edited by Vivek KS Tuesday, January 21, 2014 9:56 AM
    Tuesday, January 21, 2014 9:49 AM
  • I had this issue for some pages. For me it turned out to be issue with the master page. We have a customized master page. So I checked-out and checked-in again html file for the master page and that solved the problem. I have also allowed all authenticated users to have read permission on Device Channels list.
    • Edited by Trupti G Thursday, March 13, 2014 2:52 AM
    • Proposed as answer by Trupti G Monday, March 17, 2014 10:27 PM
    Thursday, March 13, 2014 2:52 AM
  • In my case when i changed from Classic to claims i got this issue

    Solution in my case:

    $wa = Get-SPWebApplication -Identity "MY URL"
    $wa.MigrateUsers($true)

    • Proposed as answer by CunningSteve Monday, July 21, 2014 2:19 PM
    Monday, March 17, 2014 10:50 PM

  • Solution in my case:

    $wa = Get-SPWebApplication -Identity "MY URL"
    $wa.MigrateUsers($true)

    • Thank you for your help @surapanenikiran. It works fine for me.
    • Edited by Y.Hoang Tuesday, July 22, 2014 1:05 AM
    Tuesday, July 22, 2014 1:03 AM
  • I am getting 'Access Denied' when I run this command. Any Idea? And also MigrateUsers(Boolean) is not Obsolete?
    Friday, January 16, 2015 6:39 AM
  • Hi,

    Are you able to create the site collections from the CA with the same account you are using. Also the check the app pool account is not changed.

    Regards

    Sandeep

    Friday, January 16, 2015 7:29 AM
  • Hi,

    If above does not work that try giving access to that account on Content DB to that Web app manually and then try to access.

    Hopefully this should work.

    Regards

    Sandeep

    Friday, January 16, 2015 8:51 AM
  • If you have set the Object cache Super User and Super Reader accounts for a web app, it also causes this behaviour.
    Then you need to assign the correct user policy for those two.
    But i guess you've would have known if these ones has been set, since it's a manual operation.

    But hey, who know, try to set them and assign the policy and see if it helps.

    Configure object cache user accounts in SharePoint Server 2013

    BR / Philip

    Friday, January 16, 2015 9:03 AM
  • Have you tried checking your Proxy Settings(located in Internet Options -> Connection -> LAN Settings -> Advance)

    you might have to configure proxy server settings(add an exception) so that Sharepoint site addresses bypass the proxy server. 

    Hope that might work out for you.


    Please remember to mark the replies as answers if they help and unmark them if they provide no help, this will help others who are looking for solutions to the same or similar problem.

    Monday, March 16, 2015 7:12 AM
  • Yes,This was the only reason behind issue,I checked the Log size of DB and found that it is 100 % full,Freeing memory space worked for me to access the site,Thanks a Lot !!!!
    Thursday, December 3, 2015 11:41 AM
  • I have ran into the same issue the final solution that solved the problem for me using claims authentication:

    Central Administration => Application Management => Authentication Providers => (Click default)

    Choose Kerberos

    • Proposed as answer by Thomas Tatum Monday, February 19, 2018 11:33 AM
    Thursday, June 16, 2016 1:00 AM
  • This really solved my issue.

    My SharePoint 2016 runs on a test server. Only site administrator can visit the site, normal domain users couldn't visit it. Then I run this powershell, everything is ok now.


    • Edited by BillYoung Sunday, August 14, 2016 7:08 AM
    Sunday, August 14, 2016 7:08 AM
  • Thank you so much! This solved my problem.

    Saturday, September 3, 2016 5:05 AM
  • Hello, i am having the same problem, can you please indicate which one of these suggestions solved the problem? thanks very much! 
    Monday, October 3, 2016 5:00 PM
  • Hey there

    I tried the solution indicated here and it worked for me:

    http://www.drisky.co.uk/2013/05/29/sharepoint-2013-sorry-this-site-hasnt-been-shared-with-you/

    1. Go to Central Admin. Click on the “Application Management” heading.

    2. Click on “Manage services on server”.

    3. Stop the service “Microsoft SharePoint Foundation Web Application”. This will take a little while to stop.

    4. Start the above service again.

    Thursday, October 20, 2016 12:10 PM
  • This worked on my end...Thanks
    Wednesday, November 16, 2016 2:07 PM
  • Hi Roy, am experiencing the same issue and the strange thing is that once i add that _layouts/settings.aspx am able to get the page. The root pages are all saying Sorry this site has not been shared with you. Any pointers on how to resolve the root page issue.

    Patrick.

    Thursday, April 18, 2019 7:05 AM
  • Hi RoyJoyson,

    I have the same issue. And I access to setting _layouts/settings.aspx, my user grant access. 

    Can you help me to resovle this issue

    Thanks

    Saturday, May 18, 2019 3:01 PM