none
Office Professional Plus 2010 install on XP SP3 issues

    Question

  • Okay, this is happening to me on two different computers and is driving me nuts...

    Here is the situation:

    On two different XP SP3 machines with Office 2007 installed I am trying to upgrade to Office 2010.  After the extractor finishes it's thing I receive a Setup Error:

    "Setup is unable to proceed due to the following errors

    The installation of Microsoft Office 2010 requires that MSXML version 6.10.1129.0 be installed on your computer.  Install this component and re-run setup.

     

    I check and find that MSXML version 6 SP2 is installed.  From the research I've found I've done the following:

    Reinstall .netframework (same setup error)

    Uninstall MSXML 6 SP2 and reinstall version 6.10.1129 (same setup error)

    Uninstall ALL versions of MSXML and ran setup (same setup error)

    Installed just MSXML version 6.10.1129 (same setup error)

     

    This is rediculous.  The computers have clearly met the requirements being that SP3 AND Msxml version 6.10.1129.0 being installed.  Can anyone shed some light as to why setup will not conintue because of the MSXML version 6.10.1129.0 setup error?

     

    Wednesday, August 04, 2010 2:57 PM

Answers

  • Okay, I FINALLY figured this problem out.  I hope this helps every else who has this problem and no other solution works.  What I wound up doing is uninstalling any all version and addons to Office 2007 as well as Office 2007.  I have reinstalled *multiple times* msxml6-kb954459 to no avail.  In Add/Remove Programs the version of msxml is 6.10.1129.0 but Office 2010 pro plus installer always errors out saying that 6.10.1129.0 was not installed and it needed to be installed.  I then, redownloaded the installer thinking that it may be corrupt but I received the same freak'n error.  I finally found a solution from http://forums.techarena.in/windows-software/1355091.htm; by googling this phrase "office 2010 6.10.1129.0".  Here is what the solution is (but I just did step 4):

    1. First you need to log in as administarator and then opent he regedit.
    2. After that you have to go to HKCR\TypeLib\{F5078F18-C551-11D3-89B9-0000F81FE221}\6.0\0\win32
    3. Then you need to right click an give yourself complete access for the key.
    4. After completing this you need alter the values from %SystemRoot%\System32\msxml6.dll to c:\windows\System32\msxml6.dll and then try to reinstall

    What I found was that a third party program (TaxWorks) had changed this and it was pointing to C:\program files\common files\taxprep\msxml6.dll

    I sure hope this helps the rest of you struggling with this problem.

     

    cheers!

    • Marked as answer by JepthaT Wednesday, October 06, 2010 5:57 PM
    Wednesday, October 06, 2010 5:57 PM

All replies

  • Hi,

    Make sure the following are uninstalled:
    - Send a Smile
    - Microsoft Outlook Connector

    If you cannot uninstall them from control panel, please refer to this article:

    After uninstalling, try rebooting your system.

    Hope it does help.

     

    • Marked as answer by Jennifer Zhan Wednesday, August 11, 2010 2:03 AM
    • Unmarked as answer by JepthaT Wednesday, August 11, 2010 2:31 PM
    Thursday, August 05, 2010 8:16 AM
  • Neither of these are or have been installed.
    Wednesday, August 11, 2010 2:32 PM
  • Okay, I FINALLY figured this problem out.  I hope this helps every else who has this problem and no other solution works.  What I wound up doing is uninstalling any all version and addons to Office 2007 as well as Office 2007.  I have reinstalled *multiple times* msxml6-kb954459 to no avail.  In Add/Remove Programs the version of msxml is 6.10.1129.0 but Office 2010 pro plus installer always errors out saying that 6.10.1129.0 was not installed and it needed to be installed.  I then, redownloaded the installer thinking that it may be corrupt but I received the same freak'n error.  I finally found a solution from http://forums.techarena.in/windows-software/1355091.htm; by googling this phrase "office 2010 6.10.1129.0".  Here is what the solution is (but I just did step 4):

    1. First you need to log in as administarator and then opent he regedit.
    2. After that you have to go to HKCR\TypeLib\{F5078F18-C551-11D3-89B9-0000F81FE221}\6.0\0\win32
    3. Then you need to right click an give yourself complete access for the key.
    4. After completing this you need alter the values from %SystemRoot%\System32\msxml6.dll to c:\windows\System32\msxml6.dll and then try to reinstall

    What I found was that a third party program (TaxWorks) had changed this and it was pointing to C:\program files\common files\taxprep\msxml6.dll

    I sure hope this helps the rest of you struggling with this problem.

     

    cheers!

    • Marked as answer by JepthaT Wednesday, October 06, 2010 5:57 PM
    Wednesday, October 06, 2010 5:57 PM
  • Hi Jeptha,

    You have the same workaround described in http://support.microsoft.com/kb/2290714 .

    HTH

    Wednesday, November 10, 2010 12:50 PM
  • Thanks for the info but you fail to give exact precise instructions as to which folder in the registry I am supposed to open to find the string you mention in your solution. Please clarify with EXACT INSTRUCTIONS. Thanks!
    Wednesday, July 13, 2011 6:31 PM
  • GENIUS. TaxWorks was the issue here too. Thanks a million. Hopefully it doesn't break tax works now :)
    Wednesday, August 01, 2012 9:19 PM