none
Cannot export site collection via export-spweb : cannot find an spweb object with id RRS feed

  • Question

  • Hello all,

    When trying to export a site using this command, I got the following error. I already checked that the user running the command is DB owner of the WSS content database of the current web application.

    Thanks a lot for your help.

    Regards,

    Saïd

    PS C:\Users\admin> Export-SPWeb -Identity "http://test28:2707/sites/tata"
    -Path "D:\\cmps\test.cmp"
    Export-SPWeb : Cannot find an SPWeb object with Id or Url : http://test28:27
    07/sites/tata.
    At line:1 char:13
    + Export-SPWeb <<<<  -Identity "http://test28:2707/sites/tata"  -Path "D:\\c
    mps\test.cmp"
        + CategoryInfo          : InvalidData: (Microsoft.Share...CmdletExportWeb:
       SPCmdletExportWeb) [Export-SPWeb], SPCmdletPipeBindException
        + FullyQualifiedErrorId : Microsoft.SharePoint.PowerShell.SPCmdletExportWe
       b

    Friday, April 12, 2013 2:08 PM

Answers

  • Hello all,

    Thanks for your reply.

    @Daniel : Backup is working not Export :(

    I tried with ID itself as suggested by Yogesh : same issue.

    Anyway, I managed to do it via the Central Admnistration. It worked. I could not investigate more because I have a short deadline for this project.

    Thanks a lot for your help.

    edit: after investigation, I solved the issue by adding the farm admin as a site collection administrator

    Said


    • Marked as answer by Said Khammar Wednesday, April 17, 2013 8:16 AM
    • Edited by Said Khammar Wednesday, April 17, 2013 2:38 PM
    Wednesday, April 17, 2013 8:16 AM

All replies

  • Your identity must be the default zone for the URL & resolvable

    Hope This Helps!


    Friday, April 12, 2013 2:15 PM
  • Thanks for your reply.

    I cannot export a site collection ? The goal is to create a copy of this site collection in the same web application.

    Do you have any explanation regarding identity ? Identity means the site URL ?

    Thanks a lot,

    Said

    Monday, April 15, 2013 8:30 AM
  • No you can export the site.  Yes -Identity is site URL

    Hope This Helps!


    • Edited by ThatGuyRyan Monday, April 15, 2013 12:43 PM clarified
    Monday, April 15, 2013 10:41 AM
  • I'm using the URL list in the site collection list, in the Central Administration.

    I have the same issue with any of the collection site listed.

    Of course all those site collections are using the same WSS content database.

    Test28 is my server name

    2707 the web app port number


    Export-SPWeb -Identity "http://test28:2707/sites/tata" -Path "D:\\cmps\test.cmp"

    Monday, April 15, 2013 2:57 PM
  • Hi Said,

    Could you be able to login the site collection from the IE Browser?

    I could use the Export- SPWeb -Identity "http://serverName:port/sites/siteCollection" -Path "c:\DB\abc.cmp" with SharePoint farm administrator.

    You can try to use the cmdlet Backup-SPSite to back up a site collection per the following article, then check result again.

    http://technet.microsoft.com/en-us/library/ff607901(v=office.14).aspx

    Thanks


    Daniel Yang
    TechNet Community Support

    • Proposed as answer by Leendert Dr Wednesday, April 17, 2013 8:23 AM
    Tuesday, April 16, 2013 8:12 AM
    Moderator
  • Hi Said,

    I'm assuming, the URL you mentioned above is a site collection URL. Can you please try below script in powershell and share the results:

    $site = Get-spsite "http://test28:2707/sites/tata"

    $web = $site.RootWeb

    $web | select ID

    this will give a GUID. Now, modify your export script in this way:

    Export-spweb -Identity "<ID Generated by above script>" -Path D:\cmps\test.cmp

    Looking forward for the results from you.

    Tuesday, April 16, 2013 9:33 AM
  • Hello all,

    Thanks for your reply.

    @Daniel : Backup is working not Export :(

    I tried with ID itself as suggested by Yogesh : same issue.

    Anyway, I managed to do it via the Central Admnistration. It worked. I could not investigate more because I have a short deadline for this project.

    Thanks a lot for your help.

    edit: after investigation, I solved the issue by adding the farm admin as a site collection administrator

    Said


    • Marked as answer by Said Khammar Wednesday, April 17, 2013 8:16 AM
    • Edited by Said Khammar Wednesday, April 17, 2013 2:38 PM
    Wednesday, April 17, 2013 8:16 AM