locked
outlook and wpad proxy configuration RRS feed

  • Question

  • Hi all,

     

    I have setup a wpad file and configured IE to use automatically detect settings. That's all working fine, I am able to browse the internet.

    However, it seems like outlook 2010 is not using this option and is bypassing the wpad file. Therfeore I am unable to connect to a remote mailbox.

    When setting the option to use a configuration script and point to the same wpad file, the connection is working properly.

     

    Any idea's why ouytlook is not using the automatically detect settings option?

    Thursday, January 12, 2012 4:39 PM

Answers

  • Solved the issue.

    It turned out that the bindings on the IIS servers hosting the WPAD file was causing the issue.

    It seems like the winHTTP connections are not connecting to wpad based on FQDN, but on IP address.

    As the websites are load balanced by an HLB, the IP address for the record wpad.domain.com is not the same as for the web server.

    The IIS server is hosting multiple websites and the binding "All unassigned" for port 80 was assigned to a different website.

    When changing the assignment to the WPAD website outlook was able to connect.

    • Marked as answer by David Wolters Tuesday, February 7, 2012 4:19 PM
    Tuesday, February 7, 2012 2:35 PM

All replies

  • Hi Arjen,

    Could you tell us, which file extention did you use to save the WPAD file?

    To make it work for Outlook, please ensure the two things below:

    1st. The WPAD file is saved as .js file extention.

    2nd. The WPAD file is saved on the location other than the ISA Server.

    e.g.

    IE Settings for local WPAD script

    The entries in red are mandatory to ensure that the script is taken from the local file system.  The entry in blue describes the proper format for using a script located on the local file system.

    Sincerely,

    Max Meng
    Forum Support


    Come back and mark the replies as answers if they help and unmark them if they provide no help.
    If you have any feedback on our support, please contact tnmff@microsoft.com.

    • Edited by Max Meng Tuesday, January 17, 2012 8:51 AM
    Monday, January 16, 2012 6:16 AM
  • Dear Max,

     

    Thank you for replying.

    The file I use is called wpad.dat, to support dns lookup for accessing the wpad file.

    We have set the option "Automaitcally detect settings" instead of "use automatic configuration script".

    However, when I use the last option (like in your screenshot) and point to the wpad.dat file, outlook is working properly.

    BTW, we store the wpad file on an internal IIS server.

     

    Arjen

    Monday, January 16, 2012 8:12 AM
  • Hi Arjen,

    Thanks for the feedback, so should I consider the problem has been solved?


    Max Meng

    TechNet Community Support

    Monday, January 16, 2012 8:19 AM
  • No, it is not solved yet. 

     

    I don't want to specify the "use automatic configuration script", but only the "automatically detect settings" option.

    I'll try to store the wpad.dat file as wpad.js to if that makes any difference.

     

    I'll let you know the result.

     

    Arjen

     


    • Edited by Arjen_ Monday, January 16, 2012 8:23 AM
    Monday, January 16, 2012 8:22 AM
  • FYI:

    Renaming the file to wpad.js did not solve my issue...

     

    Arjen

    Monday, January 16, 2012 10:14 AM
  • Hi Arjen,

    I am trying to involve someone familiar with this topic to further look at this issue.


    Max Meng

    TechNet Community Support

    Wednesday, January 18, 2012 1:05 AM
  • Great!

     

    Let me know when I have to test things...

     

    Arjen

    Friday, January 20, 2012 1:51 PM
  • Solved the issue.

    It turned out that the bindings on the IIS servers hosting the WPAD file was causing the issue.

    It seems like the winHTTP connections are not connecting to wpad based on FQDN, but on IP address.

    As the websites are load balanced by an HLB, the IP address for the record wpad.domain.com is not the same as for the web server.

    The IIS server is hosting multiple websites and the binding "All unassigned" for port 80 was assigned to a different website.

    When changing the assignment to the WPAD website outlook was able to connect.

    • Marked as answer by David Wolters Tuesday, February 7, 2012 4:19 PM
    Tuesday, February 7, 2012 2:35 PM
  • Also note that Outlook uses WinHHTP. Meaning in the proxy configurations, you should use http:// for he proxy script file. File:// will cause different types of issues.

    WinHTTP itself has no
    support for file:// URL’s (you can’t access a file:// URL with WinHTTP regardless
    of whether it’s a PAC file or normal file).

    So, file:// URL’s for a PAC file will not work for use with Outlook or ANY WinHTTP
    client (there are many others).

    VB

    Thursday, February 9, 2012 1:15 PM