Microsoft 2010 won't open only Word Starter


  • When ever I tried to open Microsoft 2010 Word or Excel the starter programs open and not the actual programs.  I have tried to restart my computer after making sure the settings were to open only with Microsoft 2010, but it still won't work.  It says that I have to enter my product key, but I already have it installed on my computer so it tells me that the product key is invalid. Does anyone know what I need to do?
    Sunday, June 12, 2011 12:36 PM

All replies

  • Hi,


    You have a preinstalled trial on the computer for Office. You must buy Office, which includes Word. It's always been like this. Word has never been free.

    you have to purchase a retail version of Office to continue using the product. Refer the link below to purchase office.



    • Marked as answer by Harry Yuan Friday, June 17, 2011 5:16 AM
    • Unmarked as answer by David Wolters Monday, June 20, 2011 2:23 PM
    Wednesday, June 15, 2011 2:48 AM
  • Hello, thank you for responding, but I already bought Office and installed it on my computer and the fact that it would only open up the Word and Excel starters when I wanted to open Word and Excel was the result I was trying to fix. I was able to fix the Word program by changing my preferences to open with Microsoft Word 2010, but the Excel still won't open in Excel 2010 it will only open in the starter.
    Sunday, June 19, 2011 7:56 PM
  • Hi,

    Do you get any error message before the the message that product key is invalid display?

    Repair the Office starter installation referring the link below and check if it helps resolve the issue:

    • Click Start > Control Panel > Programs (Programs and Features)
    • Right click on Microsoft Office 2010 starter in the currently installed programs list, and then click Change.
    • Select 'repair' and then click Continue.


    Tuesday, June 21, 2011 1:49 AM
  • I'm having the same trouble, i repaired word, it downloaded updates.. it worked for a while then started doing the same thing a few days later, then i had to repeat the process. not good >:(

    Tuesday, June 28, 2011 12:38 AM
  • you are a life saver i had the same problem and thanks to you i fixed it thank you!!!
    Friday, September 02, 2011 8:58 PM