Exchange 2010 UM Dial Rule group not processing order properly


  • I am currently using exchange 2010 SP1 RU1, and we are converting from Cisco Unity to exchange UM.  I have been trying to fix a problem where when users call in to OVA and try to dial someone from their personal contacts, it uses the full phone number including area code.  I created the following dial rule groups

    number mask dialed number

    91555xxxxxxx xxxxxxx (local numbers within our own area code)

    9555xxxxxxx xxxxxxx (local numbers within our own area code, without a 1 prefixed)

    9555666xxxx xxxx (our internal did range)

    * * (all numbers)

    According to the documentation, exchange uses its own internal methods to order the rules based on the most specific to the least specific, but that doesnt appear to be the case.  As long as I have the * rule in place, it ignores all the other "more specific" rules!  To make matters worse, if i take out the * rule, the option to dial mobile or home numbers disappears!

    I tried replacing the * rule with 2 rules using xxxxxxxxxx (10 digits) and xxxxxxxxxxx (11 digits) but the option for mobile and home still ended up disabled.

    Any ideas how to fix this issue, or is it just a bug?

    Wednesday, March 07, 2012 1:19 PM

All replies

  • Hi,

    I believe the connection is TCP ,so you may try wireshark trace on the Exchange UM server.

    Then see what number is being tried .

    Wednesday, March 07, 2012 1:49 PM
  • yea thats what i did, and essentially the * * rule is what is being used instead of the more specific rules. This means that our exchange UM is sending a 9-1-555-xxx-xxxx number which for a local call wont work as it needs to just be 7 digits. Without that * * rule everything works, but then the option to call mobile/home/etc goes away
    Wednesday, March 07, 2012 1:51 PM