none
How to by default uncheck send an email invitation when granting access RRS feed

  • Question

  • How to permanently disable send an email invitation when granting access? We need it by default unchecked ( send an email invitation unchecked). Is there any registry or database entry we can update, or run some powershell command?
    Wednesday, August 14, 2013 2:12 PM

Answers

  • This is not available in a supported manner.  The file is "C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\TEMPLATE\LAYOUTS\AclInv.aspx".

    You can change:

    <wssawc:InputFormCheckBox
    				  runat="server"
    				  id="chkSendEmail"
    				  Checked="True"
    				  LabelText="<%$Resources:wss,aclver_SendEmailCheckbox%>"

    To:

    <wssawc:InputFormCheckBox
    				  runat="server"
    				  id="chkSendEmail"
    				  Checked="False"
    				  LabelText="<%$Resources:wss,aclver_SendEmailCheckbox%>"

    Note that a patch may change this, and it would have to be done on every WFE users interact with.  Not a good idea.


    Trevor Seward, MCC

    Follow or contact me at...
      

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    • Marked as answer by Lindali Wednesday, August 21, 2013 10:59 AM
    Wednesday, August 14, 2013 2:59 PM
    Moderator

All replies

  • This is not available in a supported manner.  The file is "C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\TEMPLATE\LAYOUTS\AclInv.aspx".

    You can change:

    <wssawc:InputFormCheckBox
    				  runat="server"
    				  id="chkSendEmail"
    				  Checked="True"
    				  LabelText="<%$Resources:wss,aclver_SendEmailCheckbox%>"

    To:

    <wssawc:InputFormCheckBox
    				  runat="server"
    				  id="chkSendEmail"
    				  Checked="False"
    				  LabelText="<%$Resources:wss,aclver_SendEmailCheckbox%>"

    Note that a patch may change this, and it would have to be done on every WFE users interact with.  Not a good idea.


    Trevor Seward, MCC

    Follow or contact me at...
      

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    • Marked as answer by Lindali Wednesday, August 21, 2013 10:59 AM
    Wednesday, August 14, 2013 2:59 PM
    Moderator
  • Thx. Awesome.
    Its 15 hive. We went live with this change.

    C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\15\TEMPLATE\LAYOUTS\AclInv.aspx

    • Edited by VikasDMore Tuesday, October 1, 2013 7:59 PM Added implementation details
    Thursday, September 5, 2013 4:56 PM
  • Hello,

    I cannot find id="chkSendEmail" in the AclInv.aspx under folder 15. I made the change in AclInv.aspx in folder 14. However, the check box is still checked by default? Please help. Thanks.

    Monday, February 10, 2014 3:40 PM
  • You need to look for

    id="chkSendEmailv15"

    in the

    C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\15\TEMPLATE\LAYOUTS\AclInv.aspx

    file because its changed in SharePoint 2013.

    On the line below

    id="checkSendEmailv15"

    change "Checked" to "false".

    Make sure to change on all Web Front Ends. . .


    Kathryn Birstein, Senior SharePoint Architect

    Monday, April 21, 2014 3:21 PM
  • Thank you Kathryn, The new solution works.
    Monday, April 21, 2014 3:32 PM
  • This solution is horrible - hacking the ASPX?! Where is the actual setting to turn it off?
    Tuesday, May 6, 2014 11:36 PM
  • There is no actual setting. Hence why I said that this is not a good idea.

    Trevor Seward

    Follow or contact me at...
      

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Tuesday, May 6, 2014 11:37 PM
    Moderator
  • Well, I don't have an option - it's what the client wants. It'll get done on every WFE. And then it'll get overwritten in patch, which they know.

    Tuesday, May 6, 2014 11:39 PM
  • Another option is to put extra JavaScript in the Masterpage which uncheckes the checkbox after pageload.

    if you have jQuery something like:

    $( document ).ready(function() {
    $('#ctl00_PlaceHolderMain_chkSendEmailv15').attr('checked',false);
    });

    That way you never have to worry about new patches/upgrades changing the ASPX file.

    I add this while building new SiteCollections in Office365 SharePoint Online and remove it when it goes public.

    But you can leave it in..


    Tuesday, May 13, 2014 10:23 AM
  • You can not call:

    $('#ctl00_PlaceHolderMain_chkSendEmailv15')

    on premise SharePoint, becauste the page AclInv.aspx is rendered in the iframe and you will not select it with jquery.

    Wednesday, May 21, 2014 12:33 PM
  • You can not call:

    $('#ctl00_PlaceHolderMain_chkSendEmailv15')

    on premise SharePoint, becauste the page AclInv.aspx is rendered in the iframe and you will not select it with jquery.

    Works fine for me.
    Thursday, March 12, 2015 1:47 PM
  • Hi there, can't seem to locate this with Sharepoint 365... could you point me in the right direction?

    Thanks

    Danny

    Wednesday, October 28, 2015 5:01 PM
  • The risk of disabling this checkbox by default is that it also impacts the sharing behavior of documents.

    When sharing a document there also will not be sent an invitation.

     

    Tuesday, January 19, 2016 10:29 AM
  • So if this is a bad idea, and the comments below about document sharing would suggest it really is, as an alternative to disabling the 'Invite' option here, is there an easy way to default to "Show Options" rather than hide that single solitary control behind the  "Hide Options" at least that way we will have the relevant visual prompt?
    Monday, October 23, 2017 8:53 AM