none
The crawler could not communicate with the server. Check that the server is available and that the firewall access is configured correctly. RRS feed

  • Question

  • Hi,

    After crawling i am getting the below error

    The crawler could not communicate with the server. Check that the server is available and that the firewall access is configured correctly.

    As per the below,i checked out home pages and i am able to browse the pages.

    http://sharepointroot.com/2012/03/16/sharepoint-search-the-crawler-could-not-communicate-with-the-server/

    The account that i am using is having secondary site collection admin access to the parent site.

    But couldn't get the resolution on the same.

    Please suggest me to overlook this error.


    Thanks & Regards, Sudheer

    Friday, December 28, 2012 3:51 AM

Answers

  • Your crawl account should have the Full Read permission on the User Policy at the Web Application level.  It should not have any specific permission on any site collection.

    SharePoint - Nauplius Applications
    Microsoft SharePoint Server MVP
    MCITP: SharePoint Administrator 2010

    -----------------------
    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Friday, December 28, 2012 7:29 AM
    Moderator
  • Hi Sudheer,

    Can you browse to the WebApp from the server that is performing the Crawl? The first issue is usually the most typical is the LoopBackCheck 

    1. Click Start, click Run, type regedit, and then click OK.
    2. In Registry Editor, locate and then click the following registry key:
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\MSV1_0
    3. Right-click MSV1_0, point to New, and then click Multi-String Value.
    4. Type BackConnectionHostNames, and then press ENTER.
    5. Right-click BackConnectionHostNames, and then click Modify.
    6. In the Value data box, type the host name or the host names for the sites that are on the local  computer, and then click OK.
    7. Quit Registry Editor, and then restart the IISAdmin service.

    The second issue depends on where you have the Index, Query and Crawl servers and usually occurs because you have set one of your WFEs as dedicated for Crawling....

    -Ivan


    Ivan Sanders My LinkedIn Profile, My Blog, @iasanders.

    Sunday, December 30, 2012 3:25 AM

All replies

  • Your crawl account should have the Full Read permission on the User Policy at the Web Application level.  It should not have any specific permission on any site collection.

    SharePoint - Nauplius Applications
    Microsoft SharePoint Server MVP
    MCITP: SharePoint Administrator 2010

    -----------------------
    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Friday, December 28, 2012 7:29 AM
    Moderator
  • Hi Sudheer,

    Can you browse to the WebApp from the server that is performing the Crawl? The first issue is usually the most typical is the LoopBackCheck 

    1. Click Start, click Run, type regedit, and then click OK.
    2. In Registry Editor, locate and then click the following registry key:
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\MSV1_0
    3. Right-click MSV1_0, point to New, and then click Multi-String Value.
    4. Type BackConnectionHostNames, and then press ENTER.
    5. Right-click BackConnectionHostNames, and then click Modify.
    6. In the Value data box, type the host name or the host names for the sites that are on the local  computer, and then click OK.
    7. Quit Registry Editor, and then restart the IISAdmin service.

    The second issue depends on where you have the Index, Query and Crawl servers and usually occurs because you have set one of your WFEs as dedicated for Crawling....

    -Ivan


    Ivan Sanders My LinkedIn Profile, My Blog, @iasanders.

    Sunday, December 30, 2012 3:25 AM