none
Overdue task reminder even after task /library deleted RRS feed

  • Question

  • Hello everyone,

    I know there are tons of threads on this subject but those aren’t helping in my situation. Here is the situation:

    1.        SharePoint 2007 with SP3 (12.0.0.6608)
    2.        Notifications are only coming from one document library where the OOB approval workflow was running
    3.        Email subject line reads “Task assigned to XXX on 9/7/2012 is overdue.”
    4.        Email body says “Task assigned to XXX on 9/7/2012 is overdue. Due by 9/14/2012”
    5. The task referenced is already deleted from the list.
    6. Workflow already cancelled

    Here are few things I've tried without any luck.

    1.        Cleared the configuration cache from all servers in the farm
    2.        Deleted the document library where the approval workflow was running
    3.        Not finding the Task item in the content database - Select * from SecheduledWorkItems where ID=’GUID’ where GUID is the ID of the task
    4.        Databases are synced - stsadm -o sync –listolddatabases
    5.        Confirmed these alerts aren't coming from another parallel farm :-)

    Anything else I can do to stop these nuisance alerts? Any feedback would be greatly appreciated!

    Many thanks in advanced!

    BlueSky2010
    Please help and appreciate others by using forum features: "Propose As Answer", "Vote As Helpful" and "Mark As Answer"

    Friday, January 4, 2013 9:35 PM

Answers

  • Karan - 

    This is exactly what happened in our case too. Initially I did not pay much attention to the QA environment as on the notification emails the URL was pointing to the Prod server. As we restore content DB from Prod. I removed the task from the QA site - almost 2 months now and no user reported this issue after. 

    Thanks for your suggestion though.


    BlueSky2010
    Please help and appreciate others by using forum features: "Propose As Answer", "Vote As Helpful" and "Mark As Answer"


    Friday, March 15, 2013 9:17 PM

All replies

  • Hi,

    Thank you for your post.

    I'm trying to involve someone familiar with this topic to further look at this issue.

    Thanks & Regards,
    Emir Liu
    TechNet Subscriber Support in forum
    If you have any feedback on our support, please click here.


    Emir Liu
    TechNet Community Support

    Monday, January 7, 2013 4:51 AM
  • Thanks Emir for your response. Any luck finding a resource for this? 

    Appreciate your help!


    BlueSky2010
    Please help and appreciate others by using forum features: "Propose As Answer", "Vote As Helpful" and "Mark As Answer"

    Tuesday, January 8, 2013 5:42 PM
  • Hi BlueSky2010,

    It seems like you've checked the likely scenerios on what would generally cause this.  I would suggest opening a support ticket to have a much deeper look as to why this is occurring. 


    Regards, Savoeurn Va Microsoft Online Community Support

    Thursday, February 14, 2013 1:39 AM
  • Thank you for getting back to me FINALLY. I'm not really surprised by the level of "Technet subscriber PRIORITY support" - as I've seen threads like this (disregard the 2010 piece of it) before. :-)

    To your suggestion - yes I've worked with a support personnel on the phone on this issue after realizing this thread is going no where :-). 

    Thank you!

    "Subscribers now benefit from priority support in TechNet forums. A Microsoft support professional will respond within 2 business days to your posting if the community hasn't already gotten you the answer. TechNet forums are very active community and a great place to both get help and help others."


    BlueSky2010
    Please help and appreciate others by using forum features: "Propose As Answer", "Vote As Helpful" and "Mark As Answer"

    Thursday, February 14, 2013 3:58 PM
  • Hey BlueSky,

    I also faced this issue once of over due task notifications .i was on verge of getting mad after continuous troubleshooting of 3 days here is how i got it fixed (Could be only applicable in my case) :

    as we all know that in normal case scenario there is dev server , QA and production server and site + list structure also same across these three farms . Try to trace the header information of the overdue task notification mail i am sure you will able to see the you dev/QA server as the source of the mail instead of prod server (the url in the overdue task mail will also point to the prod site ) because most of the times we will create the things in dev and QA for testing and will never delete them . 

    Regards

    Karan Sharma

    Friday, March 15, 2013 9:10 PM
  • Karan - 

    This is exactly what happened in our case too. Initially I did not pay much attention to the QA environment as on the notification emails the URL was pointing to the Prod server. As we restore content DB from Prod. I removed the task from the QA site - almost 2 months now and no user reported this issue after. 

    Thanks for your suggestion though.


    BlueSky2010
    Please help and appreciate others by using forum features: "Propose As Answer", "Vote As Helpful" and "Mark As Answer"


    Friday, March 15, 2013 9:17 PM
  • I'd been banging my head against the wall over two instances where the task had been deleted but reminders still being sent.  Like you, my links appeared to be coming from production!  These tasks were in my test environment so I cancelled the workflows and no more reminders

    Gold Star for you @BlueSky2010!

    Tuesday, September 12, 2017 6:06 AM