none
Sharepoint Incoming Email with .msg attachment,Attachment missing

    Question

  • Hi

    I have a document library confogured to allow incoming emails.My environment is Moss 2007 sp1. When i send an email with an attachment of type doc or pdf or zip. The attachments are there in the document library.

    If i send an email with a .msg file (outlook 2003) as attachment, the attachment goes missing. I Stopped the Timer service and sent an email and the email was available in the drop folder.If i open the email from the drop folder i can see that my attachment is there.Now if i start the Sharepoint timer service the email body is available in the document library but the attachment is Missing. This issue is happening only with attachments of type  .msg.

    Please could you help with this issue.

     

     

     

    • Moved by Mike Walsh FIN Tuesday, April 27, 2010 5:18 PM not customization (From:SharePoint - Design and Customization (pre-SharePoint 2010))
    Tuesday, April 27, 2010 4:14 PM

All replies

  • This is the default behavior when you email enable a document library.

    If you want to save the original email as well.

    1. Go to the Document Library Settings
    2. Followed by Incoming email Settings.
    3. On the Incoming email settings page in the Email Message section.
    4. Choose Yes for Save original email? and click OK.
    Now if you send any new email with attachment, you will be able to see both the Attachment & original email in the document librabry. Hope that helps.

    -Mukesh

     

    Tuesday, April 27, 2010 5:39 PM
  • This  Setting is already done. I am able to send emails with attachment of type PDF or word  etc.it is working fine.but when the attachment is a .msg (outlook 2003) , the attachment fails.
    Tuesday, April 27, 2010 9:29 PM
  • Is "msg" in your Blocked File Types list?  (It's not there by default...)

     


    Mike Smith TechTrainingNotes.blogspot.com
    Tuesday, April 27, 2010 9:34 PM
  • No .I have checked in the central admin and it is not in the blocked type list
    Tuesday, April 27, 2010 11:15 PM
  • Did anyone ever find a resolution to this?  I'm not finding much on the interwebs regarding this 'bug?'.

     

    --UPDATE--

    This appears to be at least partially related to the attachment encoding.  I've been able to get the attachments to show up (in a useless manner) by changing the encoding type from MIME to UUEncode or BinHex.

     

    Anyone know of a way to make the attachments show up as attachments to the 'Original Message'?

    Thursday, July 29, 2010 9:37 PM
  • Hi

    There is no fix for this. I have raised this issue with Microsoft and they said that it is a product Limitation.

    What you can do is write a custom  email event handler to strip the attachment from the orgional email.The .msg would come as an eml file.

     

    The Limitation with this approach is that if the attached .msg has an another attachment ,it is difficult to get the attachment.Please let me know if you need any more help.

    I can provide sample code for the same.

    Regards

    GMR

     

    Saturday, July 31, 2010 9:06 PM
  • Hi Maruti,

     

    can you mention what your environment...?

    which moss version, which IE ur are using , which offec version.

    May be its related to compactability

    check the combinations:

    IE7+office2007+moss2007 may work

    Hope dis Help to U..!

     

     

     


    NavazShaik Sharepoint Developer
    Thursday, May 12, 2011 12:37 PM
  • Hi,

    Please check this blog entry about a fix for this issue.

    http://cesarloaiza.blogspot.com/2014/03/sharepoint-email-eventreceiver-and.html

    Regards,

    Cesar.

    Tuesday, March 11, 2014 10:48 PM