none
List tools tab was missing

    Question

  • Hi there, I have another question today :)

    On of our employees configured a custom list for his needs and also added a second filtered view. Today the list tools tab was missing, it looked like the permissions were gone but that was wrong. Permissions were correctly set and I was logged on as an site collection admin. I managed to get the list tools tab by creating a new view with SharePoint Designer, because I didn´t see another way to get in the list settings.

    Now I´m wondering how this happend, I haven´t seen a way to disable the tools tab without removing permissions. Has anyone an idea?

    Thank you, Sascha

    Monday, November 08, 2010 3:56 PM

Answers

  • The solution is very simple, someone had edited the page and added a content editor web part without adding text. We didn´t see this web part and thought there was something gone wrong but now we know it was our own fault :)
    Tuesday, November 09, 2010 8:38 AM

All replies

  • The solution is very simple, someone had edited the page and added a content editor web part without adding text. We didn´t see this web part and thought there was something gone wrong but now we know it was our own fault :)
    Tuesday, November 09, 2010 8:38 AM
  • I have the same problem, but I actually need the content editor web part on the page.  It seems adding the web part (with content or not) causes the "List Tools" tab to disappear.  Anyone found a solution for this problem?

     

    Thanks,

    Scott

    Friday, February 04, 2011 6:43 PM
  • So do we, we need to add a content editor web part to a list view page, and then the Library Tools tab disappeared...

    Thanks,

    Ching

    Friday, February 04, 2011 7:56 PM
  • I have the same Problem, need to add a Contnet Editor webpart and this makes the Library tools disappear.

    The workaround I found was to remove the content editor webpart and edit the webpart of the list( Not the CEWP  and changed the appearance settings for the webpart to show the  tool bar so you can have the New, Actions and settings available from with the list page.

    I haven't figured out on how to get the List tools to appear with a CEWP.


    • Proposed as answer by VJ3459 Friday, March 18, 2011 5:27 PM
    Friday, March 18, 2011 5:12 PM
  • VJ,
     
    If you'd like/need to keep the CEWP, here’s another work-around for you:
     
    1) Go into the edit mode for the page/library/calendar (Site Actions>>Edit Page) and edit the web part of the library/list/calendar
     2) Under “List View” select “Show Toolbar” and click “OK”
     
    With the proper permission you should see the “New”, “Actions” and “Settings” buttons at the top of your list. You can use the “Settings” button to access the List Settings. Or, if you click on the drop-down arrow next to "New" or  “Actions”, all of the ribbon menus for the list reappear.  Someone explained to me once why the ribbon vanishes, but I was so happy this worked I sort of tuned them out (multiple web part, blah blah, ribbon can't tell the difference, blah blah).

    Anyway, I hope that helps :)

    Note: there's also a back-end solution floating around...the steps above work well from an end-user POV.

    Tuesday, June 07, 2011 6:53 PM
  • What is the back-end solution?
    Monday, July 02, 2012 8:43 PM
  • Hi,

    may i know is there any way to have the List Tool tab enabled, while have mixed type of web part ?

    is there easier way other than using codes?

    Tuesday, October 16, 2012 1:23 AM
  • I had this same issue and I've found a work-around that should be helpful...

    It appears that SharePoint 2010 does not like to have a Content Editor Web Part added to view for a List or Library. I needed to have a CEWP that would hide teh Add New Item link at teh bottom of the list and put in a new custom button.  So this was an important item for me to keep on the page. Instead of finding all kinds of other coded options, here's the easiest way to get the tabs to appear on the screen.

    Select a Row within your view.  It doesn't matter what the item is.  Once selected, you will see all of teh tab items appear like normal. 

    This is the quickest and easist way to get these items to appear again.

    Good Luck!

    Matt

    Thursday, November 01, 2012 2:27 PM
  • Best answer yet!  Thanks.  Worked.  Happy.
    Wednesday, July 03, 2013 9:25 PM
  • Also found that in addition to selecting "Show Toolbar" when I Edit Page for the Library on same page as Content Editor, if i simply select one of the documents in the Library (i.e., place pointer in the checkbox next to the Name) the Tool Ribbon returns!

    In this manner, I have toolbar always available, both as soon as page comes up,via Show Toolbar - so people won't say "Help, there is no Toolbar for the Library!" and sort of hidden (until one selects a document).

    Tuesday, July 09, 2013 3:48 PM
  • So helpful! I hate it when people edit list view pages. If you need content on the page, much better to create a web part page or wiki page and then add a list view to that page. Thank you so much for this simple solution!!
    Monday, February 01, 2016 9:17 PM
  • An alternative solution from Prasad Pathak:

    "Other solution is to keep the focus on the List Views web part using JavaScript."

    <script type="text/javascript">
    ExecuteOrDelayUntilScriptLoaded(init_defaultWP, "sp.ribbon.js");
    
    function init_defaultWP() {
      setTimeout(function () {
      var defaultWP = document.getElementById"MSOZoneCell_WebPartWPQ2");
    
    WpClick({ target: defaultWP, srcElement: defaultWP });
    
    SP.Ribbon.WebPartComponent.$3.deselectWebPartAndZone = function () { };}
    , 100);}
    
    </script>
    Monday, August 07, 2017 2:55 PM