none
RDS Clipboard loosing HTML format when c drive redirected RRS feed

  • Question

  • I have faced with problem , if i'm trying to copy\paste HTML formated text from remote session to local workstation ,HTML data is not being transferred i see only plain text. This happenes only if drive C is redirected to remote session, if i will redirect all other drives excepts C , everything is ok.

    I have tested this on several client computer using different RD servers, but situation is same.


    Client computer- Windows 7 Pro SP1

    RD Server- Server 2008 R2 SP1

     
    Thursday, October 17, 2013 6:32 AM

Answers

All replies

  • Hi,

    Firstly, please provide little more information from your side.

    1.  Does this issue occurs with all user or any particular user?
         If it’s for any particular user, then check whether you assign any permission in GPO for that user.

    2.  Does the cut-and-paste work within the remote session? For example, cut some words and paste it into itself and another RemoteApp program.

    3.  Does this occur for only HTML format specific or with notepad.exe also?

    4.  Is there any local policy and group policy settings applied to disable the clipboard redirection? As per “RDP copy-and-paste not working” article.


    Computer Configuration \ Administrative Templates \ Windows Components \ Remote Desktop Services \ Remote Desktop Session Hosts \ Device and Resource Redirection \ Do not allow clipboard redirection


    Here, I can suggest you to check a registry key as per KB 2492632. Set the value from 0 to 1 on below mention path and check the issue.


    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\Wds\rdpwd\fEnableRDR


    Apart from that, check the following setting in Group Policy for ‘Hiding/Preventing Access to Drives’ as per this article and refer Local drive redirection not working in RDP Session.

    Hope it helps!
    Thanks.


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time.
    Thanks for helping make community forums a great place.

    Friday, October 18, 2013 6:02 AM
    Moderator
  • 1. This applies to all users without exception.

    2. yes ,if i will try to copy\paste in remote session to for example MS WORD , evcerything seems to be ok.

    3. Normal text is copied without problems. Problem is only with HTML formated text.

    4. No, I have some clean test environment, RD,AD servers without policy. 

    Tried to set fEnablePrintRDR,fEnableRDR to 1 but without luck.

    It looks like this is some kind of bug ,today i tried to setup RD on server 2012 and result was same.

     

    Saturday, October 19, 2013 10:46 AM
  • Hi,

    As per my last comment, I am trying to say that you can configure the setting of “Do not allow clipboard redirection” to Disable status under Group Policy path which I have mentioned. When you will disable that option then Remote Desktop Service always allows clipboard redirection. Please have a try.

    Thanks.


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time.
    Thanks for helping make community forums a great place.

    Tuesday, October 22, 2013 12:59 AM
    Moderator
  • Hello,

    we are facing the exact same problem. I've already set the value for "Do not allow clipboard red." to disable, but this has no effect.

    Terminalservers are Win2k3 and Win2k8, the Client Win 7. It seems (I cannot test it at the moment) that this issue doesn't happen on Win XP.

    With redirected local drive C to the terminalserver it is not possible to copy & paste HTML-content from the terminalserver to the client, i.e. a HTML-Table from IE9 on the TS to Excel on the client. I can paste content though - but it is not formated - just as text.

    Without redirected local drive C or just with other redirected drives (i.e. D), it is no problem to copy and paste HTML content from TS to the client.

    So it seems that the redirected local drive C blocks the clipboard in some way.

    It was hard to reproduce the issue, because at first I thought the reason had to be the version of MS Office on the client.

    Best regards

    Praenki

    Wednesday, November 6, 2013 7:50 AM
  • We are also facing the same problem. I have Clipboard redirection enabled, and copy/paste functionality works fine in both directions except that any HTML formatted data on the clipboard is not being transferred, only plain text is. For example, when I copy a block of colored, formatted text from a browser on the server (the RD host) and paste it into Word on my local machine, it is inserted as plain text. All of the formatting and coloring is lost.

    However, if I disable redirection of my local C: drive across the remote desktop connection, then copy/paste functions exactly as expected. The HTML format comes across the clipboard, and anything pasted into Word retains its coloring and formatting. I can connect other local drives such as CD-ROM drives or thumb drives and the remote clipboard is not affected. The problem only occurs when I connect the C: drive.

    I wrote a small app to monitor the clipboard and have verified that the problem is indeed the fact that when the C: drive is connected in the remote session, the HTML clipboard format is not added to the clipboard in either direction. I have been unable to find a solution to this after days of searching and am hoping that there is a solution that isn't just "don't connect the C: drive".


    My local machine is running Windows 7 Enterprise (X64) with Service Pack 1
    The server is running Windows Server 2003 with Service Pack 2

    The issue doesn't happen on winxp.

    Friday, November 8, 2013 2:08 AM