none
Access computers by IP addresses, but not by Computer Name

    Question

  • On my local network, I can type the ip address like so: \\xxx.xxx.xxx.xxx of a computer and access the shared files/printers of that computer.

    But when I try by computer name, it does not let me.  Any reason why?

    Thursday, March 14, 2013 10:45 PM

Answers

  • If you're running a standard environment, where there's only your modem / router and a smaller number of devices - access your local gateway (usually 192.168.0.1, 10.0.0.138 or 192.168.1.1), enter your credentials (usually admin/admin) and check under the configuration that the DNS service is turned on. If not, you will need to enable this, save the settings and possibly restart your modem/router.


    If you're running a server which runs the DHCP & DNS services on your network, ensure that the DNS service has started correctly. It's probably worth restarting the services regardless, just to be sure. Open the DNS MMC and check to see if there are any records in the Forward Lookup Zone. If not, you've got an issue with computers registering their details in DNS. Ensure that it has been configured correctly and that PC's are able to update their own records.

    Useful commands:

    ipconfig / flushdns
    Flushes all locally cached DNS records, may resolve a problem where an IP address has not been updated by the local system.


    ipconfig /all
    look for DNS server under the connected interface, if there is none then the IP settings are probably set to static and you will need to set the DNS manually under your network interface card settings.

    nslookup <pcname>
    Will give you the IP address assigned to the computer you are looking up according to the DNS table in the DNS.

    ping <pcname>
    Ping the computer you are trying to access via PC name, if it resolves an IP, run ipconfig on the computer you are trying to access and make sure the IP matches.

    netsh int ip reset C:\reset.log
    Completely reset the NIC, clearing cache and network settings.



    If you're still having problems,  perhaps try restarting the modem/router/server and clients PC's. This will usually fix quite a few problems.

    Friday, March 15, 2013 1:42 AM

All replies

  • DNS.  Sounds like your not able to resolve names.  Try a "ping COMPUTERNAMEHERE" or a "ping -a IPADDRESSHERE" and obviously replace with computer name and IP address where i labeled.  Report back results.

    Be kind and Mark as Answer if I helped.

    Thursday, March 14, 2013 11:36 PM
  • If you're running a standard environment, where there's only your modem / router and a smaller number of devices - access your local gateway (usually 192.168.0.1, 10.0.0.138 or 192.168.1.1), enter your credentials (usually admin/admin) and check under the configuration that the DNS service is turned on. If not, you will need to enable this, save the settings and possibly restart your modem/router.


    If you're running a server which runs the DHCP & DNS services on your network, ensure that the DNS service has started correctly. It's probably worth restarting the services regardless, just to be sure. Open the DNS MMC and check to see if there are any records in the Forward Lookup Zone. If not, you've got an issue with computers registering their details in DNS. Ensure that it has been configured correctly and that PC's are able to update their own records.

    Useful commands:

    ipconfig / flushdns
    Flushes all locally cached DNS records, may resolve a problem where an IP address has not been updated by the local system.


    ipconfig /all
    look for DNS server under the connected interface, if there is none then the IP settings are probably set to static and you will need to set the DNS manually under your network interface card settings.

    nslookup <pcname>
    Will give you the IP address assigned to the computer you are looking up according to the DNS table in the DNS.

    ping <pcname>
    Ping the computer you are trying to access via PC name, if it resolves an IP, run ipconfig on the computer you are trying to access and make sure the IP matches.

    netsh int ip reset C:\reset.log
    Completely reset the NIC, clearing cache and network settings.



    If you're still having problems,  perhaps try restarting the modem/router/server and clients PC's. This will usually fix quite a few problems.

    Friday, March 15, 2013 1:42 AM
  • It's weird. Now I can ping a computer-name, but if I try to do an nslookup on that computer-name it will say: "*** UnKnown can't find bellavia-laptop: Non-existent domain"
    Thursday, March 28, 2013 3:47 AM
  • is this a home network, or an AD environment?

    if this is an AD environment, type ipconfig /all

    check the DNS server settings make sure it's pointing to your DNS server (private IP address) and there's no Public DNS

    if the settings is mix with Private IP DNS and Public IP DNS you will experience definitely this issue.

    Sometimes you can ping computer name and sometimes it won't.

    if it's a home network, access your home router and setup the dns settings.

    Good luck!


    Every second counts..make use of it.

    Thursday, March 28, 2013 4:30 AM
  • On my local network, I can type the ip address like so: \\xxx.xxx.xxx.xxx of a computer and access the shared files/printers of that computer.

    But when I try by computer name, it does not let me.  Any reason why?

    a simple way is go to host file and edit it and put your ip address with full name . the host file is in 

    C:\Windows\System32\drivers\etc (C is drive for windows)

    and edit with not pad then add fro example :

    192.168.1.1       Server1


    Dear Problems ,You May Big But My God Is Bigger.

    • Proposed as answer by nokuthulam Monday, November 11, 2013 10:47 AM
    Thursday, March 28, 2013 4:41 AM
  • It's weird. Now I can ping a computer-name, but if I try to do an nslookup on that computer-name it will say:

    "*** UnKnown can't find (computer-name): Non-existent domain"

    • Edited by E.Zero Tuesday, April 02, 2013 3:56 PM
    Tuesday, April 02, 2013 3:55 PM
  • Check your NetBIOS status. 

    1. Go to Network and Sharing Center.
    2. Click "Change adapter settings."
    3. Select your network adapter (e.g., "Local Area Connection")
    4. Click "Change settings for this connection"
    5. Select "Internet Protocol version 4 (TCP/IPv4)" and click the "Properties" button
    6. Click the "Advanced" button on the "General" tab
    7. Select the "WINS" tab
    8. Select the radio button to "Enable NetBIOS over TCP/IP"
    9. OK your way out

    This was more necessary in XP, because Win 7 is supposed to check to see if the DHCP server (i.e., your router) provides the NetBIOS setting and enables NetBIOS if the DHCP server does not provide a setting (home routers do not).  Still, it wouldn't hurt to explicitly enable NetBIOS.

    • Proposed as answer by Mike Voon Saturday, December 03, 2016 2:59 AM
    Tuesday, April 02, 2013 4:40 PM
  • I am using a DLink TL-WR940N wireless router which has DHCP.  I looked for NetBIOS settings on the actual router, but I could not find any.

    I am convinced that the Computer-Name problem I 'm having is being caused by my wireless network hosted by my DLink router.

    I have upgraded firmware, restored defaults, and I am using a very simple, almost default, setup on my DLink router.

    Any suggestions where to go from here?

    Monday, April 08, 2013 3:00 AM
  • There isn't any facility on home routers to set NetBIOS, which is why you should configure the client computers to "Enable NetBIOS" rather than the default, which is to rely on the DHCP server.

    There are 3 options on the WINS tab of the network adapter's properties:

    • Default: Use NetBIOS setting from the DHCP Server. If static IP address is used or the DHCP server does not provide NetBIOS setting, enable NetBios over TCP/IP
    • Enable NetBIOS over TCP/IP
    • Disable NetBIOS over TCP/IP

    In XP, that last sentence for the default option isn't there, which is why I said doing this was necessary in XP but perhaps not in Win7.

    Monday, April 08, 2013 11:30 AM
  • Ok, but why would my network sometimes understand the computer-names and sometimes not?
    Saturday, April 13, 2013 6:36 PM
  • Ok, but why would my network sometimes understand the computer-names and sometimes not?

    check the workstation machine DNS settings whether its pointing to your local or internal DNS server.

    If your DNS settings is mixed with internal DNS IP Address and a Public DNS you will experience this issue.


    Every second counts..make use of it.

    Sunday, April 14, 2013 1:09 AM
  • I had faced this issue and none of the above solution was not working in my case.

    First try pinging the server with name, if no add the server name and IP address in LMHOST. then proceed to below.

    I fixed my issue by removing the stored credential from Control Panel-->User Account-->Manage Windows credentials, and then remove the shared folder credential which is there already. then re map the drive again.

    You can reach that location simply searching for "Manage Windows credentials" in start menu.

    • Proposed as answer by Bobbie Roberts Tuesday, February 11, 2014 6:49 PM
    Tuesday, September 17, 2013 6:03 AM
  • Those windows credentials is what created this problem for me.  All the DNS was resolving properly.  Thanks Pokk1ri!
    Tuesday, February 11, 2014 6:50 PM
  • On my local network, I can type the ip address like so: \\xxx.xxx.xxx.xxx of a computer and access the shared files/printers of that computer.

    But when I try by computer name, it does not let me.  Any reason why?

    though this thread is very old but it help someone else, My issue was resolved by below

    1. Ipconfig /flushdns

    2. ipconfig /registerdns

    3. Goto... Control Panel > Administrative Tools > Local Security Policy > Local Policies > Security Options

    Scroll down to... Network Access: Sharing and security model for local accounts

    Select... Guest only and not Classic. I checked on XP machine and Guest seems to be the default.

    After going through all of that if you are still having file access problems try doing this registry adjustment on the Win 7 machine with the problem.

    3. Solution is really easy just modify one key in registry:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System
    create or modify 32-bit DWORD: LocalAccountTokenFilterPolicy
    set the value to: 1

    or

    REG ADD "HKLM\System\CurrentControlSet\Services\CSC\Parameters" /v FormatDatabase /t REG_DWORD /d 1

    Thanks...

    Monday, February 17, 2014 9:40 AM
  • That fix mine too, thank you!!!
    Thursday, May 01, 2014 7:18 PM
  • Thank you! Thank you!  Been looking everywhere for this issue.  Windows 7 SP1, Server 2012 R2 Essentials.
    Thursday, June 12, 2014 3:50 AM
  • Thanks Pokk1ri... I was facing the exact same issue as well. This issue was driving me up the wall, even had my IT staff look into it. Finally your solution is what saved the day.

    Many thanks,
    Sudeep

    Monday, April 27, 2015 11:06 AM

  • A simple way is go to host file and edit it and put your ip address with full name . the host file is in 

    C:\Windows\System32\drivers\etc (C is drive for windows)

    and edit with not pad then add fro example :

    192.168.1.1       Server1


    Dear Problems ,You May Big But My God Is Bigger.

    This is what helped me and how I solved this issue. Despite I was able to ping another computer in my home network in both ways - ping IP address and PC name, I was rejected when trying to access that computer.

    I edited host file (at the above location) adding the line 192.168.1.114  MyPCName and that was all.

    Friday, June 10, 2016 4:45 PM
  • Thank you,it worked for me.
    Thursday, July 20, 2017 9:09 AM
  • I had a similar issue. I wasn't able to ping any names, only IP's. DNS was apparently running in the background, ipconfig /displaydns was returning DNS queries, although telnet on port 53 was not working to the DNS server, I was receiving error "An invalid argument was supplied telnet on port 53" I was also able to log in with domain credentials.

    In my case the issue was with User Access Control. Somebody enabled it, and didn't reboot the server immediately after that action. Most probably some other actions were performed on the server, that were pending also reboot, and from that point UAC was acting recklessly not allowing users to perform basic actions, like pinging names or telneting the DNS server on port 53.

    I have noticed by chance, after century-old battles that lasted almost 2 days that I could not access directly (an access denied message was received)  one of the system folders, C:\Windows\temp. It is the normal behavior when UAC is enabled. I have checked before the UAC settings, and the slide bar was all the way down(disabled), but apparently this feature was still "live".

    I've enabled it back(moved the slide bar up), rebooted the server and that was it, everything went back to normal. I have disabled it again, afterwards, because we need it like that, and reboot immediately the server and things were also ok.

    So..UAC... a big NO for Microsoft ! 
    Thursday, September 14, 2017 12:42 PM
  • it helps, thanx a lot!

    Thursday, November 09, 2017 1:20 AM
  • I spent a lot of time trying these solutions and nothing worked.  But I finally discovered what my problem was: we recently got a new Internet service provider and our new router's LAN was classified by Windows 7 as a "Public network."  I changed it to "Work network" and now I can get to my computers using names again!  Too easy!


    • Proposed as answer by paleGreen1 Monday, November 27, 2017 8:06 PM
    • Unproposed as answer by paleGreen1 Monday, November 27, 2017 8:06 PM
    • Edited by paleGreen1 Monday, November 27, 2017 8:07 PM
    Monday, November 27, 2017 8:04 PM