none
SharePoint 2019 - income email RRS feed

  • Question

  • Hi, I'm trying to put income email to doc's library at SharePoint 2019-on-Prem.I do according to the this article-"Configure incoming email for a SharePoint Server farm"
    I already configured SMTP on IIS 6.0 at SP2019 server in a basic scenario and add SMTP connector to Exchange . Also "Enable sites on this server to receive e-mail" switched-on at Enable Incoming E-mail at ShP server. Also I allow'ed doc's library to recive e-mail and give an e-mail address.
    When i send a mail to that addres I see .eml file in inetpub\mailroot\Drop directory. But the letter is not transferred to the library. I checked Job History - Job "Microsoft SharePoint Foundation Incoming E-Mail" have Succeeded status. What have I not done or missed? Thanks
    • Edited by AlexSper Thursday, April 18, 2019 10:07 AM
    Thursday, April 18, 2019 10:07 AM

Answers

  • I found my mistake. The fact is that in my farm there are 2 servers - a frontend and an application server. The Microsoft SharePoint Foundation Incoming E-Mail service worked on the application server, but the SMTP server was deployed in the frontend. The error is very stupid. If I carefully looked at the task history, I would have found this error more quickly. I repeat, SMTP MUST be on the APPLICATION server

    All necessary accounts had the necessary permissions on the drop folder. But, on the wrong server. As soon as I set up the SMTP on the application server, where Incoming E-Mail service was active, everything worked exactly as it should have been.

    Thanks for help!

    • Marked as answer by AlexSper Monday, April 22, 2019 1:25 PM
    Monday, April 22, 2019 1:25 PM

All replies

  • Hi AlexSper,

    You can troubleshoot this issue as following:

    Start->Run->type “services.msc”, check if the SharePoint Timer Service is running. If so, restart it. And make sure the Timer service account has permission with the drop folder.

    In CA->configure in-coming email settings, change the incoming setting to “Automatic” mode to test whether it can work fine. Then change to “Advanced” mode with the same drop folder path “c:\inetpub\mailroot\drop”, and reset IIS.

    Here is a similar post for your reference:

    https://blogs.msdn.microsoft.com/george_bethanis/2012/05/25/sps2010-cannot-send-incoming-emails-to-listslibraries

    Best regards,

    Grace Wang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Friday, April 19, 2019 7:32 AM
  • I have SharePoint 2019. There is no “Automatic”/"Advanced" mode switcher in Incoming E-mail Settings

    Unfortunately, the advice from that post (https://blogs.msdn.microsoft.com/george_bethanis/2012/05/25/sps2010-cannot-send-incoming-emails-to-listslibraries) did not help me.

    Friday, April 19, 2019 3:13 PM
  • Hi AlexSper,

    Sorry for misleading. The Automatic mode is deprecated in SharePoint 2019 server.

    You can check the blog below to make sure you configure “Foreign Connector” in Exchange correctly. Make sure Exchange and the SharePoint Timer Service Account has full permissions in the drop folder.

    https://blogs.technet.microsoft.com/mikelee/2018/08/09/does-sharepoint-2019-still-need-the-smtp-service/

    Best regards,

    Grace Wang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Monday, April 22, 2019 8:14 AM
  • I found my mistake. The fact is that in my farm there are 2 servers - a frontend and an application server. The Microsoft SharePoint Foundation Incoming E-Mail service worked on the application server, but the SMTP server was deployed in the frontend. The error is very stupid. If I carefully looked at the task history, I would have found this error more quickly. I repeat, SMTP MUST be on the APPLICATION server

    All necessary accounts had the necessary permissions on the drop folder. But, on the wrong server. As soon as I set up the SMTP on the application server, where Incoming E-Mail service was active, everything worked exactly as it should have been.

    Thanks for help!

    • Marked as answer by AlexSper Monday, April 22, 2019 1:25 PM
    Monday, April 22, 2019 1:25 PM