none
How do I change the Querystring from "ID" to "CustomID" ? RRS feed

  • Question

  • In SharePoint 2010 I'm using a modified Out of the Box Feedback workflow which I've made cosmetic changes.

    When I initiate the workflow and assign it to someone they receive an email with a link to an item in the list. Clicking on the link generates the error:

    No item exists <url>/dispform.aspx?ID=112. It may have been deleted or renamed by another user.

    The solution from Microsoft states  "Change the query string parameter from ID to CustomID. Then change the details page from QueryString(ID) to QueryString(CustomID). Once this is done the page will display with no errors."

    I understand the jist of the solution which is to not use the field "ID" in SharePoint because it's used for other things and it won't resolve properly but where do I change it? It's not explicit and I'm not a developer. I have been struggling with this for some time and even my experienced Devs have no idea what I'm talking about since it's so SharePoint centric... Is anyone versed in SP willing to help me out on this? Very much appreciated!

    Tim.


    • Edited by Rookpawn Tuesday, March 26, 2019 7:23 PM
    Tuesday, March 26, 2019 7:13 PM

All replies


  • Hi Rookpawn, 

    I have done a test in my SharePoint and i cannot reproduce your issue. I can open the link to an item from email. 

    If you copy the  <url>/dispform.aspx?ID=112, and then open the  <url>/dispform.aspx?ID=112 from browser directly, can you open it successfully?

    Make sure the item have not be deleted or renamed.   

    Best Regards, 

    Lisa Chen 



    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Wednesday, March 27, 2019 8:47 AM
    Moderator
  • Thanks for the reply Lisa! You're awesome.

    When I use the url provided in the email it won't display but if I modify ID to literally anything like TESTID it comes up. I don't know where to change it so it doesn't pass "ID" in the url but something else like dispform.aspx?TESTID=112.

    I should mention that I have the setting for "Read items that were created by the user" so that only the person who completed my online form can see their own items saved to the list.

    When I initiate the workflow and assign an item to someone else it won't come up because they didn't create it and thus don't have permission to view it.

    I tested turning off that setting and the email link works however I don't want all users to see everyone's submissions in that list on the allitems.aspx page.

    so I'm not sure where the solution lies 1. fixing the query string like Microsoft recommends by changing the ID value to something else? or 2. fixing permissions in my list so when I assign an item created by someone else to a user using workflow it's visible to them..

    Wednesday, March 27, 2019 1:49 PM