none
Fim Synchronization Error - Event ID : 6801 - How to resolve in existing farm ? RRS feed

  • Question



  • Hello,


    I'm trying to run synchronizing user profile (FIM 2016), 
    When you run SPMA it will return the following errors:

    Someone knows what may be wrong.


    Level: Error

    Source: FIMSynchronizationService

    Event ID: 6801

    Task Category: Server   

    Message: 

    The extensible extension returned an unsupported error.
     The stack trace is:
     
     "System.Net.WebException: The request failed with HTTP status 401: Unauthorized.
       at Microsoft.IdentityManagement.Connector.Sharepoint.SharepointConnector.GetSchema(KeyedCollection`2 configParameters)
    Forefront Identity Manager 4.4.1302.0"
    Thursday, June 8, 2017 2:49 PM

Answers

  • Is MIM on the same server as SharePoint? If so use the IP of the server in the SPMA connection


    If this is helpful please mark it so. Also if this solved your problem mark as answer.


    Friday, June 9, 2017 7:40 AM
    Moderator

All replies

  • I moved this to the SP 2016 forums since I'm assuming you're using MIM in conjunction with SharePoint 2016.

    Did you grant the account connecting back to SharePoint with Full Control/Administrator rights to the UPSA?


    Trevor Seward

    Office Servers and Services MVP



    Author, Deploying SharePoint 2016

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Thursday, June 8, 2017 2:58 PM
    Moderator
  • I moved this to the SP 2016 forums since I'm assuming you're using MIM in conjunction with SharePoint 2016.

    Did you grant the account connecting back to SharePoint with Full Control/Administrator rights to the UPSA?


    Trevor Seward

    Office Servers and Services MVP



    Author, Deploying SharePoint 2016

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    yes, user with full control in UPSA

    when I run sync command powershell it generates this error in the fim and in the eoor log windows:



    Thursday, June 8, 2017 4:33 PM
  • Is MIM on the same server as SharePoint? If so use the IP of the server in the SPMA connection


    If this is helpful please mark it so. Also if this solved your problem mark as answer.


    Friday, June 9, 2017 7:40 AM
    Moderator
  • Hi,

    SharePoint Server 2016 no longer uses FIM as the synchronization client. The default process is Active Directory Import. As Trevor's reply, you can use Microsoft Identity Manager 2016(MIM) to achieve it.

    What's deprecated or removed from SharePoint Server 2016

    https://technet.microsoft.com/en-us/library/mt346112(v=office.16).aspx

    More information about MIM is here:

    https://jerryyasir.wordpress.com/tag/sharepoint-2016sp2016-step-by-stepmim/

    Best Regards,

    Dennis


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Friday, June 9, 2017 8:57 AM
    Moderator
  • Hi,

    SharePoint Server 2016 no longer uses FIM as the synchronization client. The default process is Active Directory Import. As Trevor's reply, you can use Microsoft Identity Manager 2016(MIM) to achieve it.

    What's deprecated or removed from SharePoint Server 2016

    https://technet.microsoft.com/en-us/library/mt346112(v=office.16).aspx

    More information about MIM is here:

    https://jerryyasir.wordpress.com/tag/sharepoint-2016sp2016-step-by-stepmim/

    Best Regards,

    Dennis


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Hi Dennis,
    I used this article:
    Https://jerryyasir.wordpress.com/tag/sharepoint-2016sp2016-step-by-stepmim/
    to configure the server.
    Friday, June 9, 2017 11:46 AM
  • Hi Ewerton,

    I have the same problem. Did you find any solution?

    Monday, December 4, 2017 12:16 PM
  • Got the same error.

    Testsystem:

    • one server (SharePoint 2019 Preview, SQL Server 2017, MIM 2016 SP1)
    • one account as farm-admin (used in all installation steps and provisions)

    Tried ip instead of hostname also, did not work.

    Event-Log:

    The extensible extension returned an unsupported error.
     The stack trace is:
     
     "System.Web.Services.Protocols.SoapException: Server was unable to process request. ---> Attempted to perform an unauthorized operation.
       at Microsoft.IdentityManagement.Connector.Sharepoint.SharepointConnector.OpenImportConnection(KeyedCollection`2 configParameters, Schema schema, OpenImportConnectionRunStep importRunStep)
    Forefront Identity Manager 4.4.1302.0"
    Thursday, October 11, 2018 10:15 AM
  • Also, in the SPMA the user credential cannot be changed or re-entered -> "Attempted to perform an unauthorized operation".

    Only with the "Install-SharePointSyncConfiguration"-command, the login seems to work, but not when the export process will be started.


    Thursday, October 11, 2018 10:19 AM
  • It sounds like you have a misconfiguration, e.g. the SPMA connector credentials do not have access to the UPSA and/or MySite User Photo library.

    Trevor Seward

    Office Servers and Services MVP



    Author, Deploying SharePoint 2016

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Thursday, October 11, 2018 2:49 PM
    Moderator
  • Found the problem: at the installation of the management agent i did not used the url for the "Central Admin".

    The name of the parameter "SharePointUrl" is a bit misleading imho.

    Friday, October 12, 2018 6:05 AM