Updating solution is not working - how do you use Update-SPSolution? RRS feed

  • Question

  • Hi. There is something wrong with Update-SPSolution, Im not able to Update a new solution.

    Im using C# to create a new .wsp file. Then I use Update-SPSolution to update the same .wsp that I installed before with:

    Add-SPSolution $solution

    Install-SPFeature "mySolution"

    Enable-SPFeature -Identity mySolution

    And after an update there is still no change on the sharepoint site. But I changed a lot of stuff, so there should be a change. The anoying thing is, that powershell is not droping any error messages, for powershell is everything fine with:

    Update-SPSolution –Identity $solution –LiteralPath $solutionpath –GacDeployment
    So every .wsp file that Im updating with new stuff is not on the sharepoint site. Somehow I have the feeling that powershell is updating the .wsp from the cache, because if I deploy on another system with SP2010 my updated .wsp file I see the changes on the site. So the problem is not with the .wsp file, the problem is with Update-SPSolution. Is this working for you guys? Whats the secret? I tried also to reinstall the new updated solution and reactivate the features to see some changes (with -force or with disable and then enable again an spfeature) but its not helping. I tried an iisreset, deleting gac - not helping. Any ideas? Even with deleting the solution and installing it again with the new .wsp file (Uninstall-SPSolution and Remove-SPSolution) i still got the old site. If I install the same .wsp on another clear sp server the changes are there. So thats why I think that Im installing again and again the old .wsp from the cache, but where is this cache? Any ideas? Thank you

    Sunday, April 15, 2012 10:24 PM


  • Hi,

    In your Objects table under config database search for this wsp file and check the text to verify if this is getting updated or not.

    Then clear the config cache and upgrade it again followed by an IISRESET.

    I hope this will help you out

    Thanks, Rahul Rashu

    Tuesday, April 17, 2012 2:33 AM

All replies