none
Mailboxes in move process during a Dirty Shutdown event are now stuck at WaitingForJobPickup status RRS feed

  • Question

  • We are migrating from Exchange 2010 to Exchange 2016. During one of the migrations the database dismounted into a dirty shutdown state. Used Eseutil /r to repair database and following defrag and integrity check was able to mount. Everything shows as being in a healthy state. However, the mailboxes being moved during the dirty shutdown event are showing through Get-MoveRequestStatistics as Status: WaitingForJobPickup and any new move request for these boxes fails. Is there a way to clear these move requests out in order to migrate these mailboxes?
    Saturday, July 13, 2019 9:26 PM

All replies

  • We are migrating from Exchange 2010 to Exchange 2016. During one of the migrations the database dismounted into a dirty shutdown state. Used Eseutil /r to repair database and following defrag and integrity check was able to mount. Everything shows as being in a healthy state. However, the mailboxes being moved during the dirty shutdown event are showing through Get-MoveRequestStatistics as Status: WaitingForJobPickup and any new move request for these boxes fails. Is there a way to clear these move requests out in order to migrate these mailboxes?

    Remove-moverequest doesnt work?

    Saturday, July 13, 2019 9:34 PM
    Moderator
  • Hi Tyler,

    Except above suggestion, you can also try to run "Suspend-MoveRequest" and "Resume-MoveRequest" cmdlets to resume this move request, and then check if any helps.

    If still does not work, try to remove the request by using adsiedit tool, then check the result:

    ADSIEdit.msc > Connect to > Default Naming Context > DC={your domain}, DC={your domain extension} > Navigate to the user affected > Properties > Filter > Show only attributes that have values > Locate the following two values and clear them: 

    • msExchMailboxMoveFlags
    • msExchMailboxMoveStatus


    Best Regards,
    Niko Cheng


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Monday, July 15, 2019 6:17 AM
    Moderator
  • Hi Tyler,

    I'm just writing to check how's everything going? If you have any questions or needed further help on this issue, please feel free to post back. If the issue has been resolved, please mark the helpful replies as answers, this will make answer searching in the forum easier and be beneficial to other community members as well.

    Thanks for your understanding.


    Best Regards,
    Niko Cheng


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com

    Tuesday, July 23, 2019 9:58 AM
    Moderator