none
Word 2010 Spell Checker not working on a specific document

    Question

  • I'm using Office 2010 in XP Pro. In my current Word 2010 document the spell checker quit working. Spell checker works fine if I start a new document. I've had this happen before. Somehow the Spell Checker gets turned off for a specific document even though all the check boxes are fine. "What causes this? How do I prevent it? How do I get Spell Checker started again in a specific document where it has quit working? File/Info/Options/Proofing: "check spelling as you type" is checked.
    Thursday, April 28, 2011 5:30 AM

Answers

  • Hi

     

    Thank you for using Microsoft Office for IT Professionals Forums.

     

    From your description, I understand that Spell Check feature in Word 2010. If there is any misunderstanding, please feel free to let me know.

     

    This issue may occur for any one of several reasons: 

    • The Speller EN-US add-in is disabled.
    • The following entry is present in the registry:

    HKEY_CURRENT_USER\Software\Microsoft\Shared Tools\ProofingTools\1.0\Override\en-US

    • The Do not check spelling or grammar check box is selected.
    • Proofing tools are not installed.

     

    You can follow this Knowledge Base article to troubleshoot this issue:

    The spelling checker does not flag misspelled words in Word 2007 and in Word 2010

    http://support.microsoft.com/kb/970826

     

    Please take your time to try the suggestions and let me know the results at your earliest convenience. If anything is unclear or if there is anything I can do for you, please feel free to let me know.

     

    Hope that helps.

     

    Sincerely

    William Zhou CHN
    Monday, May 2, 2011 1:04 AM
    Moderator

All replies

  • Hi

     

    Thank you for using Microsoft Office for IT Professionals Forums.

     

    From your description, I understand that Spell Check feature in Word 2010. If there is any misunderstanding, please feel free to let me know.

     

    This issue may occur for any one of several reasons: 

    • The Speller EN-US add-in is disabled.
    • The following entry is present in the registry:

    HKEY_CURRENT_USER\Software\Microsoft\Shared Tools\ProofingTools\1.0\Override\en-US

    • The Do not check spelling or grammar check box is selected.
    • Proofing tools are not installed.

     

    You can follow this Knowledge Base article to troubleshoot this issue:

    The spelling checker does not flag misspelled words in Word 2007 and in Word 2010

    http://support.microsoft.com/kb/970826

     

    Please take your time to try the suggestions and let me know the results at your earliest convenience. If anything is unclear or if there is anything I can do for you, please feel free to let me know.

     

    Hope that helps.

     

    Sincerely

    William Zhou CHN
    Monday, May 2, 2011 1:04 AM
    Moderator
  • The only thing I hadn't done from above and the kb article is check "Expand Office Shared Feature... click Run all from My Computer". It had been set to "run from my computer". I changed it, maybe that will be the fix. The problem was intermittent, sometimes the spell checker worked, other times not (in the same document). Fortunately, that document's out the door.

    thanks for the help,

    Steve
    Steve
    Wednesday, May 4, 2011 3:43 AM
  • I have tried everything and it still does not fix the problem. I am working off Windows 7. PLEASE help
    Tuesday, February 14, 2012 5:13 PM
  • I have tried everything and it still does not fix the problem. I am working off Windows 7. PLEASE help

    I have the same problem. I open and new document and type 'asdsdaa' and spell check picks it up. Yet if I use one particular document and type the same nothing is picked up.

    It's crazy!

    • Proposed as answer by DJ_Lewis Monday, February 27, 2012 4:59 PM
    • Unproposed as answer by DJ_Lewis Monday, February 27, 2012 4:59 PM
    Monday, February 27, 2012 4:53 PM
  • I have tried everything and it still does not fix the problem. I am working off Windows 7. PLEASE help

    I have the same problem. I open and new document and type 'asdsdaa' and spell check picks it up. Yet if I use one particular document and type the same nothing is picked up.

    It's crazy!


    Solved it. I have just tried Method 4: again (after running all Methods) and it works 
    • Proposed as answer by SPM2012 Friday, September 27, 2013 3:12 PM
    Monday, February 27, 2012 5:00 PM
  • Copy and paste the whole doc on a blank new sheet, then the checker will work again. It worked at least for me.
    Wednesday, August 16, 2017 11:21 PM