locked
An unrecognized HTTP response was received when attempting to crawl this item. Verify whether the item can be accessed using your browser. RRS feed

  • Question

  • I have 2 WFE behing F5 that handles ssl termination too. I have a site abc.xyz.com.

    At aam i have

    http://abc.xyz.com in default zone and https://abc.xyz.com in internal zone.

    AT sharepoint content source; I have both http and https of the above site version.

    DNS entry of abc.xyz.com is pointing at VIP in f5 which load balances this site at 2 different ips assigned to each web front end server.

    Now when i run search in this content source, searchable item populates but there is error for http request telling An unrecognized HTTP response was received when attempting to crawl this item. Verify whether the item can be accessed using your browser. Why is this happening?

    Is it because requests are coming to f5 as https but search is returning it as http? Will SSL termination removal from f5 solve this issue which i really don't want to do? Will pointing dns entry to two ips in wfe instead of f5 VIP will work?


    Adit

    Friday, September 27, 2013 8:18 PM

Answers

All replies

  • Hi,

    I have seen a similar post from you, my understanding is that when you ran search in your content source, there was an error. You can take a look at the following thread:

    http://social.technet.microsoft.com/Forums/en-US/94e999e3-4128-4674-97dc-e46e71fe0f46/search-service-setup-behind-f5-an-unrecognized-http-response-was-received-when-attempting-to-crawl

    Best Regards,

    Wendy


    Wendy Li
    TechNet Community Support

    Monday, September 30, 2013 10:00 AM
  • Have you done everything right in AAM of central admin? Please follow the following link and do as instructed . May be that will help. That helped me

    .www.f5.com/pdf/deployment-guides/f5-sharepoint-2010-dg.pdf


    sachin

    • Marked as answer by New-SPAdmin Monday, September 30, 2013 7:02 PM
    Monday, September 30, 2013 2:23 PM
  • Hi all,

    I ran into similar problems and tried everything - from disabling loopback check to ignoring ssl warnings, checking crawl account permissions - I even went so far as to totally delete my search service application and rebuild it from scratch... TWICE!! Nothing seemed to help.

    In the end, I found out that the AutoSPInstaller that I used to install my SP farm with (after I had edited it extensively) had added some lines to my hosts file (find it in c:\windows\system32\Drivers\etc\) that basically told my server that every one of my four web applications redirected to 127.0.0.1

    I commented out these lines, checked the bindings of my different sites and certificates in IIS, and added the proper IP-addresses in the hosts file. Rebooted my server, and, as Sheldon would put it: Bazinga!

    No errors crawling, and I also have the possibility (though not the urge) to access my web-applications directly from my front-end server.

    To whomever it concerns: hope this little added info helps.

    • Proposed as answer by Xmantra Monday, February 9, 2015 5:09 PM
    Friday, February 6, 2015 10:25 AM
  • Hi all,

    I ran into similar problems and tried everything - from disabling loopback check to ignoring ssl warnings, checking crawl account permissions - I even went so far as to totally delete my search service application and rebuild it from scratch... TWICE!! Nothing seemed to help.

    In the end, I found out that the AutoSPInstaller that I used to install my SP farm with (after I had edited it extensively) had added some lines to my hosts file (find it in c:\windows\system32\Drivers\etc\) that basically told my server that every one of my four web applications redirected to 127.0.0.1

    I commented out these lines, checked the bindings of my different sites and certificates in IIS, and added the proper IP-addresses in the hosts file. Rebooted my server, and, as Sheldon would put it: Bazinga!

    No errors crawling, and I also have the possibility (though not the urge) to access my web-applications directly from my front-end server.

    To whomever it concerns: hope this little added info helps.

    What do you mean by "I commented out these lines, checked the bindings of my different sites and certificates in IIS, and added the proper IP-addresses in the hosts file " ??Can you please elaborate ?

    I am having the same issue and I tried everything you mentioned. Please help


    thanks, vinod

    Friday, July 24, 2015 7:20 PM
  • Hi all,

    I ran into similar problems and tried everything - from disabling loopback check to ignoring ssl warnings, checking crawl account permissions - I even went so far as to totally delete my search service application and rebuild it from scratch... TWICE!! Nothing seemed to help.

    In the end, I found out that the AutoSPInstaller that I used to install my SP farm with (after I had edited it extensively) had added some lines to my hosts file (find it in c:\windows\system32\Drivers\etc\) that basically told my server that every one of my four web applications redirected to 127.0.0.1

    I commented out these lines, checked the bindings of my different sites and certificates in IIS, and added the proper IP-addresses in the hosts file. Rebooted my server, and, as Sheldon would put it: Bazinga!

    No errors crawling, and I also have the possibility (though not the urge) to access my web-applications directly from my front-end server.

    To whomever it concerns: hope this little added info helps.

    What do you mean by "I commented out these lines, checked the bindings of my different sites and certificates in IIS, and added the proper IP-addresses in the hosts file " ??Can you please elaborate ?

    I am having the same issue and I tried everything you mentioned. Please help


    thanks, vinod

    I believe he means he used the Dedicated Crawl Target Server IP address in the Hostname of Crawl Servers or remove the hostname (which means it will go thru F5 now instead of going through the crawl server itself). Check the AAM settings.It happens when the AAM settings in misconfigured. 127.0.0.1 is a default IP address of the server.The AAM settings in CA (if you are using https and is terminating SSL at F5 level) should be:

    Internal URL                                                Public URL

    https://urweburl                                          https://urweburl

    http://urweburl                                           https://urweburl

    Both are on default zone.

    Do the index reset and run the full crawl on that content cource. This should resolve your issue.

    If you have found other solutions, let us know.

    Thanks,

    Binayak


    • Edited by Binayak Joshi Monday, July 27, 2015 7:39 PM needs to be in default zone
    Monday, July 27, 2015 7:37 PM
  • Hi Vinod,

    I hope this reaches you in time - been on vacation, so sorry for the late reply.

    Navigate to "c:\windows\system32\Drivers\etc\" and right-click the 'hosts' file;

    select 'edit'

    put a # before the lines that read '127.0.0.1 [url of your web application]' - leave the file open

    open IIS, select your server, and expand 'sites'

    select the site (webapplication) for which the url in the hosts file was set to 127.0.0.1 by single clicking is

    in the 'Actions' pane (right hand side of the page), under 'Edit Site' click 'Bindings'

    from the dialog box, note down the IP address

    Go back to the 'Hosts' file, that you left open, and simply enter the ip address followed by a tab (for readability) and the url of your web application, at the end of the file

    Repeat this for any other web applications

    save and close the 'hosts' file.

    I don't remember if restarting IIS was enough, or whether I had to reboot the server - either way, this did the trick for me.

    Goodluck!

    Monday, August 17, 2015 11:29 AM